Список библиотек DLL запущенный под процесс Outlook.exe с помощью Process Explorer

Поддержка Office 2003 завершена

8 апреля 2014 г. корпорация Майкрософт прекратила поддержку Office 2003. Это повлияло на обновления программного обеспечения и параметры безопасности. Узнайте, что это значит для вас и какие меры по безопасности можно предпринять.

ВНИМАНИЕ! Данная статья переведена с использованием программного обеспечения Майкрософт для машинного перевода и, возможно, отредактирована посредством технологии Community Translation Framework (CTF). Корпорация Майкрософт предлагает вам статьи, обработанные средствами машинного перевода, отредактированные членами сообщества Майкрософт и переведенные профессиональными переводчиками, чтобы вы могли ознакомиться со всеми статьями нашей базы знаний на нескольких языках. Статьи, переведенные с использованием средств машинного перевода и отредактированные сообществом, могут содержать смысловое, синтаксические и (или) грамматические ошибки. Корпорация Майкрософт не несет ответственности за любые неточности, ошибки или ущерб, вызванные неправильным переводом контента или его использованием нашими клиентами. Подробнее об CTF можно узнать по адресу http://support.microsoft.com/gp/machine-translation-corrections/ru.

Эта статья на английском языке: 970920
Источник: Служба технической поддержки Майкрософт
БЫСТРАЯ ПУБЛИКАЦИЯ.
СТАТЬИ ИЗ СЕРИИ "БЫСТРАЯ ПУБЛИКАЦИЯ" ПРЕДОСТАВЛЯЮТ СВЕДЕНИЯ НЕПОСРЕДСТВЕННО ИЗ СЛУЖБЫ ПОДДЕРЖКИ МАЙКРОСОФТ. СВЕДЕНИЯ, СОДЕРЖАЩИЕСЯ В НАСТОЯЩЕМ ДОКУМЕНТЕ СОЗДАЕТСЯ В ОТВЕТ НА НОВЫХ ИЛИ УНИКАЛЬНЫЕ ТЕМЫ, ИЛИ ДОПОЛНЯЮТ ДРУГИЕ СВЕДЕНИЯ БАЗЫ ЗНАНИЙ.
Симптом
Process Explorer — это программа, которая предоставляет сведения о какой дескрипторов и библиотек DLL каждый процесс имеет открыть. В контексте устранения неполадок в Outlook Process Explorer обычно используется для определения Если у вас есть любые библиотеки DLL независимых производителей, под процесс Outlook.exe. Это важный шаг, как он вызывает вероятность того, что надстройки или другие программы на компьютере могут быть причиной проблем в Outlook.

В этой статье приводятся сведения о использовании Process Explorer для вывода всех dll-файлов выполняется в процессе Outlook.exe.
Причина
Решение
Дополнительные сведения


Получение Process Explorer

Первым делом для получения последней версии Process Explorer. Ее можно загрузить с узла Microsoft TechNet по адресу:

http://TechNet.Microsoft.com/en-US/Sysinternals/bb896653.aspx

Обязательно ознакомьтесь с информацией на этой странице представить себе этот инструмент.


Работающих процессах проводника

После загрузки и извлечения Process Explorer, выполните следующие действия, чтобы собрать список библиотек DLL, запущенные под процесс Outlook.exe.

1. Запустите Outlook.

2. Дважды щелкните Procexp.exe запустить Process Explorer.

3. в меню Вид убедитесь, что установлен флажок «Показать нижнюю область».

4. Нажмите CTRL + D или нажмите кнопку - представление нижней области — представление библиотеки DLL, чтобы включить режим просмотра библиотеки DLL.

5. в верхней области Process Explorer прокрутите вниз список файлов, а затем выберите Outlook.exe.

6. после списка библиотек DLL, работающим в Outlook.exe перечислены в нижней части окна, выберите команду Сохранить как в меню файл.

7. Сохраните файл с именем Outlook.exe.txt.


Анализ выходных данных процесса Explorer

В выходной текстовый файл является табуляцией текстового файла, лучше всего открыть в Microsoft Excel, можно использовать функцию фильтра позволяет быстро находить все библиотеки DLL сторонних загрузки.

1. Запустите Microsoft Office Excel и откройте Outlook.exe.txt.

2. в мастере импорта текста используйте следующие параметры:
•Delimited
•TAB разделитель
Формат данных столбца Общие •
3. прокрутите лист вниз и найдите следующую строку:

Название компании описание имя версия

Это список всех библиотек DLL (корпорации Майкрософт и сторонних производителей), работающим в процесс Outlook.exe.

4. Выберите ячейку с «Имя» над списком библиотек DLL, а затем включите функцию фильтрации.

5. нажмите кнопку раскрывающегося списка фильтра в поле имя, а затем настройте текстовый фильтр со следующими параметрами:

Имя – содержит - .dll

6. Выберите фильтр раскрывающегося списка в поле название компании, а затем снимите флажки, содержащий «Microsoft».


Определение Microsoft и третья сторона библиотеки DLL

Третья сторона файлы DLL, запускаемые Outlook содержит отфильтрованный список библиотек DLL, отображаются с помощью действий, описанных выше. Столбец имя компании для определения поставщика, ответственного за dll-файла можно проверить.

В списке фильтров библиотеки DLL также существуют некоторые DLL-библиотек, поставляемых с Outlook, не отображаются в столбце Имя компании «Microsoft». Чтобы определить эти библиотеки DLL Microsoft, выполните следующие действия:


Outlook 2010

1. Запустите Outlook 2010.

2. Перейдите на вкладку файл на ленте, а затем нажмите кнопку Параметры.

3. в диалоговом окне параметры Outlook выберите команду надстройки.

4. Чтобы проверить надстройки COM, выберите в раскрывающемся списке управление COM-надстройки и нажмите кнопку Перейти.

5. Выберите все надстройки в диалоговом окне надстройки COM и проверьте имя файла .dll в месте: сведения в нижней части диалогового окна. Имя надстройки должен сообщить, если dll-файла осуществляется корпорацией Майкрософт.


Outlook 2007

1. Запустите Outlook 2007.

2. в меню Сервис выберите центр управления безопасностью.

3. в центре управления безопасностью нажмите кнопку надстройки.

4. Чтобы проверить надстройки COM, выберите в раскрывающемся списке управление COM-надстройки и нажмите кнопку Перейти.

5. Выберите все надстройки в диалоговом окне надстройки COM и проверьте имя файла .dll в месте: сведения в нижней части диалогового окна. Имя надстройки должен сообщить, если dll-файла осуществляется корпорацией Майкрософт.


Outlook 2003 и более ранних версий

1. Запустите Outlook 2003.

2. в меню Сервис выберите команду Параметры.

3. на вкладке Дополнительно нажмите кнопку Дополнительные параметры.

4. нажмите кнопку "COM-надстройки".

5. Выберите все надстройки в диалоговом окне надстройки COM и проверьте имя файла .dll в месте: сведения в нижней части диалогового окна. Имя надстройки должен сообщить, если dll-файла осуществляется корпорацией Майкрософт.


ОТКАЗ ОТ ОТВЕТСТВЕННОСТИ
КОРПОРАЦИЯ МАЙКРОСОФТ И ЕЕ ПОСТАВЩИКИ НЕ ДЕЛАЮТ НИКАКИХ УТВЕРЖДЕНИЙ ИЛИ НИКАКИХ ГАРАНТИЙ О ПРИГОДНОСТИ, НАДЕЖНОСТЬ И ТОЧНОСТЬ СВЕДЕНИЙ, СОДЕРЖАЩИХСЯ В ДОКУМЕНТАХ И СВЯЗАННЫЕ РИСУНКИ ОПУБЛИКОВАНЫ НА ВЕБ-САЙТЕ ("МАТЕРИАЛЫ") ДЛЯ ЛЮБЫХ ЦЕЛЕЙ. МАТЕРИАЛЫ МОГУТ СОДЕРЖАТЬ ТЕХНИЧЕСКИЕ НЕТОЧНОСТИ ИЛИ ОПЕЧАТОК И МОЖЕТ БЫТЬ ИЗМЕНЕН В ЛЮБОЕ ВРЕМЯ БЕЗ ПРЕДВАРИТЕЛЬНОГО УВЕДОМЛЕНИЯ.

В МАКСИМАЛЬНОЙ СТЕПЕНИ, ДОПУСКАЕМОЙ ПРИМЕНИМЫМ ЗАКОНОДАТЕЛЬСТВОМ, КОРПОРАЦИЯ МАЙКРОСОФТ И ЕЕ ПАРТНЕРАМ ОТКАЗЫВАЮТСЯ ОТ И ИСКЛЮЧИТЬ ВСЕ ПРЕДСТАВЛЕНИЯ, ГАРАНТИИ И УСЛОВИЯ ЯВНЫЕ, КОСВЕННЫЕ ИЛИ УСТАНОВЛЕННЫЕ ЗАКОНОМ, ВКЛЮЧАЯ, НО НЕ ОГРАНИЧИВАЯСЬ ПРЕДСТАВЛЕНИЯ, ГАРАНТИИ ИЛИ УСЛОВИЯ ПРИНАДЛЕЖНОСТИ ПРАВА, НЕ НАРУШЕНИЯ ПРАВ ИНЫХ ПРАВООБЛАДАТЕЛЕЙ, НАДЛЕЖАЩЕГО СОСТОЯНИЯ ИЛИ КАЧЕСТВА, ТОВАРНОЙ ПРИГОДНОСТИ И ПРИГОДНОСТИ ДЛЯ ОПРЕДЕЛЕННОЙ ЦЕЛИ, ПО ОТНОШЕНИЮ К МАТЕРИАЛАМ.
ol2010 ol2007 ol2003 ol2002 olxp sysinternals
Примечание. Это ЭКСПРЕСС-ПУБЛИКАЦИЯ, подготовленная непосредственно службой технической поддержки Майкрософт . Сведения, содержащиеся в данном документе, предоставлены в качестве отклика на возникшие проблемы. Из-за срочности в материалах могут быть опечатки, и в любое время и без уведомления в них могут быть внесены изменения. Чтобы получить дополнительные сведения, см. Условия использования.
Свойства

Номер статьи: 970920 — последний просмотр: 07/25/2015 15:18:00 — редакция: 5.0

Microsoft Office Outlook 2003, Microsoft Office Outlook 2007, русская версия

  • kbrapidpub kbnomt kbmt KB970920 KbMtru
Отзывы и предложения