Вставка юлианских дат (функций)

Юлианский день иногда используется для обозначения формата даты, который является сочетанием текущего года и количества дней с начала года. Например, 1 января 2007 г. представлен как 2007001, а 31 декабря 2007 г. — как 2007365. Обратите внимание, что этот формат не основан на юлианском календаре.

Кроме того, в астрономии, которая является последовательной системой дат с 1 января 4713 г. до н. э., также используется юлианская дата.

Для следующих процедур требуется вырезание и вкавка примера. Вот как это сделать:

Копирование примера

  1. Создайте пустую книгу или лист.

  2. Выделите пример в разделе справки.

    Примечание: Не выделяйте заголовки строк или столбцов.

    Выделение примера из справки

    Выделение примера в справке

  3. Нажмите клавиши CTRL+C.

  4. Выделите на листе ячейку A1 и нажмите клавиши CTRL+V.

  5. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (знак ударения) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показывать формулы.

Введите сегодня как юлианский день

Для этой задачи используются функции ТЕКСТ,СЕГОДНЯи ДАТА.ДАТА.ВЕСЯ.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

1

2

3

A

B

Формула

Описание (результат)

=ТЕКСТ(СЕГОДНЯ() ;"yy")&TEXT((TODAY() -DATEVALUE("01.01.2001"&ТЕКСТ(СЕГОДНЯ();"yy"))+1);"000")

Текущий день в юлианском формате с двузначным номером года (меняется)

=ТЕКСТ(СЕГОДНЯ() ;"yyyy")&TEXT((TODAY() -DATEVALUE("1.01."&ТЕКСТ(СЕГОДНЯ();"yy"))+1);"000")

Текущий день в юлианском формате с четырехзначным номером года (меняется)

Примечания: 

  • Текущая дата взята из системных часов компьютера.

  • В формулах выше год начинается 1 января (1/1). Чтобы преобразовать формулы в другую даты начала, отредактировать часть "1/1/" до нужной даты.

Преобразование даты в юлианский

Для этой задачи используются функции ТЕКСТ и ДАТАVALUE.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

1

2

A

Дата

23.6.2007

Формула

Описание (результат)

=ТЕКСТ(A2;"yy")&ТЕКСТ((A2-ДАТАЦЕНА("1.1."&ТЕКСТ(A2;"yy"))+1);"000")

Дата выше в юлианском формате с двузначным номером года (07174)

=ТЕКСТ(A2;"yyyy")&TEXT((A2-DATEVALUE("1.01."&ТЕКСТ(A2;"yy"))+1);"000")

Дата выше в юлианском формате с четырехзначным номером года (2007174)

Примечание:  В формуле выше год начинается 1 января (1/1). Чтобы преобразовать формулы в другую даты начала, отредактировать часть "1/1/" до нужной даты.

Преобразование даты в юлианский день, использованный в астрономии

Эта формула работает только с датами после 01.03.1901 и в книгах с системой дат 1900.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

1

2

A

Дата

23.6.2007

Формула

Описание (результат)

=A2+2415018,50

Первая дата выше в юлианском формате даты, применяемом в астрономии (28.07.8619)

Примечание: Даты можно отформатть как числа. Вы выберите ячейку, а затем на вкладке "Главная" в группе "Число" щелкните стрелку и выберите "Число".

Нужна дополнительная помощь?

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×