ЗНАЧПОЛЯ (функция)

С помощью функции ЗНАЧПОЛЯ можно извлечь данные из поля со связанным типом данных, например Stocks (Акции) или Geography (География). Существуют и более простые способы создания формул, которые ссылаются на типы данных, поэтому функцию ЗНАЧПОЛЯ следует использовать в основном для создания условных вычислений на основе связанных типов данных.

Примечание: 28 марта 2019 г.: типы данных были выпущены для всех подписчиков Windows Microsoft 365. Если вы являетесь подписчиком Microsoft 365, убедитесь, что у вас установлена последняя версия Office.

Технические подробности

Синтаксис

= ЗНАЧПОЛЯ(значение; имя_поля)

Аргументы функции ЗНАЧПОЛЯ описаны ниже.

Аргумент

Описание

значение

Функция возвращает все совпадающие поля из связанного типа данных, указанного в аргументе "значение".

имя_поля

Одно или несколько имен полей, которые вы хотите извлечь.

Описание

  • Функция ЗНАЧПОЛЯ возвращает все совпадающие поля из связанного типа данных, указанного в аргументе "значение".

  • Функция ЗНАЧПОЛЯ относится к семейству Ссылки и массивы.

Примеры

В приведенном ниже базовом примере формула =ЗНАЧПОЛЯ(A2;"Price") извлекает поле Price из биржевых данных для JM Smucker Co.

Получение цены акций компании: =ЗНАЧПОЛЯ(A2;"Price")

Следующий пример — более типичный пример использования функции ЗНАЧПОЛЯ. В нем мы используем функцию ЕСЛИОШИБКА для проверки на наличие ошибок. Если в ячейке A2 нет названия компании, формула ЗНАЧПОЛЯ возвращает ошибку и ничего не отображает (""). Но если название компании указано, мы получаем цену из типа данных в ячейке A2, используя формулу =ЕСЛИОШИБКА(ЗНАЧПОЛЯ($A2;B$1);"").

Получение цены акций компании и пропуск ошибок: =ЕСЛИОШИБКА(ЗНАЧПОЛЯ($A2;B$1);"")

Обратите внимание на то, что функция ЗНАЧПОЛЯ позволяет ссылаться на ячейки листа в аргументе "имя_поля", поэтому в формуле указана ссылка на ячейку B1, а не "Price". 

Замечания

При попытке получить данные из несуществующего поля типа функцияА возвращает ошибку #FIELD!.. Например, вы могли ввести "Цены", если фактическое поле типа данных называется "Цена". Еще раз проверьте формулу, чтобы убедиться, что используется допустимый имя поля. Если вы хотите отобразить список имен полей для записи, выберите ее ячейку и нажмите ALT+SHIFT+F10.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

Дополнительные сведения

Типы данных Stocks (Акции) и Geography (География)

Создание формул, которые ссылаются на типы данных

Ошибка #ПОЛЕ! #BUSY!

Нужна дополнительная помощь?

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×