Импорт и копирование списка автозавершения на другой компьютер

Список автозавершения — это функция, с помощью которой вы можете вводить имена и адреса электронной почты. Эти предложения могут возсовпадать со списка имен и адресов электронной почты из отправленных сообщений электронной почты. 

Список автозавершения

Способ копирования списка автозаполнения с одного компьютера на другой зависит от того, какой тип учетной записи электронной почты вы добавили в Outlook. Если у вас есть учетная записьMicrosoft 365, учетная запись Exchange Server или учетная запись IMAP (это наиболее распространенный тип учетной записи электронной почты), то список автозавершения хранится в файле данных Outlook в виде скрытого файла. Инструкции приведены в разделе Копирование списка автозаполнения .

Если у вас есть учетная запись POP3 (реже, но часто используется для сторонних поставщиков услуг электронной почты, таких как Comcast, Earthlink и Verizon), список автозавершения хранится в файле, хранящемся на вашем компьютере. Ознакомьтесь со сведениями о копировании и импорте файла. nk2.

Если вы не знаете тип своей учетной записи, выберите файл> Параметры учетной записи > Параметры учетной записи. Здесь вы можете найти тип своей учетной записи.

Копирование списка автозаполнения

Шаг 1: экспорт сообщения почтового ящика автозаполнения

  1. Выйдите из Outlook, а затем закройте Outlook Web Access или Outlook Web App (OWA) на всех рабочих станциях, подключенных к почтовому ящику.

  2. Скачайте и установите MFCMAPI из http://mfcmapi.codeplex.com.

  3. Запустите MFCMAPI. exe.

  4. В меню сеанса выберите пункт Вход.

  5. Если вам будет предложено указать профиль, выберите имя нужного профиля и нажмите кнопку ОК.

  6. В верхней области найдите строку, соответствующую почтовому ящику, и дважды щелкните ее.

  7. В левой области навигации разверните элемент корневой контейнер, а затем разверните узел банк данных или IPM_Subtree.

  8. Щелкните папку "Входящие" правой кнопкой мыши и выберите команду открыть связанную таблицу содержимого. Это действие открывает новое окно MFCMAPI, содержащее различные свойства.

  9. В столбце Тема щелкните правой кнопкой мыши элемент, который содержит тему " IPM". Configuration. Автозаполнение, а затем нажмите кнопку Экспорт сообщения. Это действие открывает окно сохранить сообщение в файл .

  10. В раскрывающемся списке выберите пункт файл MSG (Юникод), а затем нажмите кнопку ОК.

  11. Выберите папку, в которую вы хотите сохранить сообщение, а затем нажмите кнопку сохранить. Обратите внимание на это расположение.

Шаг 2: импорт сообщения почтового ящика автозаполнения

  1. Выйдите из Outlook, а затем закройте Outlook Web Access или Outlook Web App (OWA) на всех рабочих станциях, подключенных к почтовому ящику.

  2. Скачайте и установите MFCMAPI из http://mfcmapi.codeplex.com.

  3. Запустите MFCMAPI. exe.

  4. В меню сеанса выберите пункт Вход.

  5. Если вам будет предложено указать профиль, выберите имя нужного профиля и нажмите кнопку ОК.

  6. В верхней области найдите строку, соответствующую почтовому ящику, и дважды щелкните ее.

  7. В левой области навигации разверните элемент корневой контейнер, а затем разверните узел банк данных или IPM_Subtree.

  8. Щелкните папку "Входящие" правой кнопкой мыши и выберите команду открыть связанную таблицу содержимого. Это действие открывает новое окно MFCMAPI, содержащее различные свойства.

  9. Чтобы избежать дублирования записей, необходимо удалить существующее сообщение автозаполнения.

    Примечание. Перед удалением IPM. Сообщение Configuration. автозавершения, необходимо экспортировать сообщение, выполнив действия, описанные в разделе "экспорт кэша автозаполнения".

    Чтобы удалить существующее сообщение автозаполнения, выполните указанные ниже действия.

    1. В столбце " Тема " найдите элемент, в котором есть тема " IPM". Настройка. Автозаполнение.

    2. Щелкните элемент правой кнопкой мыши и выберите команду Удалить сообщение. Откроется окно удаления элемента .

    3. В раскрывающемся списке выберите вариант окончательное удаление (удаление для хранения удаленных элементов, если оно поддерживается), а затем нажмите кнопку ОК.

  10. В меню "папка" выберите пункт "Импорт", а затем — из сообщения.

  11. Найдите файл. MSG, созданный в действии 11 в разделе "экспорт почтового ящика автозаполнения" выше, и нажмите кнопку ОК.

  12. В появившемся окне " Загрузка сообщения" выберите команду загрузить сообщение в текущую папку в списке загрузить стиль и нажмите кнопку ОК.

Сведения о автозаполнении импортируются из списка IPM. Configuration. Autocomplete_<шестнадцатеричном коде>. MSG, где заполнитель<шестнадцатеричный код> представляет длинную строку цифр и букв.

Копирование и импорт файла. nk2

Шаг 1: копирование файла автозавершения со старого компьютера

  1. Поскольку папка по умолчанию скрыта, самый простой способ открыть ее — использовать командную %AppData%\Microsoft\Outlook в поле поиска Windows (или перейти к C:\Users\имя_пользователя\AppData\Roaming\Microsoft\Outlook).

  2. В папке Outlook найдите файл со списком автозаполнения (NK2).

    Примечание: По умолчанию расширения файлов в Windows скрываются. Чтобы отобразить или снова скрыть расширения файлов, в меню Сервис проводника выберите пункт Параметры папок (чтобы увидеть меню Сервис в Windows 7 или Windows Vista, нажмите клавишу ALT). На вкладке Вид установите или снимите флажок Скрывать расширения для зарегистрированных типов файлов.

  3. Скопируйте файл на новый компьютер. Файл является небольшим и может быть размещен на съемном носителе, например USB-памяти.

Шаг 2: копирование файла автоматического завершения на новый компьютер

  1. На новом компьютере на панели управления щелкните или дважды щелкните значок почта.

    Почта отображается в разных расположениях на панели управления в зависимости от версии операционной системы Microsoft Windows, выбранного представления панели управления и от того, установлена ли 32 или 64-разрядная операционная система или версия Outlook 2010.

    Самый простой способ найти значок Почта — открыть панель управления в Windows и ввести в поле Поиск в верхней части окна запрос Почта. В панели управления Windows XP запрос Почта нужно ввести в поле Адрес.

    Примечание: Значок Почта появляется после первого запуска приложения Outlook.

  2. Нажмите кнопку Показать.

  3. Запишите имя профиля. Вы должны изменить имя файла. NK2 в соответствии с именем, которое позже будет.

  4. Скопируйте файл с расширением. nk2 на новый компьютер в папке, в которой сохраняются конфигурации Outlook. Поскольку папка по умолчанию скрыта, самый простой способ открыть ее — использовать командную %AppData%\Microsoft\Outlook в поле поиска Windows (или перейти к C:\Users\имя_пользователя\AppData\Roaming\Microsoft\Outlook).

  5. После того как файл будет скопирован в папку, щелкните его правой кнопкой мыши, выберите команду Переименоватьи измените имя, чтобы оно соответствовало имени профиля, которое отображалось в действии 3.

Шаг 3: импорт списка автозавершения

Теперь вы можете запустить Outlook и импортировать файл, но вы должны запустить Outlook с особой командой.

  • В поле поиска Windows введите Outlook/importnk2 и нажмите клавишу ВВОД.

После составления сообщения и ввода значений в поля Кому, копияили СК в списке автозавершения должны быть введены данные с другого компьютера.

К началу страницы

В Outlook 2007 вы можете копировать имена и адреса электронной почты из списка автозавершения с одного компьютера на другой. Например, если вы выполняете обновление до нового компьютера и не хотите потерять все данные, хранящиеся в списке автозавершения, вы можете скопировать имена и адреса электронной почты со старого компьютера на новый компьютер.

Важно: Перед началом описанной ниже процедуры необходимо выйти из Microsoft Outlook. Имена будут включены в список автозавершения при повторном запуске Outlook.

Копирование файла автоматического завершения со старого компьютера

  1. На старом компьютере перейдите на диск: \ user\AppData\Local\Microsoft\Outlook.

    Примечание: В зависимости от параметров вашего файла эта папка может быть скрыта.

  2. Щелкните правой кнопкой мыши имя Profile. nk2 и выберите пункт Копировать.

    Совет: Вы можете скопировать файл на съемный носитель, например USB-носитель, и скопировать его в нужное место на новом компьютере. Вы также можете прикрепить файл к сообщению электронной почты и отправить ему сообщение. На новом компьютере откройте вложение в Outlook, а затем сохраните его в нужном месте.

  3. На компьютере, на котором вы хотите заполнить список автозавершения, щелкните правой кнопкой мыши в любом месте диска: \ user\AppData\Local\Microsoft\Outlook и выберите команду Вставить , чтобы сохранить имя профиля. nk2.

  4. Если имя профиля пользователя Outlook на компьютере, на котором вы перемещаете NK2-файл, не задано, необходимо переименовать его в соответствии с именем профиля пользователя Outlook, используемым на новом компьютере, после того как вы скопируйте файл в нужную папку. Например, если вы перемещаете Иван Комарова. nk2 из исходного компьютера с именем профиля пользователя Outlook Kim Комарова, и вы копируете файл Kim Комарова. nk2 на новый компьютер, вы должны переименовать файл с использованием имени профиля Outlook, которое используется на новом компьютере.

  5. При появлении запроса о замене существующего файла нажмите кнопку Да.

  6. Откройте Outlook, чтобы просмотреть изменения, внесенные в список автозавершения.

К началу страницы

Примечание:  Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Была ли информация полезной? Для удобства также приводим ссылку на оригинал (на английском языке).

Нужна дополнительная помощь?

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×