Ячейки

Импорт и экспорт текстовых файлов (в формате TXT или CSV)

Импорт и экспорт текстовых файлов (в формате TXT или CSV)

Импортировать данные из текстового файла в Excel можно двумя способами: открыть его в Excel или импортировать как диапазон внешних данных. Чтобы экспортировать данные из Excel в текстовый файл, воспользуйтесь командой "Сохранить как" и измените тип файла в меню.

Чаще всего используются два формата текстовых файлов:

  • текстовые файлы с разделителями (TXT), в которых для разделения полей текста обычно используется знак табуляции (знак ASCII с кодом 009);

  • текстовые файлы с разделителями-запятыми (CSV), в которых в качестве разделителя полей текста обычно используется запятая (,).

Вы можете изменить знак разделения, используемый в TXT- и CSV-файлах. Это может потребоваться для обеспечения успешного выполнения импорта и экспорта.

Примечание: Можно импортировать и экспортировать до 1 048 576 строк и 16 384 столбцов.

Импорт текстового файла путем его открытия в Excel

Текстовый файл, созданный в другой программе, можно открыть как книгу Excel с помощью команды Открыть. При открытии текстового файла в Excel его формат не изменяется — это можно заметить по заголовку окна Excel, где имя указывается с расширением текстового файла (например, TXT или CSV).

  1. Перейдите в папку > "Открыть" и перейдите в папку с текстовым файлом.

  2. В диалоговом окне "Открыть" выберите "Текстовые файлы" в списке "Тип файла".

  3. Найдите нужный файл и дважды щелкните его.

    • Если это текстовый файл (с расширением ТХТ), запустится мастер импорта текста. Окончив работу с мастером, нажмите кнопку Готово, чтобы завершить импорт. Дополнительные сведения о параметрах и дополнительных параметрах см. в мастере импорта текста.

    • Если файл имеет расширение CSV, Excel автоматически откроет его и отобразит данные в новой книге.

      Примечание: При открытии CSV-файлов для определения способа импорта каждого столбца используются заданные по умолчанию параметры форматирования данных. Если вы хотите применить другие параметры, используйте мастер импорта текста. Например, мастер потребуется, если столбец данных в CSV-файле имеет формат МДГ, а в Excel по умолчанию используется формат ГМД или необходимо преобразовать в текст столбец чисел, содержащих начальные нули, чтобы сохранить их. Чтобы принудительно запустить мастер импорта текста, можно изменить расширение файла с CSV на TXT или импортировать текстовый файл путем подключения к нем (дополнительные сведения см. в следующем разделе).

Импорт текстового файла путем подключения к нем (Power Query)

Вы можете импортировать данные из текстового файла в существующий файл.

  1. На вкладке "Данные" в группе & "Преобразование данных" нажмите кнопку "Из текстового/CSV-документа".

  2. В диалоговом окне "Импорт данных" найдите и дважды щелкните текстовый файл, который нужно импортировать, и нажмите кнопку "Импорт".

  3. В диалоговом окне предварительного просмотра есть несколько параметров:

    • Выберите "Загрузить", если вы хотите загрузить данные непосредственно на новый таблицу.

    • Вы также можете выбрать вариант "Загрузить в", если вы хотите загрузить данные в таблицу, в сводная диаграмма или на существующий/новый таблицу Excel, или просто создать подключение. Вы также можете добавить данные в модель данных.

    • Выберите "Преобразовать данные", если вы хотите загрузить данные в Power Query, и отредактировать их перед их загрузкой в Excel.

Если Excel не преобразует определенный столбец данных в нужный формат, данные можно преобразовать после импорта. Дополнительные сведения см. в статьях Преобразование чисел из текстового формата в числовой и Преобразование дат из текстового формата в формат даты.

Экспорт данных в текстовый файл путем его сохранения

Лист Excel можно преобразовать в текстовый файл, используя команду Сохранить как.

  1. Выберите Файл > Сохранить как.

  2. Нажмите кнопку Обзор.

  3. В диалоговом окне "Сохранить как" в поле "Тип файла" выберите формат текстового файла для этого таблицы. Например, щелкните "Текст" (с делегированной табулом) или "CSV (с запятой) ".

    Примечание: Различные форматы текстовых файлов поддерживают разные возможности. Дополнительные сведения см. в статье Поддерживаемые Excel форматы файлов.

  4. Перейдите в папку, куда вы хотите сохранить файл, а затем нажмите кнопку Сохранить.

  5. Откроется диалоговое окно с напоминанием о том, что в текстовом файле будет сохранен только текущий лист. Если вы хотите сохранить именно текущий лист, нажмите кнопку ОК. Другие листы можно сохранить в отдельных текстовых файлах, повторив эту процедуру для каждого из них.

    Кроме того, под лентой может появиться предупреждение о том, что при сохранение книги в формате CSV некоторые возможности могут быть потеряны.

Дополнительные сведения о сохранении файлов в других форматах см. в статье Сохранение книги в другом формате файла.

Импорт текстового файла путем подключения к нему

Вы можете импортировать данные из текстового файла в существующий файл.

  1. Щелкните ячейку, в которую вы хотите поместить данные из текстового файла.

  2. На вкладке Данные в группе Получение внешних данных нажмите Из текста.

  3. В диалоговом окне "Импорт данных" найдите и дважды щелкните текстовый файл, который нужно импортировать, и нажмите кнопку "Импорт".

    Следуйте инструкциям мастера импорта текста. Нажмите кнопку Кнопка на любой странице мастера импорта текста, чтобы получить дополнительные сведения об его использовании. Окончив работу с мастером, нажмите кнопку Готово, чтобы завершить импорт.

  4. В диалоговом окне Импорт данных:

    1. В группе Куда следует поместить данные? выполните одно из следующих действий:

      • Чтобы поместить данные в выбранные ячейки, щелкните На существующий лист.

      • Чтобы поместить данные в верхний левый угол нового листа, выберите вариант На новый лист.

    2. При необходимости нажмите кнопку Свойства, чтобы задать параметры обновления, форматирования и макета импортируемых данных.

    3. Нажмите кнопку ОК.

      Excel добавит диапазон внешних данных в указанное место.

Если Excel не преобразует столбец в необходимый формат, это можно сделать после импорта. Дополнительные сведения см. в статьях Преобразование чисел из текстового формата в числовой и Преобразование дат из текстового формата в формат даты.

Экспорт данных в текстовый файл путем его сохранения

Лист Excel можно преобразовать в текстовый файл, используя команду Сохранить как.

  1. Выберите Файл > Сохранить как.

  2. Откроется диалоговое окно Сохранение документа.

  3. В поле Тип файла выберите формат текстового файла для листа.

    • Например, выберите Текстовые файлы (с разделителями табуляции) или CSV (разделители — запятые).

    • Примечание: Различные форматы текстовых файлов поддерживают разные возможности. Дополнительные сведения см. в статье Поддерживаемые Excel форматы файлов.

  4. Перейдите в папку, куда вы хотите сохранить файл, а затем нажмите кнопку Сохранить.

  5. Откроется диалоговое окно с напоминанием о том, что в текстовом файле будет сохранен только текущий лист. Если вы хотите сохранить именно текущий лист, нажмите кнопку ОК. Другие листы можно сохранить в отдельных текстовых файлах, повторив эту процедуру для каждого из них.

  6. Откроется второе диалоговое окно с напоминанием о том, что сохраняемый лист может содержать возможности, которые не поддерживаются текстовыми форматами файлов. Если в новом текстовом файле нужно сохранить только данные листа, нажмите кнопку Да. Если вы не уверены и хотите получить дополнительные сведения о том, какие возможности Excel не поддерживаются форматами текстовых файлов, нажмите кнопку Справка.

Дополнительные сведения о сохранении файлов в других форматах см. в статье Сохранение книги в другом формате файла.

Способ изменения delimiter при импорте зависит от того, как вы импортируете текст.

  • Если вы используете кнопку & "Преобразовать данные из > из текстового/CSV-файла", после выбора текстового файла и нажатия кнопки "Импорт" выберите в списке знак, который нужно использовать, в области "Один из них". Новый вариант можно сразу же увидеть в области предварительного просмотра данных, чтобы перед началом работы убедиться в том, что вы сделаете нужный выбор.

  • Если вы импортируете текстовый файл с помощью мастера импорта текста, вы можете изменить его на шаге 2. На этом шаге также можно изменить способ обработки последовательных разделителей (например, идущих подряд кавычек).

    Дополнительные сведения о параметрах и дополнительных параметрах см. в мастере импорта текста.

Если вы хотите использовать в качестве по умолчанию десятичной запятой в качестве вехи для сохранения в качестве CSV-значения, но хотите ограничить это изменение в Excel, думайте об изменении стандартного десятичной запятой на запятую. В этом случае Excel будет использовать в качестве десятичной запятой. Очевидно, что это также изменит способ отображения десятичных чисел, поэтому мы также думайте изменить десятичной заметим, чтобы ограничить путаницу.

  1. Чтобы очистить параметры Excel> дополнительные>параметры редактирования> использовать системные вехи.

  2. В качестве десятичной запятой установите десятичной запятой.

  3. Установите для этого веху. (точка).

При этом в качестве CSV-файла по умолчанию в качестве значения в списке будет запятая. Вы можете изменить этот знак на другой знак с помощью параметров региона Windows. 

Внимание: Изменение параметров Windows приведет к глобальным изменениям на компьютере, которые повлияют на все приложения. Чтобы изменить только delimiter для Excel, см. в этом списке по умолчанию для сохранения файлов в виде текста (CSV-файла) в Excel.

  1. В Microsoft Windows 10 щелкните правой кнопкой мыши кнопку "Начните" и выберите "Параметры".

  2. Выберите "& язык",а затем щелкните "Регион" на левой панели.

  3. На главной панели в группе "Региональные параметры"щелкните "Дополнительные параметры даты, времени и региона".

  4. В области щелкните"Изменить форматы даты, времени или числа".

  5. В диалоговом окке "Регион" на вкладке "Формат" нажмите кнопку "Дополнительные параметры".

  6. В диалоговом окне "Настройка формата" на вкладке "Числа" введите символ, который будет применяться в качестве нового в поле для разметки списка.

  7. Дважды нажмите кнопку ОК.

  1. Нажмите кнопку Пуск и выберите пункт Панель управления.

  2. В разделе Часы, язык и регион щелкните элемент Изменение форматов даты, времени и чисел.

  3. В диалоговом окке "Регион" на вкладке "Формат" нажмите кнопку "Дополнительные параметры".

  4. В диалоговом окне "Настройка формата" на вкладке "Числа" введите символ, который будет применяться в качестве нового в поле".

  5. Дважды нажмите кнопку ОК.

Примечание:  После изменения разделителя элементов списка все программы на компьютере будут использовать новый символ. Вы можете вернуть стандартный символ, выполнив эти же действия.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

См. также

Импорт данных из внешних источников (Power Query)

Нужна дополнительная помощь?

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×