Использование констант массива в формулах массива

При вводе формулы массивачаще всего используется диапазон ячеек на вашем компьютере, но делать это не нужно. Вы также можете использовать константымассива — значения, которые вы вводите в панели формул внутри скобок: {}. После этого вы сможете назвать константу, чтобы ее было проще использовать снова.

Константы можно использовать как в формулах массива, так и в самих себя.

  1. В формуле массива введите открываю скобку, нужные значения и закрываю ее. Пример: =СУММ(A1:E1*{1;2;3;4;5})

    Константа находится внутри скобок ({)}, и да, вы действительно введите эти скобки вручную.

  2. Введите оставшуюся часть формулы и нажмите CTRL+SHIFT+ВВОД.

    Формула будет выглядеть так: {=СУММ(A1:E1*{1;2;3;4;5})}и результаты будут выглядеть так:


    Константа массива, вложенная в формулу СУММ

    Формула умножает A1 на 1 и B1 на 2 и т. д., что не экономит от необходимости в ячейках 1;2;3;4;5.

Использование константы для ввода значений в столбец

Чтобы ввести значения в одном столбце, например 3 ячейки в столбце C, нужно сделать вот что:

  1. Выделите нужные ячейки.

  2. Введите знак равных и константы. Значения в константах разделяются запятой, а не запятой. При вводе текста его необходимо окружить двойными кавычками. Например: ={"Квартал 1";" Квартал2";" Квартал 3"}

  3. Нажмите клавиши CTRL+SHIFT+ВВОД. Константа выглядит так:

    Вертикальная константа массива, содержащая текст

    В других терминах это одномерная вертикальная константа.

Использование константы для ввода значений в строке

Чтобы быстро ввести значения в одной строке, например ячейки F1, G1 и H1, необходимо сделать вот что:

  1. Выделите нужные ячейки.

  2. Введите знак равных и константы, но в этот раз значения разделяйте запятой, а не пятой. Например: ={1;2;3;4;5}

  3. Нажмите CTRL+SHIFT+ВВОД, и константа будет выглядеть так:

    Одномерная горизонтальная константа массива

    В других терминах это одномерная горизонтальная константа.

Использование константы для ввода значений в нескольких столбцах и строках

  1. Вы выберите нужные ячейки.

    Убедитесь, что количество выбранных строк и столбцов соответствует количеству значений в константе. Например, если константа будет записывать данные в четыре столбца и три строки, выберем их.

  2. Введите знак равных и константы. В этом случае разделять значения в каждой строке запятой и использовать запятую в конце каждой строки. Например:

    ={1;2;3;4:5;6;7;8:9;10;11;12}

  3. Нажмите CTRL+SHIFT+ВВОД и:

    Двумерная константа массива

    Это двумерная константа, заполняемая столбцы и строки. Если вам интересно, вы не можете создать трехмерную константу, то есть вложенную константу в другую нельзя.

Использование константы в формуле

Теперь, когда вы знакомы с константами массива, вот рабочий пример.

  • В любой пустой ячейке введите (или скопируйте и введите) эту формулу, а затем нажмите CTRL+SHIFT+ВВОД:

    =СУММ(A1:E1*{1;2;3;4;5})

    В ячейке A3 появится значение 85.

    Что произошло? Значение в ячейке A1 было умножено на 1, значение в ячейке B2 на 2 и так далее, а затем функция СУММ добавила эти результаты. Можно также ввести формулу =СУММ(A1*1;B1*2;C1*3;D1*4;E1*5)

При этом оба набора значений можно ввести в качестве констант массива.

=СУММ({3;4;5;6;7}*{1;2;3;4;5})

Для этого скопируйте формулу, выберем пустую ячейку и введите формулу в формулу и нажмите CTRL+SHIFT+ВВОД. Вы увидите такой же результат.

Примечания: Если константы не работают, и на их компьютере возникают указанные здесь проблемы.

  • Убедитесь, что значения отделены правильными символами. Если запятая или запятая опустить или поместить ее в неверном месте, константа массива может выглядеть неправильно или может появиться предупреждение.

  • Возможно, вы выбрали диапазон ячеек, не совпадающие с числом элементов в константе. Например, при выборе столбца из шести ячеек для использования с константой с пятью ячейками в пустой ячейке появляется #N/Д. Если не выбрать достаточно ячеек, Значения, не соответствующие ячейке, будут опуститься.

  • Дополнительные информацию о формулах массива:

К началу страницы

Нужна дополнительная помощь?

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×