Исправление ошибки #ЗНАЧ! в функциях ИНДЕКС и ПОИСКПОЗ

В этой статье описываются распространенные ситуации, в которых может возникнуть ошибка #ЗНАЧ! при использовании функций ИНДЕКС и ПОИСКПОЗ вместе в формуле. Одной из наиболее распространенных причин использования функций ИНДЕКС и ПОИСКПОЗ в сочетании друг с другом является необходимость найти значение в случае, когда функция ВПР неприменима, например, если длина искомого значения превышает 255 символов.

Проблема: формула не была введена как массив

Если вы используете ИНДЕКС как формулу массива вместе с функцией ПОИСКПОЗ для извлечения значения, вам необходимо преобразовать формулу в формулу массива. В противном случае возникнет ошибка #ЗНАЧ!.

Решение: Сочетание функций ИНДЕКС и ПОИСКПОЗ следует использовать как формулу массива, то есть нужно нажать клавиши CTRL+SHIFT+ВВОД. При этом формула будет автоматически заключена в фигурные скобки {}. Если вы попытаетесь ввести их вручную, Excel отобразит формулу как текст.

Если при использовании функций ИНДЕКС и ПОИСКПОЗ длина искомого значения превышает 255 символов, его необходимо вводить как формулу массива.  В ячейке F3 содержится формула =ИНДЕКС(B2:B4;ПОИСКПОЗ(ИСТИНА;A2:A4=F2;0);0), которая вводится путем нажатия клавиш CTRL+SHIFT+ВВОД

Примечание: Если у вас есть текущая версия Microsoft 365,вы можете просто ввести формулу в выходную ячейку, а затем нажать ввод, чтобы подтвердить формулу как динамическую формулу массива. В противном случае формулу необходимо ввести как формулу массива прежних вариантов. Для этого сначала выберем ячейку, введите ее в ячейку и нажимаем CTRL+SHIFT+ВВОД для подтверждения. Excel автоматически вставляет фигурные скобки в начале и конце формулы. Дополнительные сведения о формулах массива см. в статье Использование формул массива: рекомендации и примеры.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Исправление ошибки #ЗНАЧ! #BUSY!

Функция ИНДЕКС

Функция ПОИСКПОЗ

Искомые значения с помощью В ПРОСМОТР, ИНДЕКС или ВЫБОРПОЗ

Полные сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах

Все функции Excel (по алфавиту)

Функции Excel (по категориям)

Нужна дополнительная помощь?

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×