Исправление #REF! #BUSY!

Ошибка #ССЫЛКА! указывает на то, что формула ссылается на недопустимую ячейку. Чаще всего это происходит потому, что формула ссылается на ячейки, которые были удалены или заменены другими данными.

Пример ошибки #ССЫЛКА! из-за удаления столбца

В следующем примере в столбце E используется формула =СУММ(B2;C2;D2).

Формула, использующая явные ссылки на ячейки, например =СУММ(B2;C2;D2), может привести к #REF! при удалении столбца.

Удаление столбца B, C или D может привести к #REF! ошибка "#ЗНАЧ!". В этом случае удалим столбец C (Продажи 2007), а в формуле будет отсчитано =СУММ(B2;#REF!;C2). Если вы используете явные ссылки на ячейки (в которых каждая ячейка ссылается отдельно, разделена запятой) и удаляете строку или столбец, на которые имеется ссылка, Excel не может их устранить, поэтому возвращает #REF! ошибка "#ЗНАЧ!". Именно поэтому использовать явные ссылки на ячейки в функциях не рекомендуется.

Пример ошибки #ССЫЛКА! из-за удаления столбца.

Решение

  • Если вы случайно удалили строки или столбцы, вы можете немедленно нажать кнопку "Отменить" на панели быстрого доступа (или нажать клавиши CTRL+Z), чтобы восстановить их.

  • Измените формулу так, чтобы она ссылалась на диапазон, а не на отдельные ячейки, например =СУММ(B2:D2). Теперь можно удалить любой столбец в диапазоне суммирования, и Excel автоматически скорректирует формулу. Чтобы вычислить сумму значений в строках, также можно использовать формулу =СУММ(B2:B5).

Пример функции ВПР с неправильными ссылками на диапазоны

В следующем примере =В ПРОСМОТР(A8;A2:D5;5;ЛОЖЬ) возвращает #REF! из-за того, что она ищет значение из столбца 5, но диапазон ссылок — A:D, который составляет всего 4 столбца.

Пример формулы В ПРОСМОТР с неправильным диапазоном.  Формула имеет формулу =ВЛОКУ(A8;A2:D5;5;ЛОЖЬ).  Пятого столбца в диапазоне В ПРОСМОТР нет, поэтому 5 вызывает #REF! ошибка "#ЗНАЧ!".

Решение

Расширьте диапазон или уменьшите значение столбца для поиска так, чтобы он попадал в указанный диапазон. Формулы =ВПР(A8;A2:E5;5;ЛОЖЬ) будет работать правильно, так же как и формула =ВПР(A8;A2:D5;4;ЛОЖЬ).

Пример функции ИНДЕКС с неправильной ссылкой на строку или столбец

В этом примере формула =ИНДЕКС(B2:E5;5;5) возвращает #REF! поскольку диапазон ИНДЕКС составляет 4 строки и 4 столбца, но формула запрашивает возврат данных в пятой строке и пятом столбце.

Пример формулы ИНДЕКС с недопустимой ссылкой на диапазон.  Формула имеет вид =ИНДЕКС(B2:E5;5;5), но диапазон содержит всего 4 строки и 4 столбца.

Решение

Измените ссылки на строки и столбцы так, чтобы они попадали в диапазон поиска функции ИНДЕКС. Формула =ИНДЕКС(B2:E5;4;4) вернет правильный результат.

Пример ссылки на закрытую книгу с использованием функции ДВССЫЛ

В следующем примере функция INDIRECT пытается создать ссылку на закрытую книгу, что приводит к #REF! ошибка "#ЗНАЧ!".

Пример ошибки #ССЫЛКА! из-за использования функции ДВССЫЛ для ссылки на закрытую книгу.

Решение

Откройте книгу, на которые ссылается ссылка. Эта же ошибка будет возникнуть при ссылке на закрытую книгу с динамической функцией массива.

Проблемы с OLE

Если вы использовали ссылку OLE, возвращая #REF! и запустите программу, которая вызывает ссылку.

Примечание. OLE — это технология, которая используется для обмена информацией между приложениями.

Проблемы с DDE

Если вы использовали раздел динамического обмена данными (DDE), возвращающий #REF! сначала проверьте, правильно ли вы ссылаетесь на тот или иной раздел. Если вы по-прежнему получаете #REF! проверьте параметры центра управления доверием на внешний контент, как описано в описании блокировки или разблокировки внешнего содержимого в документах Office.

Примечание. Динамический обмен данными (DDE)— это протокол, установленный для обмена данными между приложениями на базе Microsoft Windows.

Проблемы с макросами

Если макрос вводит функцию, которая ссылается на ячейку над функцией, а ячейка с этой функцией находится в строке 1, функция возвращает #REF! так как над строкой 1 нет ячеек. Проверьте функцию, чтобы проверить, ссылается ли аргумент на ячейку или диапазон ячеек, которые не являются допустимами. Для этого может потребоваться изменить макрос в редакторе Visual Basic (VBE).

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Полные сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Поиск ошибок в формулах

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Нужна дополнительная помощь?

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×