Округление числа до необходимого десятичного разряда

Если отображение ненужных разрядов вызывает появление знаков ######, или если микроскопическая точность не нужна, измените формат ячеек таким образом, чтобы отображались только необходимые десятичные разряды.

Округка числа до ближайшей основной единицы

Если вы хотите округить число до ближайшего крупного блока, например тысяч, сотен, десятков или единиц, используйте функцию в формуле, выполните следующие действия:

С помощью кнопки

  1. Выделите ячейки, которые нужно отформатировать.

  2. На вкладке Главная выберите команду Увеличить разрядность или Уменьшить разрядность, чтобы отобразить больше или меньше цифр после запятой.

С помощью встроенного числового формата

  1. На вкладке Главная в группе Число щелкните стрелку рядом со списком числовых форматов и выберите пункт Другие числовые форматы.

Группа "Число" на вкладке "Главная"

  1. В списке Категория выберите значение Денежный, Финансовый, Процентный или Экспоненциальный в зависимости от типа ваших данных.

  2. В поле Число десятичных знаков введите число знаков после запятой, которые вы хотите отображать.

С помощью функции в формуле

Округлите число до необходимого количества цифр с помощью функции ОКРУГЛ. Эта функция имеет только два аргумента (аргументы — это части данных, необходимые для выполнения формулы).

  • Первый аргумент — это число, которое необходимо округлить. Он может быть ссылкой на ячейку или числом.

  • Второй аргумент — это количество цифр, до которого необходимо округлить число.

Предположим, что ячейка A1 содержит число 823,7825. Вот как можно округлить его.

  • Чтобы округлить до ближайшей тысяч и

    • Введите =ОКРУГЛ(A1;-3), что равно 1000

    • Число 823,7825 ближе к 1000, чем к 0 (0 кратно 1000 )

    • В этом случае используется отрицательное число, поскольку округление должно состоятся влево от запятой. Такое же число применяется в следующих двух формулах, которые округляют до сотен и десятков.

  • Чтобы округлить до ближайших сотен

    • Введите =ОКРУГЛ(A1;-2), что равно 800

    • Число 800 ближе к 823,7825, чем к 900. Наверное, теперь вам все понятно.

  • Чтобы округлить до ближайших десятков

    • Введите =ОКРУГЛ(A1;-1), что равно 820

  • Чтобы округлить до ближайших единиц

    • Введите =ОКРУГЛ(A1;0), что равно 824

    • Используйте ноль для округления числа до ближайшей единицы.

  • Чтобы округлить до ближайших десятых

    • Введите =ОКРУГЛ(A1;1), что равно 823,8

    • В этом случает для округления числа до необходимого количества разрядов используйте положительное число. То же самое касается двух следующих формул, которые округляют до сотых и тысячных.

  • Чтобы округлить до ближайших сотых

    • Введите =ОКРУГЛ(A1;2), что равно 823,78

  • Чтобы округлить до ближайших тысячных

    • Введите =ОКРУГЛ(A1;3), что равно 823,783

Округлите число в большую сторону с помощью функции ОКРУГЛВВЕРХ. Она работает точно так же, как функция ОКРУГЛ, за исключением того, что она всегда округляет число в большую сторону. Например, если необходимо округлить число 3,2 до ноля разрядов:

  • =ОКРУГЛВВЕРХ(3,2;0), что равно 4

Округлите число вниз с помощью функции ОКРУГЛВНИЗ. Она работает точно так же, как функция ОКРУГЛ, за исключением того, что она всегда округляет число в меньшую сторону. Например, необходимо округлить число 3,14159 до трех разрядов:

  • =ОКРУГЛВНИЗ(3,14159;3), что равно 3,141

Совет:  Чтобы познакомиться с другими примерами и поработать с ними в книге Excel Online, см. статьи Функция ОКРУГЛ,Функция ОКРУГЛВВЕРХ и Функция ОКРУГЛВНИЗ.

  1. Щелкните пустую ячейку.

  2. На вкладке Формулы в разделе Функция нажмите кнопку Построитель формул.

  3. Выполните любое из описанных ниже действий.

    Задача

    В построитель формул найдите и дважды щелкните

    В области Аргументы

    Округление числа вверх

    Раундап

    Введитечисло, округля его. В num_digitsвведите 0, чтобы округить число до ближайшего целого.

    Округление числа вниз

    ROUNDDOWN

    Введитечисло, округля его вниз. В num_digitsвведите 0, чтобы округить число до ближайшего целого.

    Округка до 1 0

    Даже

    Введитечисло, округля его.

    Округка до нечетного числа

    Странно

    Введитечисло, округля его.

    Округка числа до ближайшего числа, кратного другому

    MROUND

    Щелкните поле рядом с несколькимии введите ближайшее число, кратное.

  4. Нажмите клавишу RETURN.

Стандартный десятичный разделитель для чисел можно настроить в параметрах Excel.

  1. Нажмите кнопку Параметры (Excel 2010 Excel 2016) или кнопку Microsoft Office Изображение кнопки Office > Excel Параметры (Excel 2007).

  2. В категории Расширенные параметры нужно выбрать пункт Параметры правки, а затем установить флажок Автоматическая вставка десятичной запятой.

  3. В поле Число знаков после запятой введите положительное число для количества цифр справа от запятой или отрицательное число для количества цифр слева от запятой.

    Примечание: Например, если ввести 3 в поле Число знаков после запятой, а затем — 2834 в ячейке, то значение будет равно 2,834. Если ввести –3 в поле Число знаков после запятой, а затем — 283 в ячейке, то значение будет равно 283000.

  4. Нажмите кнопку ОК.

    В строке состояния будет отображаться индикатор Фиксированный десятичный формат.

  5. Выберите ячейку на листе и введите нужное число.

    Примечание: Установка флажка Фиксированный десятичный формат не влияет на уже введенные данные.

  • Чтобы не использовать для числа параметр "Фиксированный десятичный формат", при его вводе добавьте десятичную запятую.

  • Чтобы удалить десятичные запятые из чисел, введенных с использованием фиксированного десятичного формата, сделайте следующее:

    1. Нажмите кнопку Параметры (Excel 2010 Excel 2016) или кнопку Microsoft Office Изображение кнопки Office > Excel Параметры (Excel 2007).

    2. В категории Расширенные параметры в разделе Параметры правки снимите флажок Автоматическая вставка десятичной запятой.

    3. В пустой ячейке введите число, соответствующее числу десятичных знаков, которое вы хотите удалить, например 10, 100 или 1000.

      Например, введите 100 в ячейке, если числа содержат два десятичных знака и вы хотите преобразовать их в целые числа.

    4. На вкладке Главная в группе Буфер обмена нажмите кнопку Копировать Изображение кнопки или нажмите CTRL+C.

    5. Выделите на листе ячейки, содержащие числа с десятичными разрядами, которые вы хотите изменить.

    6. На вкладке Главная в группе Буфер обмена щелкните стрелку под кнопкой Вставить и выберите команду Специальная вставка.

    7. В диалоговом окне Специальная вставка в разделе "Операция" выберите Умножить.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

См. также

Округление числа

Почему число округлилось?

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединение к программе предварительной оценки Майкрософт

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×