С помощью набегаемого итога можно просмотреть значения элементов в ячейках при вводе новых элементов и значений с течением времени. Чтобы вычислить набегаю итог, воспользуйтесь следующей процедурой:

  1. Настройка таблицы, как в примере ниже.

    Чтобы этот пример проще было понять, скопируйте его на пустой лист.

    Копирование примера

    1. Создайте пустую книгу или лист.

    2. Выделите пример в разделе справки.

      Примечание: Не выделяйте заголовки строк или столбцов.

      Выделите образец данных

    3. Нажмите клавиши CTRL+C.

    4. Выделите на листе ячейку A1 и нажмите клавиши CTRL+V.

    5. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (знак ударения) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показывать формулы.

      A

      B

      C

      D

      E

      1

      Системная дата

      Product

      Quantity

      Формула

      Running Total

      2

      2 января

      Пляжевая игрушек

      5

      =СУММ($C$2:$C 2)

      5

      3

      2 января

      Солнцезащитные очки

      3

      =СУММ($C$2:$C 3)

      8

      4

      3 января

      Пляжевая игрушек

      9

      =СУММ($C$2:$C 4)

      17

      5

      3 января

      Солнцезащитные очки

      8

      =СУММ($C$2:$C 5)

      25

      6

      3 января

      Набор "Колебание"

      1

      =СУММ($C$2:$C 6)

      26

      7

      4 января

      Пляжевая игрушек

      6

      =СУММ($C$2:$C 7)

      32

      8

      4 января

      Солнцезащитные очки

      4

      =СУММ($C$2:$C 8)

      36

      9

      5 января

      Пляжевая игрушек

      11

      =СУММ($C$2:$C 9)

      47

      10

      5 января

      Песочнице

      1

      =СУММ($C$2:$C 10)

      48

      11

      5 января

      Солнцезащитные очки

      5

      =СУММ($C$2:$C 11)

      53

      12

      5 января

      Набор "Колебание"

      2

      =СУММ($C$2:$C 12)

      55

      При внимательном взгляде на формулы в столбце D вы увидите, что первая часть диапазона является абсолютной ссылкой (перед столбцом и строкой стоит символ $), а во второй части диапазона есть смешанная ссылка (перед столбцом стоит символ $). Таким образом, формула будет работать как набегающий итог при копировании в смежные строки.

  2. Чтобы сохранить суммарный итог, добавьте строку для каждой новой записи и скопируйте формулу из столбца D в эту строку.

    Вводить или копировать формулу вручную в каждой строке не нужно. Например, можно ввести формулу только в ячейку D2. Затем просто скопируйте формулу в другие строки, содержащие данные, перетащив его в ячейку D13.

Примечание: Сумма с нарастающем итоге отличается от нарастающем балансе, при котором сумма значений возрастает или сжимается (например, регистрируется в книге) при добавлении новых записей.

  1. Настройка таблицы, как в примере ниже.

    Чтобы этот пример проще было понять, скопируйте его на пустой лист.

    Копирование примера

    1. Создайте пустую книгу или лист.

    2. Выделите пример в разделе справки.

      Примечание: Не выделяйте заголовки строк или столбцов.

      Выделите образец данных

    3. Нажмите COMMAND+C.

    4. Выберем ячейку A1 на COMMAND+V.

    5. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих результаты, нажмите клавиши CONTROL+' (ударение) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.

      A

      B

      C

      D

      E

      1

      Системная дата

      Product

      Quantity

      Формула

      Running Total

      2

      2 января

      Пляжевая игрушек

      5

      =СУММ($C$2:$C 2)

      5

      3

      2 января

      Солнцезащитные очки

      3

      =СУММ($C$2:$C 3)

      8

      4

      3 января

      Пляжевая игрушек

      9

      =СУММ($C$2:$C 4)

      17

      5

      3 января

      Солнцезащитные очки

      8

      =СУММ($C$2:$C 5)

      25

      6

      3 января

      Набор "Колебание"

      1

      =СУММ($C$2:$C 6)

      26

      7

      4 января

      Пляжевая игрушек

      6

      =СУММ($C$2:$C 7)

      32

      8

      4 января

      Солнцезащитные очки

      4

      =СУММ($C$2:$C 8)

      36

      9

      5 января

      Пляжевая игрушек

      11

      =СУММ($C$2:$C 9)

      47

      10

      5 января

      Песочнице

      1

      =СУММ($C$2:$C 10)

      48

      11

      5 января

      Солнцезащитные очки

      5

      =СУММ($C$2:$C 11)

      53

      12

      5 января

      Набор "Колебание"

      2

      =СУММ($C$2:$C 12)

      55

      При внимательном взгляде на формулы в столбце D вы увидите, что первая часть диапазона является абсолютной ссылкой (перед столбцом и строкой стоит символ $), а во второй части диапазона есть смешанная ссылка (перед столбцом стоит символ $). Таким образом, формула будет работать как набегающий итог при копировании в смежные строки.

  2. Чтобы сохранить суммарный итог, добавьте строку для каждой новой записи и скопируйте формулу из столбца D в эту строку.

    Вводить или копировать формулу вручную в каждой строке не нужно. Например, можно ввести формулу только в ячейку D2. Затем просто скопируйте формулу в другие строки, содержащие данные, перетащив его в ячейку D13.

Примечание: Сумма с нарастающем итоге отличается от нарастающем балансе, при котором сумма значений возрастает или сжимается (например, регистрируется в книге) при добавлении новых записей.

Нужна дополнительная помощь?

Совершенствование навыков

Перейти к обучению >

Первоочередный доступ к новым возможностям

Присоединение к программе предварительной оценки Майкрософт >

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×