Связывание проектов для создания главного проекта в классической версии Project

Связывание проектов для создания главного проекта в классической версии Project

Подписка на Office 365, Project профессиональный 2019, Project профессиональный 2016, Office 2013, Office 2010

Чтобы улучшить организацию больших проектов, вы можете связать несколько файлов проектов, создав систему из главного проекта и подпроектов (внешние зависимости). Например, главный проект по строительству может включать файлы подпроектов по водопроводным, электромонтажным и столярным работам.

Связывание файлов в Project

  1. Создайте в Project отдельные файлы для каждого подпроекта, а затем откройте или создайте проект, который нужно сделать главным.

  2. В главном проекте нажмите Вид > Диаграмма Ганта.

  3. В поле Название задачи нажмите на строку, под которой нужно вставить подпроект. Его можно вставить в любой строке списка задач главного проекта.

  4. Выберите Проект > Подпроект.

    Вкладка ленты "Проект", на которой отображается команда "Вставить подпроект".

  5. В окне Вставка проекта выберите подпроект, который нужно вставить.

    • Чтобы вставить несколько подпроектов, нажмите и удерживайте клавишу CTRL и нажимайте подпроекты в нужном порядке.

    • В большинстве случаев флажок для параметра Связать с проектом должен быть установленным, чтобы изменения в подпроекте отображались в главном проекте и наоборот. Но если вы хотите просто скопировать подпроект в главный проект, не устанавливая между файлами динамическую связь, снимите этот флажок.

  6. Нажмите кнопку Вставить или, чтобы вставить проект в формате только для чтения, нажмите на стрелку на кнопке Вставить, а затем выберите команду Вставить только для чтения. При вставке проекта в таком формате будет создана связь между двумя проектами, но обновление подпроекта в главном проекте выполняться не будет. При этом в случае обновления непосредственно файла подпроекта внесенные изменения будут отображены в главном проекте. Параметр Вставить только для чтения доступен только после установки флажка Связать с проектом.

Как избежать дублирования имен ресурсов в связанных проектах

Если связать проекты, в которых используются ресурсы с одинаковыми именами, вы создадите их копии, что может привести к ошибкам. Чтобы избежать этого, в диалоговом окне Вставка проекта снимите флажок Связать с проектом. Таким образом вы гарантируете использование сведений о ресурсах (например, ставок оплаты и календарей ресурсов) из главного проекта в подпроекте.

Примечание: При обновлении несвязанного подпроекта в главном проекте внесенные изменения не будут отображаться в исходном файле подпроекта.

Reorganizing subprojects in the master project

Если вы вставили подпроект в главный проект и хотите изменить ставку списка задач, вы можете переместить вставленный проект вверх или вниз по списку задач.

  1. Выберите ">Гэтта".

  2. Выберите идентификатор, суммарная задача представляет вставленный проект, который вы хотите переместить.

  3. Щелкните правой кнопкой мыши и выберите "Вырезать", чтобы удалить вставленный проект.

    Примечание: Когда задача вырезана и вставлялась, ее уникальный идентификатор (отличается от столбца идентификатор задачи в левом столбце таблицы "Запись") при ее вхождении в список задач в другом месте. Чтобы переместить задачу без изменения уникального ИД, перетащите задачу на новое место в списке задач. Чтобы перетащить задачу, на поместите указатель на ее ИД в поле "ИД". Когда задача превратилась в четырехконечную стрелку, перетащите ее на новое место. Эти данные будут удалены из плана проекта, но не будут удалены до тех пор, пока вы не в сможете в него вернуться.

  4. Выберите ID-номер задачи ниже, в которой проект должен отображаться в списке задач.

    Примечание: При вставке или вставке проекта под другим вставленным проектом, в который вставлены только суммарная задача проекта, проект, который вставляется или вставляется, добавляется на том же уровне, что и вставленный над проектом. Однако если вставить или вставить под вставленным проектом, в который отображаются все задачи, то проект, который вы вставляете или вставляете, становится подпроектом вставленного над него проекта.

  5. Нажмите кнопку "Вировать", чтобы вировать проект над выбранной строкой.

Эти инструкции относятся к Microsoft Project 2007.

Когда следует использовать перекрестные связи между проектами, а не зависимости?

Если в вашем проекте есть задача, зависящая от задачи из другого проекта, используйте перекрестные связи, чтобы связать даты этих задач. Если впоследствии сроки задачи из другого проекта сместятся, эти изменения отразятся на вашей задаче. Если ваш проект зависит от какого-либо аспекта другого проекта, и эта зависимость не связана с определенной задачей, используйте зависимости между проектами, чтобы точно определить, в чем заключается вклад каждого проекта в связь.

  1. Откройте проекты с задачами, которые вы хотите связать.

    В одном из проектов откройте меню Окно и выберите Упорядочить все.

  2. Выберите задачу, для которой хотите создать зависимость с внешним предшественником.

  3. Щелкните "Сведения Изображение кнопки " и перейдите на вкладку "Предшественники".

  4. В столбце "ИД" введите имя проекта и номер задачи внешнего предшественника через заглавную сетку. Например, введите "Проект1\1" для задачи "ИД 1" в файле с именем "Проект1".

По умолчанию вы будете уведомлены об изменениях в проекте, связанном с внешними данными. Внешние предшественники и последователи, а также влияние на календарный план отображаются при открытом проекте с внешними связями, и вы можете принять любые или все изменения.

  • Для установления связи с внешней задачей оба проекта следует предварительно сохранить.

  • При связываке задач из разных проектов, которые хранятся в Microsoft Office Project Server, необходимо правильно отформатировать и отформатировать задачу-предшественник. В диалоговом окне "Сведения о задаче" на вкладке "Предшественники" в столбце "ИД" необходимо отформатировать задачу, как показано в следующем примере: <>\project1\42. В этом примере project1 — это название проекта, содержаного предшественника, а 42 — ее ИД.

  • Задачи с внешними связями отображаются затененными в списке задач. Дважды щелкнув задачу с внешним предшественником или последователем, вы откроете проект, содержащий внешнюю задачу (если он доступен).

Задачи из разных проектов связаны, но данные отличаются

При использовании параметра "Вставлять связь" в диалоговом окне "Специальная вставлять"(меню "Правка") для подключения задач Project использует функцию "Связь с объектами" и "Embedding" (OLE). Связываются только выбранные поля. Однако с задачей может быть связано множество других полей сведений, которые влияют на ее план, и эти поля могут быть скрыты при просмотре в режиме разделенного экрана.

При необходимости создать зависимость между задачами из разных проектов, для соблюдения календарного плана следует создать внешние зависимости, а не связи.

Если вы выбрали пункт Связать, выделите отдельные поля, а не целые строки, и создайте связь только для нужных сведений, чтобы избежать конфликтов в календарном плане.

Подробнее

Вложенные планы: главные проекты и подпроекты

Нужна дополнительная помощь?

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×