Войти с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Select a different account.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой вы хотите войти.

Проверка того, являются ли условия истинными или ложными, и логические сравнения между выражениями являются общими для многих задач. Для создания условных формул можно использовать функции AND, OR, NOT и IF .

Например, функция ЕСЛИ использует следующие аргументы.

Формула с функцией ЕСЛИ

Формула, использующая функцию IF

Изображение кнопки logical_test: условие, которое необходимо проверить.

Выноска 2 value_if_true: возвращаемое значение, если условие имеет значение True.

Изображение кнопки value_if_false: возвращаемое значение, если условие имеет значение False.

Дополнительные сведения о создании формул см. в разделе "Создание или удаление формулы".

Что вы хотите сделать?

Создание условной формулы, которая приводит к логическому значению (TRUE или FALSE)

Для выполнения этой задачи используйте функции и операторы AND, OR и NOT , как показано в следующем примере.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Копирование примера

  1. Выделите пример, приведенный в этой статье.

    выбор примера из справки в Excel 2013 для Windows

    Выделение примера в справке

  2. Нажмите клавиши CTRL+C.

  3. В Excel создайте пустую книгу или лист.

  4. Выделите на листе ячейку A1 и нажмите клавиши CTRL+V.

Важно: Чтобы пример правильно работал, его нужно вставить в ячейку A1.

  1. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (знак ударения) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показывать формулы.

Скопировав пример на пустой лист, вы можете настроить его так, как вам нужно.

Данные

15

9

8

Звездочки

Виджеты

Формула

Описание (результат)

=AND(A2>A3, A2<A4)

Определяет, больше ли значение в ячейке A2, чем значение в A3, а также если значение в A2 меньше значения в A4. (FALSE)

=ИЛИ(A2>A3, A2<A4)

Определяет, больше ли значение в ячейке A2 значения В3 или значение в A2 меньше значения В4. (TRUE)

=НЕ(A2+A3=24)

Определяет, не равна ли сумма значений в ячейках A2 и A3 24. (FALSE)

=NOT(A5="Spets")

Определяет, не равно ли значение в ячейке A5 "Spets". (FALSE)

=OR(A5<>"Spets",A6 = "Widgets")

Определяет, не равно ли значение в ячейке A5 "Spets" или значение в A6 равно "Мини-приложениям". (TRUE)

Дополнительные сведения о том, как использовать эти функции, см. в разделах "Функции AND", "OR" и "НЕ".

К началу страницы

Создание условной формулы, которая приводит к другому вычислению или значениям, отличным от TRUE или FALSE

Для выполнения этой задачи используйте функции и операторы IF, AND и OR , как показано в следующем примере.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Копирование примера

  1. Выделите пример, приведенный в этой статье.

    Важно: Не выделяйте заголовки строк или столбцов.

    выбор примера из справки в Excel 2013 для Windows

    Выделение примера в справке

  2. Нажмите клавиши CTRL+C.

  3. В Excel создайте пустую книгу или лист.

  4. Выделите на листе ячейку A1 и нажмите клавиши CTRL+V.

Важно: Чтобы пример правильно работал, его нужно вставить в ячейку A1.

  1. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (знак ударения) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показывать формулы.

Скопировав пример на пустой лист, вы можете настроить его так, как вам нужно.

Данные

15

9

8

Звездочки

Виджеты

Формула

Описание (результат)

=ЕСЛИ(A2=15, "ОК", "Не ОК")

Если значение в ячейке A2 равно 15, возвращается "ОК". В противном случае возвращается сообщение "Не ОК". (ОК)

=ЕСЛИ(A2<>15, "ОК", "Не ОК")

Если значение в ячейке A2 не равно 15, возвращается значение "ОК". В противном случае возвращается сообщение "Не ОК". (Не ОК)

=ЕСЛИ(НЕ(A2<=15), "ОК", "Не ОК")

Если значение в ячейке A2 не меньше или равно 15, возвращается значение "ОК". В противном случае возвращается сообщение "Не ОК". (Не ОК)

=ЕСЛИ(A5<>"SPROCKETS", "ОК", "Не ОК")

Если значение в ячейке A5 не равно "SPETS", возвращается значение "ОК". В противном случае возвращается сообщение "Не ОК". (Не ОК)

=ЕСЛИ(И(A2>A3, A2<A4), "ОК", "Не ОК")

Если значение в ячейке A2 больше значения В3, а значение в A2 также меньше значения в A4, возвращается "ОК". В противном случае возвращается сообщение "Не ОК". (Не ОК)

=ЕСЛИ(И(A2<>A3, A2<>A4), "ОК", "Не ОК")

Если значение в ячейке A2 не равно A3, а значение в A2 также не равно значению в A4, возвращается "ОК". В противном случае возвращается сообщение "Не ОК". (ОК)

=ЕСЛИ(ИЛИ(A2>A3, A2<A4), "ОК", "Не ОК")

Если значение в ячейке A2 больше значения в A3 или значение в A2 меньше значения в A4, возвращается "ОК". В противном случае возвращается сообщение "Не ОК". (ОК)

=IF(OR(A5<>"Sprockets", A6<>"Widgets"), "OK", "Not OK")

Если значение в ячейке A5 не равно "Spets" или значение в A6 не равно "Widgets", возвращается "ОК". В противном случае возвращается сообщение "Не ОК". (Не ОК)

=ЕСЛИ(ИЛИ(A2<>A3, A2<>A4), "ОК", "Не ОК")

Если значение в ячейке A2 не равно значению в A3 или значение в A2 не равно значению в A4, возвращается "ОК". В противном случае возвращается сообщение "Не ОК". (ОК)

Дополнительные сведения о том, как использовать эти функции, см. в разделах "Функция ЕСЛИ", "И" и " ИЛИ".

К началу страницы

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×