Если книга содержит ссылку на данные в книге или другом файле, перемещенного в другое место, вы можете исправить эту ссылку, обновив путь к исходный файл. Если вам не удалось найти документ, на который вы изначально ссылались, или нет доступа к нему, можно отключить в Excel обновление ссылки, отключив автоматическое обновление или удалив ссылку.

Важно:  связанный объект гиперссылки — это не одно и то же. Следующая процедура не позволит исправить неправиленные гиперссылки. Дополнительные информацию о гиперссылках см. в теме "Создание и изменение гиперссылки".

Исправление неправиленной ссылки

Внимание: Это действие нельзя отменить. Перед началом этой процедуры может потребоваться сохранить резервную копию книги.

  1. Откройте книгу, которая содержит неверную связь.

  2. На вкладке "Данные" нажмите кнопку "Изменить связи".

    Команда "Изменить связи" недоступна, если книга не содержит ссылок.

  3. В поле "Исходный файл" выберите неправиленную ссылку, которую вы хотите исправить.

    Примечание: Чтобы исправить несколько ссылок, щелкните каждую из Клавиша COMMAND, удерживая нажатой Клавиша COMMAND.

  4. Выберите команду Смена источника.

  5. Перейдите к расположению файла, содержащего связанные данные.

  6. Выберите новый исходный файл и нажмите кнопку "Изменить источник".

  7. Нажмите кнопку Закрыть.

Удаление неявной ссылки

При разрыве связи все формулы, которые ссылаются на исходный файл, преобразуются в их текущее значение. Например, если формула =СУММ([Budget.xls]Годовой! C10:C25) — 45, после того как связь не будет нарушена, формула будет преобразована в 45.

  1. Откройте книгу, которая содержит неверную ссылку.

  2. На вкладке "Данные" нажмите кнопку "Изменить связи".

    Команда "Изменить связи" недоступна, если книга не содержит ссылок.

  3. В поле "Исходный файл" выберите ненужную ссылку, которую нужно удалить.

    Примечание: Чтобы удалить несколько ссылок, щелкните каждую из Клавиша COMMAND, удерживая нажатой кнопку мыши.

  4. Щелкните элемент Разорвать.

  5. Нажмите кнопку Закрыть.

Важно:  связанный объект гиперссылки — это не одно и то же. Следующая процедура не позволит исправить неправиленные гиперссылки. Подробнее о гиперссылках: создание, изменение и удаление гиперссылки

Исправление неправиленной ссылки

Внимание: Это действие нельзя отменить. Перед началом этой процедуры может потребоваться сохранить резервную копию книги.

  1. Откройте книгу, которая содержит неверную связь.

  2. В меню Правка выберите пункт Связи.

    Если книга не содержит ссылок, команда "Ссылки" недоступна.

  3. В поле "Исходный файл" щелкните неправиленную ссылку, которую нужно исправить.

    Примечание: Чтобы исправить несколько ссылок, щелкните каждую из Клавиша COMMAND, удерживая нажатой Клавиша COMMAND.

  4. Выберите команду Смена источника.

  5. Выполните одно из следующих действий:

    Задача

    Необходимые действия

    Исправление неправиленной ссылки на лист в другой книге

    В диалоговом окне "Открытие" найдите книгу и нажмите кнопку "Изменить".

    Исправление неправиленной ссылки на книгу или другой документ Office

    Введите новое имя или расположение документа в поле "Изменить ссылки на текстовое поле" и нажмите кнопку "ОК".

Отключение автоматического обновления связанных данных

  1. Откройте книгу, которая содержит неверную связь.

  2. В меню Правка выберите пункт Связи.

    Если книга не содержит ссылок, команда "Ссылки" недоступна.

  3. В поле "Исходный файл" щелкните неправиленную ссылку, которую нужно исправить.

    Примечание: Чтобы исправить несколько ссылок, щелкните каждую из Клавиша COMMAND, удерживая нажатой Клавиша COMMAND.

  4. Нажмите Вручную.

Удаление неявной ссылки

При разрыве связи все формулы, ссылаясь на исходный файл, преобразуются в их текущее значение. Например, если формула =СУММ([Budget.xls]Годовой! C10:C25) — 45, после того как связь не будет нарушена, формула будет преобразована в 45.

  1. Откройте книгу, которая содержит неверную связь.

  2. В меню Правка выберите пункт Связи.

    Если книга не содержит ссылок, команда "Ссылки" недоступна.

  3. В поле "Исходный файл" щелкните ненужную ссылку, которую нужно удалить.

    Примечание: Чтобы удалить несколько ссылок, щелкните каждую из Клавиша COMMAND , удерживая нажатой кнопку мыши.

  4. Щелкните элемент Разорвать.

См. также

Импорт данных из файла в формате CSV, HTML или текстового файла

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×