Ошибка #ДЕЛ/0! возникает в Microsoft Excel, когда число делится на ноль (0). Это происходит, если вы вводите простую формулу, например =5/0, или если формула ссылается на ячейку с 0 или пустую ячейку, как показано на этом рисунке.

Примеры формул, вызывающих #DIV/0! исчезнут.

Есть несколько способов исправления этой ошибки.

  • Убедитесь в том, что делитель в функции или формуле не равен нулю и соответствующая ячейка не пуста.

  • Измените ссылку в формуле, чтобы она указывала на ячейку, не содержащую ноль (0) или пустое значение.

  • Введите в ячейку, которая используется в формуле в качестве делителя, значение #Н/Д, чтобы изменить результат формулы на #Н/Д, указывая на недоступность делителя.

Во многих случаях #DIV/0! из-за того, что формулы ожидают ввода от вас или другого пользователя. В этом случае вы не хотите, чтобы сообщение об ошибке отображались, поэтому существует несколько способов обработки ошибок, которые можно использовать для подавления ошибки при ожидании ввода данных.

Оценка знаменателя на наличие нуля или пустого значения

Самый простой способ избавиться от ошибки #ДЕЛ/0! — воспользоваться функцией ЕСЛИ для оценки знаменателя. Если он равен нулю или пустой, в результате вычислений можно отображать значение "0" или не выводить ничего. В противном случае будет вычислен результат формулы.

Например, если ошибка возникает в формуле =A2/A3, можно заменить ее формулой =ЕСЛИ(A3;A2/A3;0), чтобы возвращать 0, или формулой =ЕСЛИ(A3;A2/A3;""), чтобы возвращать пустую строку. Также можно выводить произвольное сообщение. Пример: =ЕСЛИ(A3;A2/A3;"Ожидается значение."). При этом Excel если(существует A3, возвращается результат формулы, в противном случае игнорируется).

Примеры устранения #DIV/0! исчезнут.

Чтобы скрыть #DIV/0, используйте #DIV.0! #BUSY!

Эту ошибку также можно скрыть, вложенную операцию деления в функцию ЕСЛИERROR. При использовании A2/A3 можно использовать =ЕСЛИERROR(A2/A3;0). Эта формула Excel, если формула возвращает ошибку, возвращает 0, в противном случае возвращает результат формулы.

В версиях до Excel 2007 можно использовать синтаксис ЕСЛИ(ЕОШИБКА()): =ЕСЛИ(ЕОШИБКА(A2/A3);0;A2/A3) (см. статью Функции Е).

Примечание. Как при работе с ifERROR, так и с методом ЕСЛИ(ЕERROR()) используются обработчики всех ошибок, а не только #DIV/0!. Прежде чем применять обработку ошибок, необходимо убедиться, что формула работает правильно. В противном случае вы можете не понимать, что формула работает неправильно.

Совет: Если в Microsoft Excel включена проверка ошибок, нажмите кнопку Значок кнопки рядом с ячейкой, в которой показана ошибка. Выберите пункт Показать этапы вычисления, если он отобразится, а затем выберите подходящее решение.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

См. также

Функция ЕСЛИ

Функция ЕСЛИОШИБКА

Функции Е

Полные сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Поиск ошибок в формулах

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×