Перейти к основному контенту
Поддержка
Войдите с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Выберите другую учетную запись.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой нужно войти.

Источник: служба технической поддержки Майкрософт

Результат

На компьютерах с системой Windows Vista не работает служба брандмауэра Windows. При попытке запустить ее вручную появляется приведенное ниже сообщение об ошибке. Эта проблема может также возникнуть со службой клиента DHCP и службой политики диагностики.

Ниже приведены сообщения об ошибках для службы брандмауэра Windows.

Не удалось запустить брандмауэр Windows на локальном компьютере. Дополнительные сведения содержатся в журнале системных событий. Если эта служба разработана не в Майкрософт, обратитесь к разработчику службы и сообщите специфический для этой службы код ошибки 5.



В журнале системных событий регистрируется указанное ниже событие.

Источник: поставщик журнала событий диспетчера служб.
Код события: 7024
Служба брандмауэра Windows завершена из-за внутренней ошибки 5 (0x5).

Причина

Это сообщение об ошибке означает, что доступ запрещен. Такая ошибка может возникнуть, если учетная запись MpsSvc не имеет разрешений, необходимых для доступа к соответствующим разделам реестра.

Ниже указаны разделы реестра, доступ к которым необходим учетной записи NT Service\MpsSvc.

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Epoch
    Необходимые разрешения: запрос значения; установка значения.

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy 
    Необходимые разрешения: полный доступ; чтение.

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Defaults\FirewallPolicy
    Необходимые разрешения: полный доступ; чтение.


Если указанная проблема возникает со службой клиента DHCP, это может быть связано с отсутствием у учетной записи NT Service\DHCP разрешений, необходимых для доступа к указанным ниже разделам реестра.

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp
    Необходимые разрешения: запрос значения, создание значения, перечисление подразделов, уведомление, контроль чтения.

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp\Configurations
    Необходимые разрешения: полный доступ, чтение.


Если проблема возникает со службой политики диагностики, это может быть связано с отсутствием у учетной записи Trustedinstaller разрешений, необходимых для доступа к указанному ниже разделу реестра.


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DPS\Parameters
Необходимые разрешения: полный доступ, чтение.

Решение

Выполните автоматическую диагностику и исправление распространенных ошибок брандмауэра Windows (примеры приведены ниже).

  • Брандмауэр Windows не является брандмауэром по умолчанию.

  • Брандмауэр Windows не запускается.

  • Системе Windows Vista не удается запустить брандмауэр Windows.

  • Возникла внутренняя ошибка 5 (0x5): удаленный помощник не работает.

  • Не удается получить доступ к общим файлам и принтерам.

Чтобы загрузить и запустить автоматическое средство устранения неполадок, щелкните ссылку Устранить проблему:



Чтобы устранить проблему самостоятельно, добавьте для учетной записи разрешения на доступ к указанным разделам реестра. Например, ниже описано добавление необходимых разрешений для службы брандмауэра Windows.

  1. В редакторе реестра найдите раздел, для которого требуется добавить разрешение.

  2. Щелкните этот раздел правой кнопкой мыши и выберите пункт "Разрешения".

  3. Убедитесь, что в качестве расположения выбран локальный компьютер.

  4. В поле "Введите имена выбираемых объектов" введите "NT SERVICE\mpssvc". Нажмите кнопку "Проверить имя".

  5. Нажмите кнопку "ОК".

  6. Выберите учетную запись в списке и добавьте для нее необходимое разрешение.

  7. Нажмите кнопку "ОК".


Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?
После нажатия кнопки "Отправить" ваш отзыв будет использован для улучшения продуктов и служб Майкрософт. Эти данные будут доступны для сбора ИТ-администратору. Заявление о конфиденциальности.

Спасибо за ваш отзыв!

×