Перейти к основному контенту
Поддержка
Войдите с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Выберите другую учетную запись.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой нужно войти.

Данная статья относится к Microsoft Dynamics NAV для всех стран и всех языковых стандартов.

Симптомы

При авторизации кредитной карты в Microsoft Dynamics NAV 2009 R2, базовая проверка информация передается в службу Microsoft Dynamics NAV Online и затем передается поставщику платежей. В этом случае недостаточно оплаты проверки информация отправляется процесса авторизации, появление сообщение об ошибке о том, не всю необходимую информацию, если с данной транзакцией.
Например может появиться следующее сообщение об ошибке:

Ошибка авторизации транзакции с суммой # .
Код ошибки = 22062;
Сообщение = транзакция было отклонено поставщиком платежа.


Причина

Эта проблема возникает, так как недостаточно сведений проверки отправки процесса авторизации кредитной карты. Для некоторых поставщиков платежа необходимо настроить Microsoft Dynamics Online решение, чтобы предоставить дополнительные сведения о проверке. Например платежей поставщикам в США необходимо указать состояние держателя кредитной карты.

Дополнительные сведения

При авторизации кредитной карты в Microsoft Dynamics NAV 2009 R2, базовая проверка информация передается в службу Microsoft Dynamics Online и затем передается соответствующим поставщиком платежа. Основным сведениям относятся имя держателя кредитной карты, адрес, Страна и почтовый индекс. Тем не менее требования к проверке различаться в зависимости от поставщика платежа, тип кредитной карты и требований банка – выдачи кредитной карты.
Прежде чем запускать процесс авторизации кредитной карты, убедитесь в том, что основные сведения, например имя, адрес, почтовый индекс и т. д., вводится в карточке контакта владельца карты. Для некоторых поставщиков платежа необходимо настроить Microsoft Dynamics Online решение, чтобы предоставить дополнительные сведения о проверке. Например необходимо указать состояние держателя карты для платежей поставщикам в США.

Решение

Сведения об исправлении

Исправление от корпорации Майкрософт доступно. Однако оно предназначено только для устранения проблемы, описанной в этой статье. Предлагаемое исправление должно применяться исключительно в системах, в которых обнаружена эта специфическая неполадка. Это исправление может проходить дополнительное тестирование. Таким образом Если вы не подвержены серьезно эту проблему, рекомендуется дождаться следующего пакета обновления для Microsoft Dynamics NAV или следующей версии Microsoft Dynamics NAV, содержащего это исправление.

Примечание. В особых случаях оплата, предусмотренная в службу поддержки может быть отменена Если специалист службы технической поддержки Microsoft Dynamics и связанных продуктов определит, что решения проблемы является специально выпущенное. Затраты на обычные услуги службы поддержки будут применяться к дополнительным вопросам и проблемам, которые не охватываются конкретным обновлением.



Сведения об установке

Корпорация Майкрософт предлагает примеры программного кода только для иллюстрации и без явных или подразумеваемых гарантий. Это включает, но не ограничиваясь, подразумеваемые гарантии товарной пригодности или пригодности для определенной цели. В данной статье предполагается, что вы знакомы с демонстрируемым языком программирования и средствами, которые используются для создания и отладки. Сотрудники службы поддержки Майкрософт могут объяснить возможности конкретной процедуры, но не выполнять модификации примеров для обеспечения дополнительных функциональных возможностей или создания процедур для определенных требований.

Примечание. Перед установкой данного исправления убедитесь, что все пользователи Microsoft Navision вошли выход из системы. Это включает в себя пользователей клиентских служб приложений Microsoft Navision (NAS). Должен быть только клиент пользователя, который вошел в систему, при реализации данного исправления.

Чтобы реализовать это исправление, необходимо иметь лицензию разработчика.

Рекомендуется, чтобы учетной записи пользователя в окне Логины Windows или в окне Логины базы данных был присвоен идентификатор роли «SUPER» Если учетная запись пользователя не может быть назначена роль «SUPER» идентификатор, необходимо убедиться, что учетная запись пользователя имеет следующие разрешения.

  • Изменение разрешений для объекта, подлежащий изменению.

  • Разрешение Execute для объекта идентификатор объекта системы 5210 и 9015 идентификатор объекта системного объекта.



Примечание. Необходимо иметь права к хранилищам данных, если необходимо выполнить восстановление данных.

Изменения кода

Примечание. Всегда тестовый код исправления в контролируемой среде, прежде чем применить исправления на производственных компьютерах.
Чтобы устранить эту проблему, выполните следующие действия:

  1. Убедитесь, что поле района (92) существует в таблице Contact (5050) и в форме карточки контакта (5050).

  2. Измените код в функцию CreateCreditCardObject в функции сделать центр интеграции платежа (826) следующим образом:
    Существующий код

    ...CreditCardInfo.StreetAddress := Contact.Address;
    CreditCardInfo.PostalCode := Contact."Post Code";
    CreditCardInfo.City := Contact.City;
    CreditCardInfo.CountryOrRegion := Contact."Country/Region Code";
    ...

    Код для замены

    ...CreditCardInfo.StreetAddress := Contact.Address;
    CreditCardInfo.PostalCode := Contact."Post Code";
    CreditCardInfo.City := Contact.City;
    CreditCardInfo.CountryOrRegion := Contact."Country/Region Code";

    // Add the following line.
    CreditCardInfo.StateOrProvince := Contact.County;
    ...

Предварительные условия

Необходимо иметь Microsoft Dynamics NAV 2009 R2 для установки этого исправления.

Сведения об удалении

Установленное обновление удалить нельзя.

Статус

Корпорация Майкрософт подтверждает, что это проблема продуктов Майкрософт, перечисленных в разделе "Относится к".

Примечание. Это статья «БЫСТРАЯ ПУБЛИКАЦИЯ», созданная непосредственно из технической поддержки корпорации Майкрософт. Сведения, содержащиеся в настоящем документе, предоставляются "как есть" в ответ на возникающие проблемы. В результате скорости предоставления материалов они могут включать опечаток и быть изменены в любое время без предварительного уведомления. Другие вопросы, связанные с Условиями использования см.

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?
После нажатия кнопки "Отправить" ваш отзыв будет использован для улучшения продуктов и служб Майкрософт. Эти данные будут доступны для сбора ИТ-администратору. Заявление о конфиденциальности.

Спасибо за ваш отзыв!

×