Email не удается синхронизироваться с Microsoft Dynamics 365 при кодировании с помощью PEC
В этой статье описывается решение проблемы, из-за которой электронная почта не может синхронизироваться с Microsoft Dynamics 365 при кодировании с помощью PEC.
Область применения: Microsoft Dynamics CRM
Исходный номер базы знаний: 4490718
Введение
Что такое сообщения электронной почты по PEC?
Электронные письма PEC — это сертифицированные электронные письма, которые используются в некоторых странах и регионах и имеют такую же юридическую силу, что и зарегистрированные электронные письма (s/mime).
S/MIME (безопасные и многоцелевые расширения электронной почты) — это широко распространенный метод, или, точнее, протокол, для отправки сообщений с цифровой подписью и шифрованием.
S/MIME позволяет шифровать электронные письма и добавлять к ним цифровую подпись.
Симптомы
Сообщения электронной почты PEC не синхронизируются с синхронизацией Server-Side или Email маршрутизатором.
Причина
Server-Side Синхронизация и маршрутизатор Email используют веб-службы Exchange для подключения к Exchange Server.
PEC и RFC6109 не используют API через REST или SOAP, так как Server-Side Синхронизация и маршрутизатор Email не смогут правильно синхронизировать эти сообщения электронной почты.
Решение
При шифровании сообщения электронной почты создается маркер, который отправляется получателю этого сообщения.
Это отношение "один к одному" позволяет пользователю отправлять сообщение электронной почты другому пользователю и шифроваться.
Что происходит при отправке зашифрованного сообщения электронной почты:
Так как Dynamics является сторонним приложением, при попытке получить доступ к электронной почте оно будет получать это сообщение только в зашифрованном состоянии.
Так как маркер не будет существовать в Dynamics 365, сообщение электронной почты не будет расшифровано.
- Уникальный шифр шифрует сообщение электронной почты.
- Сообщение электронной почты закодировано в зашифрованный текст.
- Email отправляется и получается.
- Получатель вводит ключ шифра для декодирования сообщения.
PEC и RFC6109 не используют API через REST или SOAP, так как синхронизация Server-Side и маршрутизатор Email не поддерживает синхронизацию этого типа электронной почты.
Чтобы синхронизировать это сообщение с вашей Dynamics 365 организацией, необходимо удалить шифрование из электронной почты, что можно сделать, переадресовав сообщение.