Пустая страница отображается в Приложении Microsoft Dynamics для Outlook

В этой статье описывается решение проблемы, из-за которой при использовании приложения Dynamics 365 для Outlook на рабочем столе отображается пустая страница.

Область применения: Microsoft Dynamics CRM
Исходный номер базы знаний: 4091345

Симптомы

При попытке использовать приложение Dynamics 365 для Outlook в классическом приложении Outlook вместо загрузки приложения отображается пустая страница.

Причина

Причина 1. Это может произойти, если не все URL-адреса, используемые для проверки подлинности и доступа к Dynamics 365, находятся в одной зоне безопасности Обозреватель Интернета.

Причина 2. Это может произойти, если папка LocalLow имеет неправильный уровень целостности. Правильный параметр заключается в том, чтобы уровень целостности был задан как низкий, как указано в имени папки.

Причина 3. Эта проблема может возникнуть, если проблема кэшируется в Интернете Обозреватель или Edge. Если он ранее работал, но перестал работать в последнее время, это, скорее всего, причина.

Причина 4. Корпорация Майкрософт знает о проблеме, которая может возникнуть при следующих условиях:

  • Вы используете Windows 10 с обновлением 1903 или более поздней версии.
  • Ваша организация настроена на использование Dynamics 365 Online с локальной службой Exchange.
  • Вы используете Office 365 профессиональный плюс с версией до 1910 года.

Решение

Решение 1:
Выполните действия, описанные в статье Об ошибке "Что-то пошло не так во время входа", используя приложение Dynamics 365 для Outlook, чтобы убедиться, что все необходимые URL-адреса находятся в одной зоне безопасности в Интернете Обозреватель.

Решение 2:

  1. Откройте окно командной строки.
  2. Выполните следующую команду:
    icacls %userprofile%\Appdata\LocalLow /t /setintegritylevel (OI)(CI)L

Решение 3.
Если вы используете Office 365 версии 16.0.11629 и Windows 10 версии 1903 или более поздней, выполните следующие действия, так как надстройки Office теперь используют Microsoft Edge WebView для надстроек Office:

  1. Установите Предварительную версию средств разработки Microsoft Edge.
  2. В Outlook запустите приложение Dynamics 365 для Outlook.
  3. Запустите Microsoft Edge DevTools Preview.
  4. Вы должны видеть Dynamics 365 (EXP) в качестве целевого объекта отладки.
  5. Выберите его, чтобы запустить средства F12 .
  6. Перейдите на вкладку Консоль .
  7. Запустите: window.localStorage.clear().
  8. Снова откройте приложение в Outlook.

Если вы используете ранние версии Office 365 и Windows, выполните действия, описанные в статье Устранение ошибок при попытке открыть Dynamics 365 приложение для Outlook, чтобы очистить кэш Обозреватель Интернета.

Если вы используете компьютер Mac, см. раздел Очистка кэша приложения Office на компьютере Mac.

Решение 4.
Если условия, указанные в разделе Причина 4, выполняются, установите версию 1910: 30 октября или более позднюю, включающую исправление для этого типа проблемы.