Ошибка при синхронизации Microsoft Office Outlook с сервером Microsoft Dynamics CRM

В этой статье описывается решение проблемы, из-за которых невозможно синхронизировать Microsoft Office Outlook с клиентом Microsoft Dynamics CRM для Outlook из-за ошибки Уже установлен клиент Microsoft CRM для Outlook на другом компьютере.

Область применения: Microsoft Dynamics CRM 2011 г.
Исходный номер базы знаний: 953774

Симптомы

Клиент Microsoft Dynamics CRM для Microsoft Office Outlook устанавливается с помощью балансировки нагрузки и перемещаемого профиля. Затем вы подключаете клиент к серверу и определяете его как клиент синхронизации. Затем подключите клиент к другому серверу в качестве того же пользователя. При попытке синхронизировать Outlook с клиентом Microsoft Dynamics CRM для Outlook появляется следующее сообщение об ошибке:

Клиент Microsoft CRM для Outlook уже установлен на другом компьютере. Только один клиентский компьютер на пользователя может запустить автоматический процесс, выполняющий массовое обновление элементов Outlook с помощью микрофона. Данные CRM. Этим клиентом должен быть компьютер, который чаще всего находится в сети (например, настольный компьютер) или основной компьютер пользователя. Чтобы изменить клиент синхронизации, в меню CRM выберите пункт Параметры и перейдите на вкладку Синхронизация.

Причина

Эта проблема возникает из-за неправильного HKEY_CURRENT_USER (HKCU) копирования раздела реестра при подключении к новому серверу в сценарии перемещаемого профиля.

Клиент синхронизации определяется записью outlooksyncsubscriptionid реестра и записью outlooksyncclientid реестра. Если записи реестра отсутствуют в HKCU разделе реестра, клиент не считается клиентом синхронизации.

Решение

Чтобы устранить эту неполадку, выполните следующие действия:

  1. Проверьте, присутствуют ли outlooksyncsubscriptionid записи реестра и outlooksyncclientid записи реестра в HKCU\software\microsoft\mscrmclient разделе реестра при подключении к новому серверу.
  2. Если записи реестра отсутствуют в HKCU\software\microsoft\mscrmclient разделе реестра, проверка, включены ли какие-либо из следующих параметров объекта групповая политика (GPO).
    • Запрет распространения изменений перемещаемого профиля на сервер
    • Разрешить только локальные профили пользователей
  3. Если параметры объекта групповой политики включены, отключите их.