Ошибка "Исключение RPC 1726 произошло в сеансе 10" при просмотре журнала приложений на компьютере, на котором выполняются службы AOS Microsoft Dynamics AX

В этой статье приводятся сведения об устранении ошибок, возникающих при проверке журнала приложений на компьютере, на котором выполняются службы Microsoft Dynamics AX 4.0 Application Object Server (AOS).

Применимо к: Microsoft Dynamics AX
Исходный номер базы знаний: 937873

Симптомы

При просмотре журнала приложений на компьютере под управлением microsoft Dynamics AX 4.0 Application Object Server (AOS) могут отображаться сообщения об ошибках, похожие на следующие:

Сообщение об ошибке 1

Тип события:информация
Источник события: Dynamics Server 17
Дата:04.07.2007
Время:12:30:14 pm
Категория события:None
Описание:
Объектный сервер 01: ошибка RPC: в сеансе 10 произошло исключение RPC 1726

Сообщение об ошибке 2

Тип события:информация
Источник события: Dynamics Server 01
Категория события:None
Идентификатор события:110
Дата:04.07.2007
Время:12:30:33
Пользователь:не определен
Computer: ComputerName
Описание:
Объектный сервер 01: нет проверки 10. Прекращение сеанса.

Первое сообщение об ошибке может быть связано со вторым сообщением об ошибке. Пока сервер AOS не завершит сеанс 10, каждый сеанс, возвращающий сообщения об ошибках RPC, перестанет отвечать на запросы. Если слишком много сеансов перестает отвечать на запросы и возвращает сообщения об ошибках RPC, сервер AOS может завершить работу.

Причина

Эта проблема может возникнуть из-за того, что пользователи неграмотно покидают Microsoft Dynamics AX. Например, пользователи завершают процесс Microsoft Dynamics AX с помощью диспетчера задач.

RPC 1726 — это общее сообщение об ошибке подключения. Однако сообщение об ошибке RPC 1726 может быть связано с no ping from 10. Сообщение об ошибке завершения сеанса . В этом случае проблема обычно возникает из-за того, что пользователи не могут выйти из Microsoft Dynamics AX.

Решение

Если у вас возникла эта проблема в клиенте Microsoft Dynamics AX, не выходите из клиента, нажав клавиши CTRL+ALT+DEL. Рекомендуется нажать клавиши CTRL+Break, а затем дождаться, пока система снова станет реагировать, или обратиться к администратору Microsoft Dynamics AX или другому пользователю, у которого есть права на онлайн-форму пользователей. Администратор или другой пользователь может выбрать Завершить сеанс , чтобы завершить сеанс клиента.

Дополнительная информация

При возникновении этой проблемы на сервере AOS важно определить, какой сеанс является причиной и что делают пользователи, чтобы вызвать проблему.

Для этого выполните следующий скрипт:

select * from sysuserlog where logouttime = 0 and sessionid = <X>

Примечание.

Замените <X> сеансом, указанным в сообщении об ошибке RPC. В результатах запроса обратите внимание на столбцы USERID и COMPUTERNAME . Значения столбцов указывают, кто и откуда выполняет вход.

Как правило, исключения RPC вызваны неграмотным выходом из приложения. Однако исключения также могут указывать на то, что бизнес-процесс зависает или занимает много времени.

Ссылки

Дополнительные сведения см. в разделе Поиск идентификатора пользователя, связанного с идентификатором сеанса, в сообщении об ошибке в журнале приложений на сервере AOS в Microsoft Dynamics AX: "Ошибка RPC: исключение RPC 1726 произошло в sessionID<>".