Удаление повторяющихся папок в Outlook при подключении к почтовому ящику Exchange Server

Симптомы

В Microsoft Outlook в почтовом ящике Microsoft Exchange Server отображаются дубликаты папок при просмотре списка папок Outlook или при просмотре списка папок с помощью Outlook Web App (OWA).

Причина

На мобильном устройстве или стороннем серверном приложении, которое синхронизируется с почтовым ящиком Exchange Server, может неожиданно возникнуть дублирование. Кроме того, непредвиденное дублирование может быть результатом Exchange Server обслуживания почтового ящика или других изменений, выполненных на компьютере, на котором выполняется Exchange Server. Другие факторы также могут способствовать проблеме, описанной в разделе Симптомы этой статьи.

Разрешение

Следующие действия могут привести к потере данных, если вы не будете следовать им точно так, как написано. Перед выполнением этих действий рекомендуется создать резервную копию данных Outlook или убедиться, что резервная копия почтового ящика Exchange Server создана.

Чтобы удалить повторяющиеся элементы, выполните следующие действия.

  1. Закройте Outlook и закройте OWA на всех рабочих станциях, подключенных к почтовому ящику пользователя.

  2. Используйте MFCMapi для идентификации повторяющихся папок. Для этого выполните следующие действия:

    1. Скачайте MFCMAPI (прокрутите вниз и выберите Последний выпуск).
    2. Выполните MFCMAPI.exe.
    3. Выберите меню Сервис , а затем выберите Параметры.
    4. Включите следующий параметр:
      • Использование MDB_ONLINE при вызове OpenMsgStore
    5. Нажмите ОК.
    6. В меню Сеанс выберите пункт Вход.
    7. Если появится запрос на ввод профиля, выберите имя профиля и нажмите кнопку ОК.
    8. На верхней панели найдите строку, соответствующую почтовому ящику, и дважды щелкните ее.
    9. В области навигации (область слева) разверните узел Корневой контейнер, а затем разверните узел Top of Information Store.
    10. Чтобы определить повторяющиеся папки, выберите одну из повторяющихся папок на панели слева. На панели справа найдите столбец Значение для PR_CREATION_TIME свойства . Сравните это значение с повторяющимися папками с тем же именем. Повторяющаяся папка будет иметь более новую дату и время создания. Работайте с одной парой папок за раз (например, начните с двух отображаемых папок Календарь).
  3. Используйте MFCMAPI, чтобы скопировать все элементы из папки-дубликата в исходную папку. Это элементы, созданные после создания повторяющихся папок. Сюда могут входить сообщения электронной почты, полученные в папке "Входящие", созданные контакты, запланированные встречи в календаре и собрания, которые вы приняли.

    1. В левой области MFCMAPI дважды щелкните повторяющуюся папку, которая содержит более новую дату и время создания.

    2. В открывавшемся окне выберите верхнюю панель, а затем нажмите клавиши CTRL+A, чтобы выбрать все элементы.

      Если элементы не отображаются в верхней области, папка уже пуста; перейдите к шагу 7.

    3. Выберите меню Действия , а затем выберите команду Копировать сообщения .

    4. Закройте окно папки, а затем дважды щелкните исходную папку с датой и временем создания.

    5. Выберите меню Действия , а затем выберите команду Вставить сообщения .

    6. Установите флажок MESSAGE_MOVE , а затем нажмите кнопку ОК.

    7. Закройте окно папки.

  4. В MFCMAPI вернитесь в повторяющуюся папку, которая теперь пуста. Используйте MFCMAPI, чтобы удалить его.

    1. Щелкните правой кнопкой мыши дубликат папки и выберите команду Удалить папку.
    2. Включите параметр Жесткое удаление и нажмите кнопку ОК.
  5. Повторите шаги 2–4 для других общих папок Outlook (контакты, удаленные элементы, черновики, папка "Входящие", Журнал, нежелательная почта, заметки, отправленные элементы и задачи).

  6. Закройте средство MFCMAPI.

  7. Запустите Outlook с помощью resetfolders параметра:

    1. Откройте диалоговое окно Выполнить. Для этого воспользуйтесь одним из следующих способов, соответствующих вашей версии Windows.

      Windows 10, Windows 8.1 и Windows 8: нажмите клавиши Windows+R.
      Windows 7 и Windows Vista: Нажмите кнопку Пуск , наведите указатель мыши на пункт Все программы, выберите Стандартные, а затем — Выполнить.
      Windows XP: Нажмите кнопку Пуск Windows, а затем выберите Выполнить.

    2. В диалоговом окне Выполнить введите следующее и нажмите кнопку ОК :

      Outlook.exe /resetfolders

Дополнительная информация

Дополнительные сведения о параметрах командной строки в Outlook см. в разделе Параметры командной строки для продуктов Microsoft Office.