Адресат не получает сообщения электронной почты, отправляемые пользователем Microsoft Dynamics CRM с помощью веб-клиента Microsoft Dynamics CRM

Симптомы

Веб-клиент Microsoft Dynamics CRM 3.0

Когда Microsoft Dynamics CRM пользователь отправляет сообщение электронной почты с помощью веб-клиента Microsoft Dynamics CRM 3.0, получатель не получает сообщения электронной почты. Эта проблема возникает при выполнении следующих условий:

  • Компоненты сервера Microsoft Dynamics CRM и Microsoft Exchange Server установлены на отдельных серверах.

  • Во время установки компонентов сервера Microsoft Dynamics CRM введите имя сервера Exchange, имя сервера входящей почты протокола SMTP (простой) и исходящих имя SMTP-сервера.

  • Сервер Microsoft Dynamics CRM имеет локальную службу SMTP установлен.

Примечание. В сервере Microsoft Dynamics CRM можно увидеть неразрешенных сообщений в следующем каталоге:

C:\Inetpub\mailroot\BadmailКроме того может появиться следующее сообщение об ошибке:

«Не удалось инициализировать маркер» инициализировать маркер FailureT

Веб-клиент Microsoft Dynamics CRM 4.0 или Microsoft Dynamics CRM 2011

Когда Microsoft Dynamics CRM пользователь отправляет сообщение электронной почты с помощью веб-клиента Microsoft Dynamics CRM 4.0 или Microsoft Dynamics CRM 2011, сообщение электронной почты отправляется или ставит в очередь. Тем не менее при возникновении ошибки, когда пользователь отправляет сообщение электронной почты, пользователь получает одно из следующих сообщений об ошибке в действия электронной почты.

Сообщение об ошибке 1

Это сообщение еще не были отправлены для доставки. 1 попыток на данный момент.

Сообщение об ошибке 2

Не удается доставить сообщение. Он должен повторно для дальнейшей обработки.

Кроме того появляется сообщение об ошибке, подобное приведенному ниже, в журнале событий MSCRMEmailLog:

Тип события: ошибка

Источник события: MSCRMEmailLog

Категория события: нет

ID:0 событий

Date:Date
Time:Time
User:N/A

Computer:ComputerName
Описание: #61042 - произошла ошибка при обработке исходящего сообщения электронной почты с тему «тест 3 сегодня CRM:0001011» для SMTP: http://adsrv:81/MS1 для доставки через adsrv. System.Net.Mail.SmtpException: Сбой при отправке электронной почты. ---> System.Net.WebException: не удается подключиться к удаленному серверу---> System.Net.Sockets.SocketException: подключение не установлено, т.к. конечный компьютер отверг

в System.Net.Sockets.Socket.DoConnect (конечная точка endPointSnapshot, SocketAddress socketAddress)

в System.Net.Sockets.Socket.InternalConnect (конечная точка remoteEP)

в System.Net.ServicePoint.ConnectSocketInternal (логическое сбой подключения, сокет s4, s6 сокета Socket & сокета, IP-адрес и адрес, состояние ConnectSocketState, IAsyncResult asyncResult, тайм-аут Int32, исключений и исключений)

---Конец трассировки стека внутреннего исключения---

в System.Net.ServicePoint.GetConnection (PooledStream PooledStream, владелец объекта, логическое async, IP-адрес и адрес сокета & abortSocket разъем abortSocket6, время ожидания Int32)

в System.Net.PooledStream.Activate (owningObject объекта, логическое async, время ожидания Int32, GeneralAsyncDelegate asyncCallback)

в System.Net.PooledStream.Activate (объект owningObject, GeneralAsyncDelegate asyncCallback)

в System.Net.ConnectionPool.GetConnection (объект owningObject, GeneralAsyncDelegate asyncCallback, Int32 creationTimeout)

в System.Net.Mail.SmtpConnection.GetConnection (строка хоста, порта Int32)

в System.Net.Mail.SmtpTransport.GetConnection (строка хоста, порта Int32)

в System.Net.Mail.SmtpClient.GetConnection()

в System.Net.Mail.SmtpClient.Send (сообщение MailMessage)

---Конец трассировки стека внутреннего исключения---

в System.Net.Mail.SmtpClient.Send (сообщение MailMessage)

в Microsoft.Crm.Tools.Email.Providers.SmtpPollingSendEmailProvider.SendMessage (MailMessage mailMessage)

в Microsoft.Crm.Tools.Email.Providers.SmtpPollingSendEmailProvider.ProcessMessageInternal (emailMessage электронной почты)

в Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.ProcessMessage (emailMessage электронной почты)

в Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()



Дополнительные сведения см. в http://go.microsoft.com/fwlink/events.asp центра справки и поддержки.

Причина

Microsoft Dynamics CRM использует локальный SMTP-сервер для пересылки сообщений на сервер Exchange. Данная проблема возникает по одной из следующих причин:

  • Настройки SMTP на сервере Microsoft Dynamics CRM не настроен для пересылки сообщений на сервер Exchange.

  • Сервер Exchange не настроен Разрешить ретрансляцию сообщений на сервере Microsoft Dynamics CRM.

Решение

Чтобы устранить эту проблему, выполните следующие действия.

Действие 1: Настройте SMTP на сервере Microsoft Dynamics CRM для пересылки сообщений на сервер Exchange

  1. Откройте Internet Information Services (IIS) на сервере Microsoft Dynamics CRM. Для этого нажмите кнопку Пуск, выберите пункт Администрированиеи щелкните Диспетчер Internet Information Services (IIS).

  2. В диспетчере Internet Information Services (IIS) разверните Виртуальный SMTP-сервер по умолчанию, щелкните правой кнопкой мыши домены, выберите команду Создатьи затем щелкните домен.

  3. В мастере создания SMTP выберите Удаленный в поле Укажите тип доменаи нажмите кнопку Далее.

  4. Введите имя домена в поле имя и нажмите кнопку Готово.

  5. В правой области щелкните правой кнопкой мыши имя домена, которое добавляется в шаги с 2 по 4 и нажмите кнопку Свойства.

  6. На вкладке Общие установите флажок Разрешить ретрансляцию для этого домена входящей почты и затем Пересылать всю почту на направляющий узел. В поле Пересылать всю почту на направляющий узелвведите имя сервера Exchange, а затем нажмите кнопку ОК.

  7. Перезапустите службу SMTP на сервере Microsoft Dynamics CRM. Чтобы сделать это, нажмите кнопку Пуск, выберите пункт Администрированиеи выберите службы. Щелкните правой кнопкой мыши Почтовый протокол SMTP (простой)и выберите пункт перезапустить.

Шаг 2: Настройка сервера Exchange, чтобы разрешить ретрансляцию сообщений на сервере Microsoft Dynamics CRM

Exchange Server 2003

При использовании Microsoft Exchange Server 2003, необходимо сначала настроить ограничения ретрансляции, а затем проверьте подключения элемента управления.

Настройка ограничений ретрансляции
  1. Нажмите кнопку Пуск, выберите пункт программы, выберите пункт Microsoft Exchangeи нажмите кнопку Диспетчер системных.

  2. Выберите серверы, щелкните имя сервера Exchange Server, нажмите кнопку протоколыи щелкните SMTP.

  3. Щелкните правой кнопкой мыши Виртуальный сервер SMTP по умолчанию, выберите команду Свойстваи перейдите на вкладку доступ .

  4. В области Ограничения ретрансляции нажмите кнопку Ретрансляция.

  5. Убедитесь, что выбран параметр только указанные в списке и затем добавить сервер Microsoft Dynamics CRM в список.

    Если вы используете Microsoft Dynamics CRM 4.0 или Microsoft Dynamics CRM 2011, убедитесь, что Добавление сервера Exchange маршрутизатора установлен в список.

  6. Перезапустите службу SMTP. Чтобы сделать это, выполните следующие действия.

    1. Нажмите кнопку Пуск, выберите программы, Администрированиеи выберите службы.

    2. Щелкните правой кнопкой мыши Почтовый протокол SMTP (простой)и выберите пункт перезапустить.

Проверьте подключения элемента управления
  1. Нажмите кнопку Пуск, выберите пункт программы, выберите пункт Microsoft Exchangeи нажмите кнопку Диспетчер системных.

  2. Выберите серверы, щелкните имя сервера Exchange Server, нажмите кнопку протоколыи щелкните SMTP.

  3. Щелкните правой кнопкой мыши Виртуальный сервер SMTP по умолчанию, выберите команду Свойстваи перейдите на вкладку доступ .

  4. В области Управления подключения щелкните подключение.

  5. По умолчанию выбран параметр все, кроме указанных в списке . Если сервер Microsoft Dynamics CRM добавляется в этот список, должны обратитесь к администратору Exchange для определения причины, что был добавлен к серверу Microsoft Dynamics CRM.

    Примечание. Для сообщений электронной почты Microsoft Dynamics CRM для правильной работы сервера Microsoft Dynamics CRM должен иметь возможность подключения к серверу Exchange.

  6. Если выбран параметр только указанные в списке , необходимо добавить сервер Microsoft Dynamics CRM в список для подключения к серверу Exchange.

  7. Если изменены параметры подключения элемента управления перезапустите службу SMTP. Чтобы сделать это, выполните следующие действия.

    1. Нажмите кнопку Пуск, выберите программы, Администрированиеи выберите службы.

    2. Щелкните правой кнопкой мыши Почтовый протокол SMTP (простой)и выберите пункт перезапустить.

Exchange Server 2007

При использовании Microsoft Exchange Server 2007, необходимо создать новый соединитель получения Exchange, настройке соединителя для анонимного пользователя, настроить протокол разрешения для соединителя приема и перезапустите службу транспорта Microsoft Exchange на сервере Exchange.

Exchange создать соединитель получения
  1. Откройте консоль управления Exchange.

  2. Разверните узел Конфигурация сервера.

  3. Выберите транспортный сервер-концентратор.

  4. Щелкните правой кнопкой мыши Соединителей полученияи нажмите кнопку Создать соединитель получения.

  5. Введите имя в поле имя .

  6. В списке выберите назначение для этого соединителя получения выберите Внутреннийи нажмите кнопку Далее.

  7. В разделе Настройки удаленной сети нажмите кнопку Добавитьи введите IP-адрес сервера Microsoft Dynamics CRM.


    Примечание. Если значение 0.0.0.0-255.255.255.255, нажмите кнопку Удалить.

  8. Нажмите кнопку Далее, нажмите кнопку Создатьи затем нажмите кнопку Готово.

Настройка коннектора для анонимного пользователя
  1. Щелкните правой кнопкой мыши Exchange соединителю создан и выберите команду Свойства.

  2. Перейдите на вкладку Группы разрешений .

  3. Убедитесь, что параметр Укажите, кому разрешено подключаться к соединителю получения задать для анонимных пользователей, нажмите кнопку Применитьи нажмите кнопку ОК.

Настройка протокола разрешений для соединителя получения

Примечание. Необходимо иметь средства поддержки Windows для выполнения этих действий. Только опытные администраторы должны использовать средство Adsiedit.msc.

  1. Запустите средство Adsiedit.msc.

  2. Последовательно разверните узлы Конфигурация, разверните узел службы, разверните узел Microsoft Exchange, разверните узел CN = Первая организация, разверните Административные группы, разверните Группу администраторов Exchange, разверните узел серверы, разверните узел протоколыи затем разверните Соединителей получения SMTP.

  3. Щелкните правой кнопкой мыши Exchange соединителю создан и выберите команду Свойства.

  4. Перейдите на вкладку Безопасность.

  5. Выберите Анонимный вход.

  6. Выберите флажки Отправлять сообщения любому адресату и Принять основного домена отправителя , нажмите кнопку Применить,и нажмите кнопку ОК.

Перезапустите службу транспорта Microsoft Exchange на сервере Exchange
  1. Нажмите кнопку Пуск, выберите пункт Выполнить, введите services.msc и нажмите кнопку ОК.

  2. Щелкните правой кнопкой мыши Службу передачи Microsoft Exchangeи выберите пункт перезапустить.

Ссылки

Дополнительные сведения об устранении проблем с входящей и исходящей почты посетите следующий веб-узел Microsoft TechNet:

http://technet.microsoft.com/en-us/library/gg583996.aspxДополнительные сведения о том, как разрешить серверов приложений для ретрансляции из системы Exchange Server 2007 посетите следующий веб-узел корпорации Майкрософт:

http://msexchangeteam.com/archive/2006/12/28/432013.aspx

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединение к программе предварительной оценки Майкрософт

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×