Данные Microsoft Excel не сохраняет форматирование в операциях слияния в Word

Симптомы

При выполнении слияния в Microsoft Word и листа Microsoft Excel использовать в качестве источника данных для списка получателей, некоторые числовые данные могут не сохранять форматирование при объединении.

Это относится к форматированный проценты, денежных значений и почтовые индексы, как показано в следующей таблице:
Format In Excel data In Word MergeField
----------------------------------------------------
Percentage 50% .5
Currency $12.50 12.5
Postal Code 07865 7895

Причина

Это происходит, поскольку данные в списке получателей в Word появится в собственном формате какие магазины Excel, без форматирования, с применением на листе ячейки, которые содержат данные.

Решение

Для решения этой проблемы воспользуйтесь одним из следующих способов.

Способ 1

Соединиться с листа Excel, который содержит данные, которые вы хотите использовать с помощью динамического обмена данными (DDE). Чтобы сделать это, выполните следующие действия.

Microsoft Word 2002 и Word 2003

  1. Запустите Word и откройте новый документ.

  2. В меню Сервис выберите команду Параметрыи откройте вкладку Общие .

  3. Установите флажок Подтверждать преобразование при открытии , а затем нажмите кнопку ОК.

  4. В меню Сервис выберите команду письмаи рассылки и выберите команду Мастер слияния.

  5. В области задач Слияние выберите тип документа, который вы хотите работать и нажмите кнопку Далее.

  6. В разделе Выбор документавыберите начальный документ, который вы хотите использовать и нажмите кнопку Далее.

  7. В разделе Выбор получателейщелкните использовать существующий списоки нажмите кнопку Обзор.

  8. В диалоговом окне Выбор источника данных найдите папку, содержащую книгу Excel, которую требуется использовать в качестве источника данных, выберите ее и нажмите кнопку Открыть.

  9. В диалоговом окне Подтверждение источника данных щелкните Книги MS Excel через DDE (*.xls)и нажмите кнопку ОК.

  10. В диалоговом окне Microsoft Excel, ячейку или именованный диапазонвыберите диапазон ячеек или лист, содержащий данные, которые вы хотите использовать и нажмите кнопку ОК.

    Примечание: данные теперь отображается в окне Получатели слияния с одинаковым форматированием, представленные на листе Excel.

Word 2007 и Word 2010

  1. Запустите Word и откройте новый документ.

  2. Перейдите к параметры Word

    • В Word 2007 нажмите Кнопку Microsoft Officeи нажмите кнопку Параметры Word.

    • В Word 2010 щелкните файли нажмите кнопку Параметры.

  3. На вкладке « Дополнительно » перейдите в раздел « Общие ».

  4. Установите флажок Подтверждать преобразование формата файла при открытии , а затем нажмите кнопку ОК.

  5. На вкладке рассылки нажмите кнопку Начать слияниеи выберите команду Мастер слияния пошаговой.

  6. В области задач Слияние выберите тип документа, который вы хотите работать и нажмите кнопку Далее.

  7. В разделе Выбор документавыберите начальный документ, который вы хотите использовать и нажмите кнопку Далее.

  8. В разделе Выбор получателейщелкните использовать существующий списоки нажмите кнопку Обзор.

  9. В диалоговом окне Выбор источника данных найдите папку, содержащую книгу Excel, которую требуется использовать в качестве источника данных, выберите ее и нажмите кнопку Открыть.

  10. В диалоговом окне Подтверждение источника данных щелкните установите флажок Показать все . Щелкните Книги MS Excel через DDE (*.xls)и нажмите кнопку ОК.

  11. В диалоговом окне Microsoft Excel, ячейку или именованный диапазонвыберите диапазон ячеек или лист, содержащий данные, которые вы хотите использовать и нажмите кнопку ОК.

    Примечание: данные теперь отображается в окне Получатели слияния с одинаковым форматированием, представленные на листе Excel.

Способ 2

Формат поля Microsoft Excel, содержащий почтовый код как текст. Чтобы сделать это, выполните следующие действия.

Microsoft Word 2002 и Word 2003

  1. В Microsoft Excel выберите столбец, содержащий поле Почтовый код.

  2. В меню Формат выберите команду ячейки.

  3. Перейдите на вкладку число .

  4. В списке категориищелкните тексти нажмите кнопку ОК.

  5. Сохраните источник данных. Продолжите операцию слияния в Word.

Word 2007 и Word 2010

  1. В Microsoft Excel выберите столбец, содержащий поле Почтовый код.

  2. На вкладке Главная перейдите в группу ячеек . Затем нажмите кнопку Формати выберите команду Формат ячеек.

  3. Перейдите на вкладку число .

  4. В списке категориищелкните тексти нажмите кнопку ОК.

  5. Сохраните источник данных. Продолжите операцию слияния в Word.

Ссылки

Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:

304387 Дата, номер телефона и денежных полях слияния неправильно при использовании источника данных Access или Excel в Word 2002 или Word 2003

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединение к программе предварительной оценки Майкрософт

Были ли сведения полезными?

Спасибо за ваш отзыв!

×