You have multiple accounts
Choose the account you want to sign in with.

Аннотация

В этой статье описываются известные проблемы при установке Microsoft SQL Server на компьютер под управлением Windows 7 или Windows Server 2008 R2.

Примечания

  • За исключением SQL Server 2008 Express Edition, для всех выпусков, которые выполняются на Windows 7 или Windows Server 2008 R2, должен быть установлен как минимум SQL Server 2008 с пакетом обновления 1 (SP1).

    Примечание. Выпуск Express Edition уже включает пакет обновления 1.

  • Для всех выпусков SQL Server 2005, которые выполняются на Windows 7 или Windows Server 2008 R2, должен быть установлен как минимум SQL Server 2005 с пакетом обновления 3 (SP3).

  • В данной статье термин "Windows 7" означает клиентскую версию Windows 7. Термин "Windows Server 2008 R2" означает серверную версию Windows 7.

  • Подробнее о требованиях к программному обеспечению и оборудованию для различных версий SQL Server см. в документе Требования к оборудованию и программному обеспечению для установки SQL Server 2012.

  • Заметки о выпуске, где перечислены различные проблемы, известные на момент выпуска продукта, см. в документе Заметки о выпуске SQL Server 2012.

Известные проблемы

  • Windows 7 не использует свойство RequireKerberos, чтобы определить, включена ли проверка подлинности Kerberos

    Поскольку Windows 7 не использует свойство RequireKerberos, чтобы определить, включена ли проверка подлинности Kerberos для ресурса сетевого имени, происходит сбой установки отказоустойчивого кластера SQL Server 2008.

  • Если в Windows 7 или Windows Server 2008 R2 включена политика использования федерального стандарта обработки информации (FIPS), происходит сбой проверки кластера в ходе установки SQL Server 2008

    Если в Windows 7 или Windows Server 2008 R2 включена политика FIPS, происходит сбой проверки кластера в ходе установки SQL Server 2008. Поэтому происходит сбой установки.

    Чтобы решить эти две проблемы, нужно установить SQL Server 2008 вместе с пакетом обновления 1 (SP1) для SQL Server 2008 или более поздним обновлением для кластерных установок. Дополнительные сведения о получении пакета обновления 1 (SP1) для операционной системы Microsoft SQL Server 2008 см. в следующей статье базы знаний Майкрософт:

    968382 Как получить последний пакет обновления для SQL Server 2008

    Дополнительные сведения об обновлении установки SQL Server в кластерной и некластерной среде см. в следующей статье базы знаний Майкрософт:

    955392 Как обновить или интегрировать установку SQL Server 2008

  • Возможен сбой установки SQL Server 2008 на Windows Server 2008 R2

    Возможен сбой установки SQL Server 2008 на Windows Server 2008 R2, если платформа Microsoft .NET Framework не включена. Эта проблема возникает потому, что установка .NET Framework 3.5 является необходимым требованием для данной установки.

    В Windows Server 2008 R2 платформа .NET Framework 3.5 является компонентом Windows. По умолчанию платформа .NET Framework 3.5 не включена. Чтобы избежать сбоя установки, нужно включить .NET Framework 3.5 в компонентах Windows и только потом устанавливать SQL Server 2008.

  • Возможен сбой установки SQL Server 2008

    Возможен сбой установки SQL Server 2008 со следующей ошибкой:

    Невозможно вызвать Invoke или BeginInvoke для элемента управления до завершения создания дескриптора окна.

    Для решения этой проблемы можно установить накопительный пакет обновления. Дополнительные сведения см. в следующей статье базы знаний Майкрософт:

    975055 Исправление: при установке SQL Server 2008 на компьютере под управлением Windows 7 появляется сообщение об ошибке: "Невозможно вызвать Invoke или BeginInvoke для элемента управления до завершения создания дескриптора окна".

Дополнительная информация

Минимальные требования к версиям для Windows 7 или Windows Server 2008 R2

Перед установкой SQL Server на компьютер под управлением Windows 7 или Windows Server 2008 R2 нужно выполнить следующие минимальные предварительные требования, соответствующие вашей ситуации.

SQL Server 2008

Кластерные установки

SQL Server 2008 нужно установить вместе с пакетом обновления 1 (SP1) для SQL Server 2008 или более поздним обновлением (такая версия также называется "интегрированной").

Некластерные установки

Сначала нужно установить SQL Server 2008, а затем — пакет обновления 1 (SP1) для SQL Server 2008 или более позднее обновление.

Примечание. Среда выполнения экспресс-выпуска SQL Server 2008 поддерживается в Windows 7 и Windows 2008 R2.

Подробнее о требованиях к программному обеспечению и оборудованию для установки SQL Server 2008 см. на веб-сайте MSDN в статье Требования к оборудованию и программному обеспечению для установки SQL Server 2012.

SQL Server 2005

Сначала нужно установить SQL Server 2005, а затем — пакет обновления 3 (SP3) для SQL Server или более позднее обновление.

Дополнительные сведения о кластерных установках Microsoft SQL Server 2005 см. в следующей статье базы знаний Майкрософт:

973993 Некоторые узлы не обновляются ожидаемым образом при развертывании пакета обновления 3 (SP3) или более позднего обновления в кластере SQL Server 2005 на базе отказоустойчивой кластеризации Windows Server 2008 R2

Дополнительные сведения о получении пакетов обновления для SQL Server 2005 см. в следующей статье базы знаний Майкрософт:

913089 Как получить последний пакет обновления для SQL Server 2005

Подробная информация для SQL Server 2005


Примечание. Среда выполнения экспресс-выпуска SQL Server 2005 с пакетом обновления 2 (SP2) поддерживается в Windows 7 и Windows Server 2008 R2.


.NET Framework

Перед установкой SQL Server 2008 на компьютере под управлением Windows Server 2008 R2 необходимо сначала включить платформу .NET Framework 3.5 с пакетом обновления 1 (SP1). Платформа .NET Framework 3.5 с пакетом обновления 1 (SP1) — необходимое условие для установки SQL Server 2008. В процессе установки SQL Server 2008 будет также установлена платформа .NET Framework 3.5 с пакетом обновления 1 (SP1), если она еще не установлена. Однако для отказоустойчивой кластеризации платформа .NET Framework 3.5 с пакетом обновления 1 (SP1) должна быть установлена до установки отказоустойчивого кластера SQL Server 2008.

В Windows Server 2008 R2 платформа .NET Framework является компонентом системы. Поэтому установить платформу .NET Framework из точки повторного распространения нельзя. Платформу .NET Framework нужно устанавливать из роли сервера или с помощью средства ServerManagerCmd.exe.

Платформу .NET Framework необязательно устанавливать в следующих сценариях:

  • На компьютере, работающем под управлением Windows Server 2008 R2, где платформа .NET Framework 3.5 с пакетом обновления 1 (SP1) уже установлена

  • На компьютере под управлением Windows 7

Примечание. В Windows 7 платформа .NET Framework 3.5 с пакетом обновления 1 (SP1) установлена по умолчанию.

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединение к программе предварительной оценки Майкрософт

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×