Подсказки индекса, которые применяются к таблице $nod$ dbconfig может не работать должным образом в Microsoft Dynamics NAV 4.0

Microsoft Business Solutions Navision 4.0 и Microsoft Navision 4.0 теперь являются частью Microsoft Dynamics NAV 4.0. Все ссылки в Microsoft Business Solutions-Navision или Microsoft Navision 4.0 относятся к Microsoft Dynamics NAV.

Данная статья относится к Microsoft Dynamics NAV 4.0 для всех стран и всех языковых стандартов.

Симптомы

При применении к таблице $nod$ dbconfig подсказки индекса, подсказка индекса не может работать должным образом. При возникновении этой проблемы, подсказка индекса по умолчанию переопределяет подсказку индекса применения. Эта проблема возникает, если выполняются следующие условия:

  • Запустите Microsoft Dynamics NAV 4.0.

  • Примененные обновления 6 для Microsoft Dynamics NAV 4.0 Пакет обновления 3.

Причина

Эта проблема возникает, потому что Microsoft Dynamics NAV не имеет индекс, который должен быть управляемая при использовании определенной комбинации свойств MaintainSQLIndex и подсказки индекса.

Решение

Исправление от корпорации Майкрософт доступно. Исправление устраняет проблему, описанную в данной статье. Исправление необходимо применяйте только в тех системах, где наблюдается данная проблема.

Для немедленного решения этой проблемы в службу технической поддержки Microsoft Dynamics и связанных продуктов для получения исправления. Можно войти на сайт Microsoft Dynamics и создать новый запрос на обслуживание. Чтобы сделать это, посетите следующий веб-сайт корпорации Майкрософт:

https://mbs.microsoft.com/support/newstart.aspxМожно также службу технической поддержки Microsoft Dynamics и связанных продуктов по телефону (888) 477-7877.

Примечание. В особых случаях оплата, предусмотренная в службу поддержки может быть отменена Если специалист службы технической поддержки Microsoft Dynamics и связанных продуктов определит, что решения проблемы является специально выпущенное. Затраты на обычные службы поддержки будет применяться к любые дополнительные вопросы и проблемы, которые не соответствуют требованиям особым обновлением.

Предварительные условия

Не необходимые компоненты необходимы для установки этого исправления.

Сведения об удалении

Установленное обновление удалить нельзя.

Необходимость перезагрузки

При появлении запроса на перезагрузку компьютера после установки исправления необходимо перезагрузить компьютер.

Как получить исправление Microsoft Dynamics NAV или обновления файлов

После запроса файла загрузки или исправления Microsoft Dynamics NAV из службы технической поддержки для Microsoft Dynamics, гиперссылка будет отправлено вам по электронной почте.


Это сообщение будет содержать гиперссылку и пароль. Можно использовать гиперссылки для загрузки исправления Microsoft Dynamics NAV или файлов обновления. Если щелкнуть гиперссылку, откроется диалоговое окно Загрузка файла — предупреждение безопасности . Затем вы предложение запустить, сохранить или отменить загрузку.


Если нажать кнопку выполнить, начнется процесс извлечения и загрузки. Необходимо указать папку для новых файлов и затем указать пароль.


Если нажать кнопку Сохранить, укажите путь для сохранения сжатого файла. При открытии сохраненного файла, вам будет предложено указать путь к файлам. Затем необходимо указать пароль, полученный в сообщении электронной почты.


Если нажать кнопку Отмена, процесс загрузки прекратится.

Установка исправления Microsoft Dynamics NAV или файл обновления

Обновления и исправления платформы Microsoft Dynamics NAV будут доступны как отдельные файлы. Чтобы установить Microsoft Dynamics NAV исправление или обновление, исправление или обновление файлов необходимо заменить существующие файлы установки Microsoft Dynamics NAV.

Если установлен клиент Microsoft Dynamics NAV, необходимо заменить следующие файлы установки клиента Microsoft Dynamics NAV.

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Ndbcs.dll

4.0.3.25321

1,090,680

31-Oct-2007

21:18

x86

Примечание. Клиент Microsoft Dynamics NAV обычно устанавливается в следующий каталог:

Создаваемую бизнес C:\Program решения Navision\Client\Чтобы заменить существующие файлы Microsoft Dynamics NAV, выполните следующие действия.

  1. Закройте Microsoft Dynamics NAV.

  2. Перейдите в каталог установки клиента Microsoft Dynamics NAV.

  3. Скопируйте файлы, которые вы загрузили.

  4. Вставьте в каталоге установки клиента Microsoft Dynamics NAV загруженные файлы.

  5. В диалоговом окне Подтверждение замены файла нажмите кнопку Да, чтобы перезаписать файлы в каталоге установки.

Статус

Корпорация Майкрософт подтверждает, что это проблема продуктов Майкрософт, перечисленных в разделе "Относится к".

Дополнительные сведения

Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:

Описание 824684 Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединение к программе предварительной оценки Майкрософт

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×