Симптом

При попытке использовать приложение Dynamics 365 для Outlook на рабочем столе Outlook вместо загрузки приложения, как ожидалось.

Причина

Причина 1: Это может произойти, если не все URL-адреса, используемые для аутентификации и доступа к Dynamics 365, находятся в одной и той же зоне безопасности Internet Explorer.

Причина 2: Это может произойти, если папка LocalLow имеет неправильный уровень целостности. Правильная настройка заключается в том, чтобы установить уровень целостности до минимума, как указывает имя папки.

Причина 3: Эта проблема может возникнуть, если проблема кэшируется в Internet Explorer или Edge. Если раньше это работало, но бросило работу в последнее время, то это, скорее всего, причина.

Причина 4: Корпорация Майкрософт знает о проблеме, которая может возникнуть при следующих условиях:

  • Вы используете Windows 10 с обновлением 1903 или выше

  • Ваша организация настроена на использование Dynamics 365 Online с Exchange on-premises

  • Вы используете Office 365 ProPlus с версией до 1910 года

Решение

Резолюция 1:

Используйте шаги в следующей статье, чтобы проверить, что каждый из необходимых URL-адресов находятся в одной и той же зоне безопасности Internet Explorer.

https://support.microsoft.com/help/4035750

Резолюция 2:

  1. Откройте окно командной строки.

  2. Выполните следующую команду:

icacls %userprofile%/Appdata-LocalLow /t/setintegritylevel (OI)(CI)L

Резолюция 3:

Если вы используете Office 365 версии 16.0.11629 и Windows 10 версия 1903 или  позже, следуйте этим шагам, как Office Add-ins теперь используют Microsoft Edge WebView:

  1. Установка Microsoft Edge DevTools Предварительный просмотр

  2. В Outlook запустите приложение Dynamics 365 для Outlook

  3. Выполнить Microsoft Edge DevTools Предварительный просмотр

  4. Вы должны увидеть Dynamics 365 (EXP) как цель отладки

  5. Нажмите на него, чтобы запустить "F12" инструменты

  6. Перейдите на вкладку "Консоль"

  7. Запуск: window.localStorage.clear()

  8. Откройте приложение снова в Outlook

Если вы используете ранние версии Office 365 и Windows, используйте следующие действия в следующей статье, чтобы очистить кэш Internet Explorer:

https://support.microsoft.com/en-us/help/4345548

Если вы используете Mac, обратитесь к следующей статье:

https://docs.microsoft.com/office/dev/add-ins/testing/debug-office-add-ins-on-ipad-and-mac#clearing-the-office-applications-cache-on-a-mac

Резолюция 4:

Если условия, упомянутые в Cause 4, верны, установите обновление Office 1910 или позже, которое включает в себя исправление для этого типа проблемы.

 

 

 

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединение к программе предварительной оценки Майкрософт

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?

Что повлияло на вашу оценку?

Добавите что-нибудь? Это необязательно

Спасибо за ваш отзыв!

×