Сбой службы SQL Server с помощью учетных данных домена для запуска

Симптом

После перезапуска SQL Server, службы SQL Server не перейти в оперативный режим и запуск журнала содержит следующие ошибки: 17182, 17826 или 17120.

Примечания.

  • Эта проблема возникает только на экземпляре SQL Server, который выполняется под учетной записью домена.

  • В журнале просмотреть сообщения, которые похожи на следующие примеры записей: Time stamp spid9s Error: 17182, Severity: 16, State: 1. Time stamp spid9s TDSSNIClient initialization failed with error 0xffffffff, status code 0x80. Reason: Unable to initialize SSL support. Time stamp spid9s Error: 17182, Severity: 16, State: 1. Time stamp spid9s TDSSNIClient initialization failed with error 0xffffffff, status code 0x1. Reason: Initialization failed with an infrastructure error. Check for previous errors. Time stamp spid9s Error: 17826, Severity: 18, State: 3. Time stamp spid9s Could not start the network library because of an internal error in the network library. To determine the cause, review the errors immediately preceding this one in the error log. Time stamp spid9s Error: 17120, Severity: 16, State: 1. Time stamp spid9s SQL Server could not spawn FRunCommunicationsManager thread. Check the SQL Server error log and the Windows event logs for information about possible related problems.

     

Причина

Эта проблема возникает из-за отсутствия разрешения, которые обычно предоставляются учетной записи службы SQL. Права пользователя стартовой учетной записи SQL Server, должен присутствовать являются:

  1. Вход в качестве службы (SeServiceLogonRight).

  2. Замена маркера уровня процесса (SeAssignPrimaryTokenPrivilege).

  3. Обход перекрестной проверки (SeChangeNotifyPrivilege).

  4. Настройка квот памяти для процесса.

Решение

Чтобы устранить эту проблему, предоставьте разрешения отсутствует домен учетной записи службы SQL. Дополнительные сведения о службе разрешения обратитесь к разделу службы разрешения в статье Настройка учетных записей служб и разрешения.

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединение к программе предварительной оценки Майкрософт

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?

Что повлияло на вашу оценку?

Добавите что-нибудь? Это необязательно

Спасибо за ваш отзыв!

×