Удаление повторяющихся папок в Outlook при подключении к почтовому ящику Exchange Server

Проблемы

В Microsoft Outlook в почтовом ящике сервера Microsoft Exchange Server отображаются повторяющиеся папки при просмотре списка папок Outlook, а также при просмотре списка папок с помощью Outlook Web App (OWA).

Причина

На мобильном устройстве или стороне сервера стороннего поставщика, которые синхронизируются с почтовым ящиком Exchange Server, может неожиданно возникнуть дублирование. Иногда это может привести к тому, что результаты обслуживания почтового ящика Exchange Server или другие изменения, выполняемые на компьютере с Exchange Server, могут быть непредсказуемыми. Другие факторы могут также влиять на проблемы, описанные в разделе "признаки" этой статьи.

Решение

Описанные ниже действия могут привести к потере данных, если вы не захотите подписаться на них. Рекомендуется создать резервную копию данных Outlook или создать резервную копию почтового ящика сервера Exchange, прежде чем продолжить выполнение этих действий.

Чтобы удалить повторяющиеся элементы, выполните указанные ниже действия.

1. Закройте Outlook и закройте OWA на всех рабочих станциях, которые подключены к почтовому ящику пользователя.

2. Используйте MFCMapi для идентификации повторяющихся папок. Для этого выполните следующие действия:

  1. Скачайте MFCMAPI из GitHub (прокрутите список вниз и выберите пункт последний выпуск).

  2. Запустите MFCMAPI. exe.

  3. В меню Сервис выберите пункт Параметры.

  4. Щелкните, чтобы включить следующий параметр:

    • Использование MDB_ONLINE при вызове OpenMsgStore

  5. Нажмите кнопку ОК.

  6. В меню сеанса выберите пункт Вход.

  7. Если вам будет предложено указать профиль, выберите имя своего профиля и нажмите кнопку ОК.

  8. В верхней области найдите строку, соответствующую почтовому ящику, и дважды щелкните ее.

  9. В области навигации (левая область) разверните элемент корневой контейнер, а затем — элемент хранилище данных.

  10. Чтобы определить дубликат папки, щелкните одну из повторяющихся папок на левой панели. Возвратав области справа найдите столбец value (значение ) для свойства PR_CREATION_TIME . Сравните это значение с дубликатом папки с тем же именем. Повторяющаяся папка будет иметь более новую дату и время создания. Совместное использование одной пары папок (например, начните с двух отображаемых папок календаря).

3. с помощью MFCMAPI скопируйте в исходную папку все элементы из дублированной папки. Это элементы, созданные после создания дубликатов папок. Это может быть адрес электронной почты, полученный в папке "Входящие", созданные вами контакты, назначенные встречи календаря и собранные собрания.

  1. В левой области MFCMAPI дважды щелкните повторяющуюся папку, в которой есть более поздняя дата и время создания.

  2. В открывшемся окне щелкните верхнюю область, а затем нажмите клавиши CTRL + A , чтобы выбрать все элементы. Если на верхней панели нет элементов, папка уже пуста; Перейдите к действию 7.

  3. Щелкните меню действия , а затем выберите команду Копировать сообщения .

  4. Закройте окно папки, а затем дважды щелкните исходную папку, для которой Дата и время создания устарели.

  5. Щелкните меню действия , а затем выберите команду Вставить сообщения .

  6. Нажмите кнопку, чтобы установить флажок MESSAGE_MOVE , а затем нажмите кнопку ОК.

  7. Закройте окно папки.

4. в MFCMAPI переключитесь обратно на повторяющуюся папку, которая теперь пуста. Используйте MFCMAPI, чтобы удалить его.

  1. Щелкните повторяющуюся папку правой кнопкой мыши и выберите команду Удалить папку.

  2. Щелкните, чтобы включить функцию окончательного удаления , а затем нажмите кнопку ОК.

5. Повторите шаги 2 – 4 для других распространенных папок Outlook (контакты, удаленные элементы, Черновики, входящие, журнал, Нежелательная почта, заметки, отправленные элементы и задачи).

6. Закройте MFCMAPI.

7. Запустите Outlook с помощью переключателя ResetFolders :

  1. Открытие диалогового окна "выполнить".  Для этого воспользуйтесь одной из описанных ниже процедур в зависимости от используемой версии Windows. Windows 10, windows 8,1 и Windows 8: нажмите клавиши Windows + R.Windows 7 и Windows Vista: Нажмите кнопку Пуск , наведите указатель на пункт все программы, выберите стандартныеи нажмите кнопку выполнить. Windows XP: Нажмите кнопку Пуск в Windows и выберите команду выполнить.

  2. В диалоговом окне " выполнить " введите следующую команду и нажмите кнопку ОК: Outlook. exe/ResetFolders

Дополнительная информация

Дополнительные сведения о параметрах командной строки в Outlook можно найти в следующих статьях:

http://office.microsoft.com/en-us/outlook-help/command-line-switches-for-microsoft-office-outlook-2007-HP001218589.aspx?CTT=1

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединение к программе предварительной оценки Майкрософт

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×