Сообщение об ошибке "Системное сообщение 5045" в различных расположениях в Microsoft Dynamics SL
В этой статье представлено решение ошибки, которая возникает в различных расположениях в Microsoft Dynamics SL.
Применимо к: Microsoft Dynamics SL
Исходный номер базы знаний: 875699
Симптомы
Рассмотрим следующие сценарии в различных расположениях в Microsoft Dynamics SL.
- Вы пытаетесь войти в Microsoft Dynamics SL. См . причину 1, 2 или 3.
- Кроме того, вы выполняете любое действие, создающее журнал событий Microsoft Dynamics SL. Просмотрите все причины.
- Или нажмите кнопку Пуск на экране Проверка физической целостности базы данных (95.500.00). См . причину 5.
В этих сценариях появляется следующее сообщение об ошибке:
Системное сообщение 5045 — ошибка файла при попытке открыть файл состояния процесса
Причина
Эта проблема возникает по одной или нескольким из следующих причин.
Причина 1
Идентификатор пользователя Windows имеет недостаточные разрешения для операции. См . решение 1.
Причина 2
Неверный логический диск, сопоставленный с установкой Microsoft Dynamics SL. См . решение 2.
Причина 3
Файл Solomon.ini на компьютере рабочей станции поврежден. См . решение 3.
Причина 4
Файлы журнала событий повреждены. См . решение 4.
Причина 5
Таблица PSTATUS повреждена. См . решение 5.
Решение
Чтобы устранить эту проблему, используйте соответствующее решение.
Решение 1
Назначьте соответствующие разрешения пользователям Microsoft Dynamics SL.
- Обратитесь к администратору сети, чтобы убедиться, что идентификатор пользователя Windows имеет достаточные разрешения.
- Убедитесь, что все пользователи Microsoft Dynamics SL имеют полный доступ к каталогу, в котором вы установили Microsoft Dynamics SL. Расположение установки по умолчанию:
- Microsoft Dynamics SL 7.0 и более поздних версий:
DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications
- Microsoft Dynamics SL 6.5 и более ранних версий:
DriveLetter:\Program Files\Solomon\
- Microsoft Dynamics SL 7.0 и более поздних версий:
Решение 2
Поделитесь диском и сопоставьте его правильно. Расположение по умолчанию для установки Microsoft Dynamics SL выглядит следующим образом:
- Microsoft Dynamics SL 7.0 и более поздних версий:
DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications
- Microsoft Dynamics SL 6.5 и более ранних версий:
DriveLetter:\Program Files\Solomon
В этом случае диски с компьютеров рабочей станции должны быть сопоставлены либо с корнем тома, либо с одним из следующих расположений в зависимости от версии:
- Microsoft Dynamics SL 7.0 и более поздних версий:
DriveLetter:\Program Files\Microsoft Dynamics SL\
- Microsoft Dynamics SL 6.5 и более ранних версий:
DriveLetter:\Program Files\
Это означает, что следует совместно использовать корень тома или одно из расположений, которые были рассмотрены ранее. На компьютерах рабочей станции свойства значка для программы main должны быть следующими:
- Microsoft Dynamics SL 7.0 и более поздних версий:
DriveLetter:\SL\Applications\MSDynamicsSL.exe
илиDriveLetter:\Applications\MSDynamicsSL.exe
- Microsoft Dynamics SL 6.5 или более ранних версий:
DriveLetter:\Program Files\Solomon\Parent.exe
илиDriveLetter:\Solomon\Parent.exe
Примечание.
Свойства значка не должны находиться в одном из следующих расположений (что указывает на корень карты):
- Microsoft Dynamics SL 7.0 и более поздних версий:
DriveLetter:\MSDynamicsSL.exe
- Microsoft Dynamics SL 6.5 и более ранних версий:
DriveLetter:\Parent.exe
Свойства Icon не должны находиться в одном из следующих расположений (которое указывает UNC-путь):
- Microsoft Dynamics SL 7.0 и более поздних версий:
\\Servername\sharename\Applications\MSDynamicsSL.exe
- Microsoft Dynamics SL 6.5 и более ранних версий:
\\Servername\sharename\Solomon\Parent.exe
UNC-пути не поддерживаются в Microsoft Dynamics SL или Microsoft Business Solutions ( Соломон).
Решение 3
Переименуйте все файлы Solomon.ini на компьютере рабочей станции в Solomon.old.
Решение 4
Удалите все файлы журнала событий в следующих расположениях:
- Microsoft Dynamics SL 7.0 и более поздних версий:
DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications\Eventlog\
- Microsoft Dynamics SL 6.5 и более ранних версий:
DriveLetter:\Program Files\Solomon\Eventlog\
Решение 5
Удалите поврежденные записи в таблице PSTATUS.
Примечание.
Прежде чем следовать инструкциям, приведенным в этой статье, убедитесь, что у вас есть полная резервная копия базы данных, которую можно восстановить в случае возникновения проблемы.
Используя SQL Server Management Studio или анализатор запросов SQL, выполните следующую инструкцию для базы данных приложения Microsoft Dynamics SL или базы данных приложения Microsoft Business Solutions — Solomon:
Delete from PSTATUS