Ошибка "Ошибка обработчика печати кристалла 709 Не удалось найти таблицу" при запуске пользовательского отчета Crystal Reports

В этой статье приводятся решения проблемы, из-за которых может появиться сообщение Об ошибке " Не удалось найти таблицу " при выполнении настраиваемого отчета Crystal Reports в Microsoft Dynamics SL 2011.

Применимо к: Microsoft Dynamics SL 2011
Исходный номер базы знаний: 939712

Симптомы

Рассмотрим следующий сценарий.

  • Вы используете Microsoft Dynamics SL 2011.
  • Вы используете пользовательский отчет Crystal Reports.
  • Вход выполняется с помощью проверки подлинности Windows.

В этом случае появляется следующее сообщение об ошибке:

Вспомогательное приложение Crystal Reports для Соломона IV
Получение отчета о сбое SQL-запроса: C:\Program Files\Microsoft Dynamics SL\Usr_Rpts\03730DET. RPT
Ошибка обработчика печати: 709 — ошибка в файле C:\Program Files\Microsoft Dynamics SL\Usr_Rpts\03730DET. RPT:

Не удалось найти таблицу.

Причина 1

Эта ошибка возникает из-за того, что выполняются следующие условия:

  • Отчет Crystal Reports использует одну или несколько настраиваемых таблиц или пользовательских представлений.
  • Пользователь E7F575915A2E4897A517779C0DD7CE Microsoft SQL Server или роль приложения SQL Server MSDSL не имеют необходимых разрешений для пользовательской таблицы или пользовательского представления. См. раздел Решение 1 в разделе Разрешение.

Причина 2

Подключение к открытой базе данных (ODBC) неправильно настроено для использования проверки подлинности Windows вместо проверки подлинности SQL Server. При первом запуске отчета Crystal Reports на новой рабочей станции создается подключение ODBC для системной базы данных Microsoft Dynamics SL и базы данных приложения Microsoft Dynamics SL. Это подключение должно быть настроено для использования SQL Server проверки подлинности, даже если для входа в Microsoft Dynamics SL используется проверка подлинности Windows. См. раздел Решение 2 в разделе Разрешение.

Решение 1

Назначьте соответствующие права настраиваемой таблице или пользовательскому представлению. Для этого выполните следующие действия:

  1. Запустите Microsoft SQL Server Management Studio.
  2. Разверните узлы Базы данных, Базы данных Microsoft Dynamics SL, а затем Таблицы или Представления.
  3. Найдите настраиваемую таблицу или настраиваемое представление в списке.
  4. Щелкните правой кнопкой мыши настраиваемую таблицу или настраиваемое представление. Затем выберите Свойства.
  5. На панели Выбор страницы выберите Разрешения.
  6. Нажмите кнопку ДОБАВИТЬ, введите MSDSL, а затем нажмите кнопку ОК.
  7. Для параметра Выбор разрешения выберите поле Предоставить проверка.
  8. Нажмите кнопку ДОБАВИТЬ.
  9. Нажмите кнопку Обзор. Затем выберите поле проверка рядом с пользователем E7F575915A2E4897A517779C0DD7CE.
  10. Нажмите кнопку ОК два раза.
  11. Для разрешения На управление выберите поле Предоставить проверка.

Решение 2

Чтобы устранить эту проблему, удалите подключения ODBC и позвольте Microsoft Dynamics SL повторно создать подключения. Для этого выполните следующие действия:

  1. Нажмите кнопку Пуск, выберите Параметры, а затем панель управления.
  2. Выберите Администрирование.
  3. Выберите Источники данных (ODBC).
  4. На вкладке User DSN удалите все записи для системной базы данных Microsoft Dynamics SL и базы данных приложения Microsoft Dynamics SL.
  5. На вкладке System DSN удалите все записи для системной базы данных Microsoft Dynamics SL и базы данных приложений Microsoft Dynamics SL.
  6. Войдите в Microsoft Dynamics SL еще раз, а затем повторите попытку использования отчета. Записи пользовательского ИМЕНИ DSN должны быть созданы автоматически.