Ошибка "Ошибка обработчика кристаллической печати: не удалось открыть набор строк" при попытке распечатать отчет в Microsoft Dynamics SL

В этой статье описаны способы устранения ошибок, возникающих при попытке печати отчета в Microsoft Dynamics SL.

Применимо к: Microsoft Dynamics SL
Оригинальный номер базы знаний: 905310

Симптомы

При попытке распечатать отчет в Microsoft Dynamics SL или Microsoft Business Solutions — Solomon появляется сообщение об ошибке, аналогичное следующему примеру:

Вспомогательное приложение Crystal Reports для Соломона IV

Не удается запустить задание печати.

Отчет: диск :\Program Files\Solomon\Module_Code\XXXXX. Ошибка модуля печати кристаллов RPT: 723 — ошибка на файловом диске :\Program Files\Solomon\Module_Code\XXXXX. RPT:

Не удалось открыть набор строк.

Примечание.

В этом сообщении об ошибке диск представляет диск, на котором вы установили Microsoft Dynamics SL, Module_Code представляет код модуля, соответствующий модулю Microsoft Dynamics SL, на котором находится отчет, а XXXXX — имя файла отчета.

Причина

Эта проблема возникает по одной или нескольким из следующих причин.

Причина 1

Отчет содержит заметки. См . решение 1.

Причина 2

У вас установлен Microsoft Solomon 6.0, и отчет, который вызывает ошибку, — это распределение учетных записей (01.ACC. Отчет di) . См . решение 2.

Причина 3

Отчет является пользовательским отчетом, который использует препроцесс. См . решение 3.

Причина 4

Имена источников данных (DSN) open DataBase Connectivity (ODBC) отсутствуют или повреждены. См . решение 4.

Причина 5

Параметр для использования идентификаторов с кавычками ANSI не выбран. См . решение 5.

Причина 6

На компьютере, на котором работает Microsoft SQL Server, на котором размещены базы данных Microsoft Dynamics SL или Microsoft Business Solutions — Solomon, недостаточно свободного места. См . решение 6.

Решение

Чтобы устранить эту проблему, используйте соответствующее решение.

Решение 1

Если при попытке напечатать отчет, содержащий заметки, появляется сообщение об ошибке, щелкните, чтобы очистить поле Выбор отдельных записей проверка в меню База данных в Crystal Reports for Solomon.

Решение 2

Если сообщение об ошибке появляется только при попытке распечатать распределение учетной записи (01.ACC. Di) отчет и установка Microsoft Solomon 6.0. Замените файл 01acctdi.rpt, который находится в вашей установке, с помощью файла 01acctdi.rpt с установочного компакт-диска Microsoft Solomon 5.5.

Решение 3

Если при попытке напечатать пользовательский отчет, использующий предварительную обработку, появляется сообщение об ошибке, используйте один из следующих методов.

Способ 1

Добавьте пользовательский отчет в качестве отдельного элемента в структуре меню Microsoft Dynamics SL.

Способ 2

Вложите пользовательский отчет в виде нового формата к существующему отчету, который не использует предварительную обработку. Чтобы присоединить пользовательский отчет, выполните следующие действия.

  1. Запустите Microsoft Dynamics SL.

  2. В меню Служебной программы выберите Пункт Обслуживание управления отчетами.

    Примечание.

    Откроется диалоговое окно Обслуживание управления отчетами (98.300.00).

  3. В поле Номер отчета введите номер отчета, к которому требуется вложить настраиваемый отчет.

  4. Выберите Параметры управления.

  5. Убедитесь, что поле Pre-Process (Предварительная обработка ) пустое. Если поле Pre-Process (Предварительная обработка ) не пустое, вернитесь к шагу 3 и введите другой номер отчета.

  6. В первой пустой строке введите отображаемое имя отчета в поле Имя формата отчета , а затем введите имя файла отчета в поле Формат отчета .

    На этом шаге "отчет" относится к отчету Crystal Reports в Microsoft Windows. Например, введите 01accdi в поле Формат отчета , если имя файла отчета — 01accdi.rpt.

  7. Нажмите кнопку Сохранить. Затем нажмите кнопку Закрыть.

Решение 4

Удалите и повторно создайте имена DSN ODBC базы данных Microsoft Dynamics SL или Microsoft Solomon. Для этого выполните следующие действия:

  1. Выберите Пуск, панель управления, Администрирование, а затем — Источники данных (ODBC).
  2. На вкладке User DSN выберите базу данных Dynamics SL и нажмите кнопку Удалить. Повторите для всех баз данных Dynamics SL, которые отображаются в списке.
  3. На вкладке System DSN выберите системный источник данных, связанный с базой данных Dynamics SL, а затем нажмите кнопку Удалить.
  4. Нажмите ОК.
  5. Чтобы повторно создать имена DSN ODBC, запустите Microsoft Dynamics SL, а затем запустите предварительный просмотр любого отчета.

Решение 5

Включите идентификаторы с кавычками ANSI (Американский институт национальных стандартов). Для этого выполните следующие действия:

  1. Выберите Пуск, панель управления, Администрирование, а затем — Источники данных (ODBC).
  2. На вкладке User DSN выберите соответствующую базу данных и нажмите кнопку Настроить.
  3. Нажмите кнопку Далее.
  4. Укажите соответствующие учетные данные и нажмите кнопку Далее.
  5. Установите флажок Использовать идентификаторы с кавычками ANSI проверка.
  6. Нажмите кнопку Далее.
  7. Нажмите кнопку Готово.
  8. Нажмите кнопку ОК два раза.

Решение 6

Освободите место на диске на компьютере. Для этого удалите ненужные данные или увеличьте емкость диска.