"0x80100065" error when you call the SCardConnect function in Windows 7, Windows Server 2008 R2, Windows 8, and Windows Server 2012

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7, Windows Server 2008 R2, Windows 8, or Windows Server 2012.
  • You plug a Chip/Smart Card Interface Devices (CCID)-compliant smart card reader into the computer. This reader supports the AUTO_PARAMETER_NEGOTIATION feature.
  • You call the SCardConnect function to connect the smart card reader to the computer.
In this scenario, the SCardConnect function returns the following error message:
0x80100065 (SCARD_W_UNSUPPORTED_CARD)

Cause

This issue is caused by a code defect in the Wudfusbcciddriver.dll process.

Resolution

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2 SP1
  • Windows 8
  • Windows Server 2012

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the SCardConnect function, go to the following Microsoft website:
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information
Vlastnosti

ID článku: 2821230 – Posledná kontrola: 3. 5. 2013 – Revízia: 1

Pripomienky