Deployment fails when you deploy Enterprise Portal for Microsoft Dynamics AX 2012 R2

This article applies to Microsoft Dynamics AX for all regions.

Symptoms

When you deploy Enterprise Portal for Microsoft Dynamics AX 2012 R2 in an environment that has the ASP.NET impersonation and the claims-based authentication enabled, the deployment fails. Additionally, you receive the following error message:
Microsoft.Dynamics.Framework.BusinessConnector.Session.Exceptions.NoKernelSessionException

Cause

This problem occurs because Microsoft SharePoint Products and Technologies cannot impersonate either the Microsoft .NET Business Connector (BC) proxy account or a registered account in Microsoft Dynamics AX. By default, the SharePoint worker process runs as the NT Authority\IUSR user account when the claims-based authentication is enabled. Additionally, the SharePoint web application has the following configuration setting in the Web.config file:
AllowAnonymousImpersonation = True
Therefore, the Microsoft Dynamics AX application object server (AOS) denies the request to access the AOS.

Resolution

To resolve this problem, install the hotfix that is described in the "Hotfix information" section. Additionally, you must deploy claims-based Enterprise Portal sites that use forms-based authentication as described in the following Microsoft website:

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, go to the following Microsoft website: You can also contact technical support for Microsoft Dynamics by telephone by using these links for country-specific telephone numbers. To do this, go to one of the following Microsoft websites:

PartnersCustomersIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.


Installation information

If you have customizations for one or more of the methods or the tables that are affected by this hotfix, you must apply these changes in a test environment before you apply the hotfix in a production environment.

For more information about how to install this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
893082 How to install a Microsoft Dynamics AX hotfix

Prerequisites

You must have Microsoft Dynamics AX 2012 R2 installed to apply this hotfix.

Restart requirement

You must restart the Application Object Server (AOS) service after you apply the hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
Vlastnosti

ID článku: 2824690 – Posledná kontrola: 17. 2. 2017 – Revízia: 2

Microsoft Dynamics AX 2012 R2, Enterprise Portal Framework

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