Mobilné zariadenia sa neukladá do karantény očakávaným spôsobom po odstránení Exchange Online

Vzťahuje sa na: Exchange Online

Príznaky


Microsoft Exchange Online, sú niektoré mobilné zariadenia neukladá do karantény podľa očakávania.

Predstavte si napríklad nasledujúci scenár:

  1. Nájomcu služieb Office 365, nakonfigurované nastavenie prístupu služby Exchange ActiveSync karantény - ja sa rozhodnete blokovať alebo povoliť neskôr. Zariadenie karanténe stlačte "nemá." Ak nemá zariadenie, rutiny cmdlet Get-CASMailbox zobrazuje "Povolené" a "Blokované" ActiveSyncAllowedDeviceIDs a ActiveSyncBlockedDeviceIDsparametre.
  2. Neskôr, ktorú chcete odstrániť zariadenie. Môžete to urobiť pomocou jednej z nasledujúcich metód:

    Metóda 1

    1. Vyhľadajte centrum spravovania pre Exchange -> príjemcu -> poštové schránky.
    2. V pravej časti "Mobilné zariadenia", vyberte položku Zobraziť podrobnostia odstráňte zariadenie zo zoznamu mobilné zariadenia.

    Metóda 2

    Rutiny cmdlet Prostredia PowerShell odstrániť MobileDevice .

  3. Po odstránení zariadenia sa používateľ pokúsi pridať alebo konfigurovať rovnaké zariadenie.

V tomto prípade zariadenie nie je v karanténe a môže pripojiť. Office 365 Exchange admin Center, zariadenia údaje používateľa Zobraziť stav "Prístup" a Get-MobileDevice cmdlet ukazuje, že hodnota parametra DeviceAccessState "nemá." Toto nie je očakávaným výsledkom. Namiesto toho očakávate, že zariadenie bude v karanténe.

Príčina


Po odstránení zariadenia (z Office 365 výmeny Admin Center alebo pomocou PowerShell pomocou rutiny cmdlet Remove-MobileDevice ) nie sú ActiveSyncAllowedDeviceIDs a ActiveSyncBlockedDeviceIDs parametre zrušené. Preto pri pokuse používateľa pripojiť pomocou zariadenia, ktoré boli odstránené, zariadenia, Id je stále vyplnený v parametri ActiveSyncAllowedDeviceIDs tak zariadenie nie je v karanténe a môže pripojiť.

Alternatívne riešenie


Zariadenie zabrániť v pripojení, nastavte parametre ActiveSyncAllowedDeviceIDsa ActiveSyncBlockedDeviceIDs$null po odstránení zariadenia. Napríklad, spustite nasledujúci cmdlet:

Set-CASMailbox joe@contoso.com -ActiveSyncAllowedDeviceIDs $null.

Keď sa tieto $null, zariadenie je v karanténe pri pokuse o pripojenie.

Potrebujete ďalšiu pomoc? Prejdite na Microsoft Community.