Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Príznaky

Niektoré klientske aplikácie Microsoft Outlooku majú problémy s pripojením, keď sa v rámci služby dostupnosť služby Accessu, ktoré sú vo verejnom priečinku, čakajú na odpovede zo služby dostupnosti. Tento problém sa vyskytuje napríklad vtedy, keď viac ako 500 vlákien počká na odpovede vo verejnom priečinku.  

Poznámok

  • Nie je k dispozícii žiadna možnosť na zakázanie dostupnosti služby na serveri so spustenou službou Exchange Server 2010 Service Pack (SP1).

  • Po reštartovaní služby Exchange RPC Client Access na serveri verejného priečinka Exchange Server 2010 SP1 je tento problém dočasne vyriešený.

Príčina

Tento problém sa vyskytuje z dôvodu novej funkcie v Exchange serveri 2010 SP1. Táto nová funkcia používa službu Microsoft Exchange RPC Client Access ako proxy pre staršie verzie služby dostupnosť (informácie o voľnom čase). Ak máte verejný priečinok, ktorý je nainštalovaný na serveri Exchange Server 2010 SP1, Služba Microsoft Exchange RPC Client Access zachytí požiadavky na informácie o voľnom čase.

Riešenie

Ak chcete tento problém vyriešiť, použite jeden z nasledujúcich postupov.

Metóda 1



Inovovať všetkých klientov na Outlook 2007 alebo novšiu verziu, ktorá používa služby Exchange Web Services (EWS) na uskutočňovanie hovorov na dostupnosť služieb priamo na server klientskeho prístupu Exchange. 

Metóda 2

Nainštalujte nasledujúcu aktualizáciu na serveroch poštovej schránky Exchange servera 2010 SP1 hosťovaní databázy verejného priečinka:

2497453 Oprava: aplikácia môže prestať reagovať po niekoľkých požiadavkách HTTP sa preruší, ak použijete HttpWebRequest trieda na odoslanie požiadaviek v rozhraní .NET Framework

Metóda 3

Dôležité Táto časť, metóda alebo úloha obsahuje kroky, ktoré vám informujú o tom, ako upraviť databázu Registry. Ak však databázu Registry upravíte nesprávne, môžu nastať vážne problémy. Preto dávajte pozor a postupujte presne podľa týchto krokov. Na dosiahnutie lepšej ochrany je vhodné pred úpravou databázu Registry zálohovať. To vám umožní obnoviť databázu Registry, ak sa vyskytnú problémy. Ďalšie informácie o tom, ako zálohovať a obnovovať databázu Registry, nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné číslo článku:

322756 Ako zálohovať a obnovovať databázu Registry vo Windowse
Upozornenie nasledujúce problémy sa môžu vyskytnúť, ak použijete tento postup:

  • V Office 365 a na lokálnom nasadení servera Exchange Server alebo v združených organizáciách staršie klientov, ako napríklad Microsoft Office Outlook 2007 alebo Microsoft Office Outlook 2003, už nebudú dostávať informácie o voľnom čase z cloudovej lokality alebo vzdialenej organizácie.

  • Najaktuálnejšie údaje o voľnom čase sa nehlásia pre starších klientov. Údaje by mohli byť až 15 minút zastarané.

Ak chcete tento problém vyriešiť, postupujte podľa týchto krokov na poštovom serveri, ktorý hosťuje databázu verejného priečinka:

  1. Kliknutím na nasledujúce číslo článku prejdite na článok v databáze Microsoft Knowledge Base a potom nainštalujte súhrnnú aktualizáciu, ktorá je popísaná v článku:

    2579150 Popis súhrnnej aktualizácie 4 pre Exchange Server 2010 Service Pack 1

  2. Vypnutie služby dostupnosti.

    Ak chcete, aby sme službu dostupnosti vypli za vás po inštalácii Update Rollup 2579150, prejdite na časťOpravte to za mňa. Ak chcete službu dostupnosti radšej vypnúť sami, prejdite na časťja to vyriešim.

    Fix it pre meTo vypnutie služby dostupnosti automaticky, kliknite na spravit tlačidlo alebo prepojenie. Potom kliknite na položku Spustiť v dialógovom okne Preberanie súboru a postupujte podľa krokov v sprievodcovi riešenie Fix it .




    Poznámok

    • Tento sprievodca môže byť dostupný iba v angličtine. Automatická oprava však funguje aj pre ostatné jazykové verzie systému Windows.

    • Ak nie ste v počítači, v ktorom sa vyskytol problém, môžete riešenie Fix it uložiť na jednotku flash alebo na CD disk a potom ho spustiť v počítači, v ktorom sa vyskytol problém.


    Potom prejdite na časť vyriešil saproblém?



    Dovoľte mi spravit myselfAfter nainštalovaním aktualizácie, postupujte podľa týchto krokov na zakázanie dostupnosti služby:

    1. Kliknite na tlačidlo Štart, do poľa Spustiť vyhľadávanie zadajte výraz regedit a potom kliknite na položku regedit.exe.

    2. Vyhľadajte nasledujúci podkľúč databázy Registry a kliknite naň:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\

    3. V ponuke Upraviť ukážte na položku novéa potom kliknite na položku kľúč.

    4. Zadajte ParametersSystem a potom stlačte kláves ENTER.

    5. Vyhľadajte nasledujúci podkľúč databázy Registry a kliknite naň:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem

    6. V ponuke Upraviť ukážte na položku novéa potom kliknite na položku hodnota DWORD.

    7. Zadajte DisableAvailabilityServiceCalls a potom stlačte kláves ENTER.

    8. Na table s podrobnosťami kliknite pravým tlačidlom myši na položku DisableAvailabilityServiceCallsa potom kliknite na položku Upraviť.

    9. Do poľa údaj hodnoty zadajte hodnotu 1 a potom kliknite na tlačidlo OK.

    10. Ukončite Editor databázy Registry.


Vyriešil sa problém?

  • Skontrolujte, či sa problém vyriešil. Ak sa problém vyriešil, dokončili ste sa v tejto časti. Ak sa problém nevyriešil, môžete sa obrátiť na oddelenie technickej podpory.

  • Ocenili by sme vaše pripomienky. Ak chcete poskytnúť pripomienky alebo nahlásiť akékoľvek problémy s týmto riešením, zanechajte komentár k bloguOpravte to za mňaalebo nám odošlite e-mailovú správu.

Stav

Spoločnosť Microsoft potvrdzuje, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v tomto článku v časti Informácie v tomto článku sa týkajú nasledujúcich produktov.

Ďalšie informácie

Ďalšie informácie o službe dostupnosti nájdete na nasledujúcej webovej lokalite Microsoft TechNet:

Dostupnosť služby v službe Exchange 2013

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×