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Symptoms

Consider the following scenario:

  • A user uses Outlook in a Microsoft Exchange Server 2010 environment.

  • The user adds an invalid email address or domain name to the Safe Sender list that is located under Junk E-mail Options. For example, the user adds an email address that is encapsulated in single quotation marks: 'test@domain.com'.

  • You try to manage the junk email rule for the user's mailbox by running the Set-MailboxJunkEmailConfiguration cmdlet with the TrustedSendersAndDomains parameter.

In this scenario, the cmdlet does not run successfully. Additionally, you receive the following error message:

Junk e-mail validation error. Value: email address
+ CategoryInfo : NotSpecified: (0:Int32) [Set-MailboxJunkEmailConfiguration], JunkEmailValidationException
+ FullyQualifiedErrorId : D7CA9FF, Microsoft.Exchange.Management.StoreTasks.SetMailboxJunkEmailConfiguration


Cause

This issue occurs because the Exchange server cannot validate the email addresses in the trusted senders list when the server tries to manage the junk email rules that are stored in the mailbox.

Resolution

To resolve this issue, install the following update rollup:

2645995 Description of Update Rollup 1 for Exchange Server 2010 Service Pack 2

Workaround

To work around the issue, the user must remove the invalid entry from the Safe Sender list in Outlook.

More Information

For more information about the Set-MailboxJunkEmailConfiguration cmdlet visit the following Microsoft website:

General information about the Set-MailboxJunkEmailConfiguration cmdletFor more information about the overview of Junk Email Filter, visit the following Microsoft website:

General information about the overview of Junk Email FilterFor more information about how to delete junk email rules by using MFCMAPI, click the following article number to view the article in the Microsoft Knowledge Base:

2860406How to delete junk email rules by using MFCMAPI in an Exchange Server environment  

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