Momentálne ste offline a čaká sa, kým sa znova pripojíte na internet

Oprava: Nové pripojenia sa neprijímajú na konkrétny webový server proxy alebo webový prijímač Threat Management Gateway 2010

DÔLEŽITÉ: Tento článok je preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft a možno ho opraviť prostredníctvom technológie Community Translation Framework (CTF). Microsoft ponúka strojovo preložené články, články upravené komunitou aj články preložené prekladateľmi, aby zabezpečil prístup ku všetkým článkom databázy Knowledge Base vo viacerých jazykoch. Strojovo preložené články aj upravené články môžu obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky. Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené neprávnym prekladom obsahu alebo jeho použitím zo strany našich zákazníkov. Ďalšie informácie o technológii CTF nájdete na lokalite http://support.microsoft.com/gp/machine-translation-corrections/sk.

Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 2967726
Príznaky
Servera so systémom Microsoft Forefront Threat Management Gateway (TMG) 2010 môže zastaviť prijímanie nových pripojení na konkrétny webový server proxy alebo webový prijímač. Tento problém môže nastať po niekoľkých hodín do niekoľkých dní dostupnosť servera.
Príčina
Tento problém sa vyskytuje, keď TMG prestal prijímať nové pripojenia na webový prijímač. To čoskoro zadá nevybavených frontu zásuvky doplnkových funkcií driver (AFD). Oneskorenie Front je plný, server začne obnoviť nové prichádzajúce pripojenia. Ak server sledovať pomocou Network Monitor v tejto situácii, môžete si všimnúť SYN, ACK/RST vzor pre každý pokus o nové pripojenie.
Riešenie
Ak chcete odstrániť tento problém, nainštalujte Súhrnná 5 pre Forefront Threat Management Gateway (TMG) 2010 Service Pack 2.
Stav
Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.
Ďalšie informácie
Po nainštalovaní súhrnnej 5, musíte zapnúť funkciu na čas mimo nečinnosti prijímanie hovorov. Ak to chcete urobiť, postupujte nasledovne:
  1. Skopírujte nasledujúci skript do programu Poznámkový blok a uložte fileas SetAcceptIdleTimeout.vbs:
    'Define the constants needed.Const strVpsGUID = "{143F5698-103B-12D4-FF34-1F34767DEABC}"Const strVpsPropertyName = "AcceptIdleTimeout"Const Error_FileNotFound = &H80070002Set objArgs = wscript.Argumentsif objArgs.Count > 0 then    uAcceptIdleTimeout = objArgs(0)end ifif objArgs.Count <> 1 then    wscript.echo "Usage: SetAcceptIdleTimeout.vbs <timeout>"    wscript.echo    wscript.echo "Set async accept timeout to <timeout> value (in sec)"    wscript.echo "To disable async accept timeout set it to 0"    wscript.Quit 2end ifset objArray = CreateObject("FPC.Root").GetContainingArray()Set objVPSet = OpenVPSet(objArray, strVpsGUID)objVPSet.Value(strVpsPropertyName) = uAcceptIdleTimeoutobjArray.Save()objArray.RestartServices(1)function OpenVPSet(objParent, strVpsGUID)    Set objVPSets = objParent.VendorParametersSets    On Error Resume Next    Set OpenVPSet = objVPSets.Item(strVpsGUID)    ' Save the Err properties in case it needs to be re-raised    errNumber      = Err.Number    errSource      = Err.Source    errDescription = Err.Description    errHelpFile    = Err.HelpFile    errHelpContext = Err.HelpContext        On Error GoTo 0        if errNumber = Error_FileNotFound Then        Set OpenVPSet = objVPSets.Add(strVpsGUID)    Elseif errNumber < 0 Then        ' An error other than "file not found" occurred -- re-raise the error,        ' this time not under "On Error Resume Next"        Err.Raise errNumber, errSource, errDescription, errHelpFile, errHelpContext    End Ifend function

  2. Spustite skript na jeden zo serverov TMG. Napríklad nastavenie časového limitu 5 minút, spustite nasledujúce správu príkazového riadka:

    cscript.exe SetAcceptIdleTimeout.vbs 300
  3. Aby sa zmeny prejavili, reštartujte službu firewall všetky polia členov.

Konfliktný, spustite nasledujúci príkaz toset limitu nečinnosti na 0:

cscript.exe SetAcceptIdleTimeout.vbs 0

Odkazy
Ďalšie informácie o Terminológia ktorú spoločnosť Microsoft používa na popis aktualizácií softvéru.

Upozornenie: Tento článok bol preložený automaticky.

Vlastnosti

ID článku: 2967726 – Posledná kontrola: 06/23/2015 03:48:00 – Revízia: 2.0

Microsoft Forefront Threat Management Gateway 2010 Enterprise, Microsoft Forefront Threat Management Gateway 2010 Standard

  • kbqfe kbfix kbexpertiseinter kbbug kbsurveynew kbmt KB2967726 KbMtsk
Pripomienky