Služba IIS súhrnné overovanie neumožňuje prejsť-keď overenie požiadavky, ktoré sú smerované prostredníctvom servera proxy

DÔLEŽITÉ: Tento článok je preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft a možno ho opraviť prostredníctvom technológie Community Translation Framework (CTF). Microsoft ponúka strojovo preložené články, články upravené komunitou aj články preložené prekladateľmi, aby zabezpečil prístup ku všetkým článkom databázy Knowledge Base vo viacerých jazykoch. Strojovo preložené články aj upravené články môžu obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky. Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené neprávnym prekladom obsahu alebo jeho použitím zo strany našich zákazníkov. Ďalšie informácie o technológii CTF nájdete na lokalite http://support.microsoft.com/gp/machine-translation-corrections/sk.

Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 3050055
Príznaky
Predstavte si nasledujúcu situáciu:
  • Môžete nastaviť Internet Information Services (IIS) použiť súhrnné overovanie.
  • Server prijme žiadosť, ktorý má ProstredníctvomHlavičky HTTP. (K tomu dochádza, ak presmerovaná požiadavka klienta prostredníctvom servera proxy.)
  • Prostriedkov, ktoré požaduje je chránený súhrnné overovanie.
  • Podriadené požiadavky sa vytvorí v IIS kanála. Napríklad zoznam predvolený dokument sa odošle požiadavka a adresu URL, ktoré sa odosielajú obsahuje lomku (/) ako posledný znak.
V tomto prípade súhrnné overovanie zlyhá a vráti server 401 odpoveď.
Príčina
Požiadavky, ktoré sú smerované prostredníctvom servera proxy a ktoré podriadené požiadavky vytvorené v službe IIS potrubí, IIS nedá dôveryhodnosti súhrnné overovanie z bezpečnostných dôvodov.
Ako problém obísť
Odporúča sa, že riešenie tohto problému nakonfigurovaním webové stránky používať iný typ overenia. Napríklad môžete nastaviť webovej stránky pomocou overovania systému Windows alebo základné overovanie prostredníctvom Transport Layer Security (TLS). Ak nemôžete urobiť, by ste mali používať niektorý z nasledujúcich postupov:
  • Klient použiť požiadavku URL, ktorá obsahuje názov súboru po poslednom /"znakov.
  • Nastavenie fondu aplikácií režime spravovaného kanálaClassic.
  • Použitie Modul URL Rewrite prepísať URL cestu z "/" /názov súboru>."

    Pomocou modulu URL Rewrite vyriešiť tento problém, nakonfigurujte modul takto:

    ----------
    system.webServer>        <rewrite>            <rules>                <rule name="<a rule name>" enabled="false">                    <match url="(^$|.*/$)" />                    <action type="Rewrite" url="{R:0}<a file name that you want the users to access>" />                </rule>            </rules>        </rewrite></system.webServer>
    ----------
Stav
Spoločnosť Microsoft potvrdila, že ide o chybu v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti „Vzťahuje sa na“.

Upozornenie: Tento článok bol preložený automaticky.

Vlastnosti

ID článku: 3050055 – Posledná kontrola: 06/13/2015 11:39:00 – Revízia: 2.0

Microsoft Internet Information Services 8.5, Microsoft Internet Information Services 8.0, Microsoft Internet Information Services 7.5

  • kbmt KB3050055 KbMtsk
Pripomienky