Príznak
Po registrácii počítača pomocou aplikácie runtime počítača Power Automate sa zobrazí nasledujúce chybové hlásenie: Pri pokuse o registráciu počítača sme nedostali odpoveď. Ďalšie podrobnosti získate kliknutím na položku Ďalšie informácie."
Príčina
Tento problém sa vyskytuje pri pokuse o registráciu počítača a počítač nedostane odpoveď od niektorej z cloudových služieb Power Automate. Môže to byť z mnohých dôvodov:
-
Oneskorenie operácií dataverse
-
Problém s lokálnou alebo sieťovou konfiguráciou
-
Nestabilná sieť v súčasnosti
Riešenie
Existuje niekoľko možných riešení týchto problémov:
-
Latenciu organizácie Dataverse môžete skontrolovať tak, že prejdete na nasledujúcu URL adresu , https://[myorg].crm.dynamics.com/tools/diagnostics/diag.aspx (kde [myorg].crm.dynamics.com je URL adresa vašej organizácie) a kliknete na položku Spustiť. Ak sa v poradí desiatok sekúnd zobrazujú extrémne vysoké latencie, môžete to skúsiť znova, keď sa to zlepší.
-
Ak sa problém vyskytne konzistentne, požiadavka sa môže stratiť z dôvodu konfigurácie počítača alebo siete. Aby registrácia počítača fungovala, služba Power Automate spustená vo vašom počítači (UIFlowService) musí byť schopná kontaktovať vašu organizáciu Dataverse (*.dynamics.com), prenos azure (*.servicebus.windows.net) a službu Power Automate (*.gateway.prod.island.powerapps.com). Ak sa vyskytnú tieto riešenia, existujú dve možné riešenia:
-
Ak je prístup k vonkajšej sieti obmedzený na určitých používateľov, môžete zmeniť konto, v akom je služba Power Automate spustená v počítači. Pozrite si tento článok o tom, ako zmeniť toto konto.
-
Ak máte server proxy, skontrolujte, či je správne nakonfigurovaný tak, aby služba Power Automate mohla získať prístup k službe Dataverse. Prečítajte si tento článok.
-
-
Ak je vaša sieť všeobecne nestabilná, skúste sa znova zaregistrovať, keď sa stabilizuje.