Používanie čítačky obrazovky na vytvorenie grafu vo formulári v počítačových databázach Accessu

Nahlas prečítajte symbol s označením Obsah čítačky obrazovky. Táto téma sa zaoberá používaním čítačky obrazovky s balíkom Office

Tento článok je určený pre ľudí so zrakovým postihnutím, ktorí s produktmi balíka Office používajú program na čítanie obrazovky. Je súčasťou obsahu lokality Office Accessibility. Všeobecnú pomoc nájdete na domovskej stránke podpory pre Office.

Pomocou Access s klávesnicou a čítačkou obrazovky môžete vytvoriť koláčový, stĺpcový alebo čiarový graf vo formulári. Testovali sme ho s čítačkami Moderátor, JAWS a NVDA, ale môže fungovať aj s inými čítačkami obrazovky, pokiaľ dodržujú bežné normy a techniky zjednodušenia ovládania. Dozviete sa tiež, ako formátovať, zmeniť veľkosť alebo premiestniť graf.

Do formulára môžete pridať graf na vizualizáciu údajov. Graf môžete zviazať s tabuľkou alebo dotazom a prispôsobiť ho pomocou pestrej palety vlastností.

Ďalšie informácie o grafoch a o tom, ako sa rozhodnúť, ktorý graf by ste mali vytvoriť, nájdete v časti Výber najlepšieho typu grafu pre vaše potreby v časti Vytvorenie grafu vo formulári alebo zostave.

Poznámky: 

Obsah tohto článku

Vytvorenie grafu

Ak chcete úspešne vytvoriť graf v programe Access, zviažte graf so zdrojom údajov, napríklad tabuľkou alebo dotazom, a mapte polia k dimenziám grafu.

  1. Prejdite na formulár, v ktorom chcete vytvoriť graf, a stlačte kombináciu klávesov Shift + F10. Otvorí sa kontextová ponuka. Stlačením klávesu D otvorte formulár v návrhovom zobrazení.

  2. Ak chcete vybrať typ grafu, stlačte kombináciu klávesov Alt + J, D, H, 1. Otvorí sa ponuka grafu. Použite jeden z nasledovných postupov:

    • Ak chcete vytvoriť koláčový graf, stlačte kláves P.

    • Ak chcete vytvoriť stĺpcový graf, stlačte kláves C.

    • Ak chcete vytvoriť čiarový graf, stlačte kláves L.

  3. Stlačte kláves Enter. Do formulára sa vloží zástupný graf. Otvorí sa tabla Nastavenie grafu.

  4. Ak chcete presunúť zameranie na tablu Nastavenie grafu, stláčajte kláves F6, kým sa neozve položka na table. Možno budete musieť požiadať kolegu, aby vám pomohol identifikovať tablu.

  5. Ak je to potrebné, ak chcete presunúť zameranie na kartu Údaje, stláčajte kombináciu klávesov Shift + Tab, kým sa neozve aktuálna karta. Potom stláčajte kláves so šípkou doprava, kým sa neozve: "Data tab" (Karta Údaje). Zobrazia sa vlastnosti karty.

  6. Ak chcete vybrať alebo zmeniť typ zdroja údajov pre graf, stláčajte kláves Tab, kým sa neozve "Data source" (Zdroj údajov) a za ním aktuálny typ zdroja, napríklad "Table" (Tabuľka). Ak chcete zmeniť typ zdroja údajov, stláčajte kláves so šípkou doľava alebo doprava, kým sa neozve názov typu zdroja.

  7. Stlačte raz kláves Tab. Ozzve sa názov aktuálneho zdroja údajov a potom "Combo box" (Rozbaľovacie pole). Ak nebol vybratý žiadny zdroj údajov, ozzve sa "Combo box" (Rozbaľovacie pole). Ak chcete vybrať alebo zmeniť zdroj údajov, stláčajte kláves so šípkou nadol, kým sa neozve názov želaného zdroja, a stlačte kláves Enter.

    V predvolenom nastavení sa vzorový diagram nahradí živým grafom, ktorý používa prvé dve polia v zdroji údajov ako dimenzie Os (kategória) a Hodnoty (os Y). Často je prvý stĺpec v tabuľke aj primárnym kľúčom, ktorý sa vám ako dimenzia grafu zrejme nehodí.

  8. Ak chcete vytvoriť graf, musíte vybrať aspoň dve polia v možnostiach Os (kategória),Legenda (rad)a Hodnoty (os Y). Ak sa chcete presunúť na požadovanú možnosť, stláčajte kláves Tab, kým sa neozve požadovanú možnosť, napríklad "Axis, category" (Os, kategória). Stláčajte kláves so šípkou nahor alebo nadol, kým sa neozve názov poľa, ktoré chcete použiť. Ak je pole usporiadané ako začiarkavacie políčko, vyberte ho stlačením medzerníka. Ak je pole prepínačom, vyberie sa automaticky pri jeho pohybe. Ďalšie informácie o každej z možností a ich vplyve na graf nájdete v časti Nastavenia údajov v kroku 3 v časti Vytvorenie grafu vo formulári alebo zostave.

Formátovanie grafu

Graf a jeho jednotlivé prvky môžete formátovať. Môžete formátovať aj jednotlivé rady údajov, ktoré sú množinou hodnôt v stĺpci, riadku alebo výseku koláčového grafu zodpovedajúcemu legende grafu. Možnosti formátovania závisia od typu grafu.

Podrobné informácie o vlastnostiach radu údajov, ktoré môžete formátovať, nájdete v časti Nastavenie formátu v kroku 3 v časti Vytvorenie grafu vo formulári alebo zostave.

Formátovanie koláčového grafu

Vlastnosti koláčového grafu môžete upraviť pomocou tably Hárok vlastností. Možno budete musieť požiadať kolegu, aby vám pomohol vybrať vlastnosti, ktoré chcete upraviť v kroku 8.

  1. Otvorte formulár s grafom v návrhovom zobrazení podľa pokynov v časti Vytvorenie grafu.

  2. Stláčajte kláves F6, kým sa neozve "Workspace" (Pracovný priestor) nasledovaný názvom formulára.

  3. Ak chcete presunúť zameranie na graf, stláčajte kláves Tab, kým sa neozve číslo grafu, napríklad "Chart 19, collapsed" (Graf 19, zbalené).

  4. Stlačením klávesu F4 otvorte tablu Hárok vlastností.

  5. Jedenkrát stlačte kláves F6. Zameranie sa presunie na riadok vlastnosti na table Hárok vlastností. Ozzve sa číslo riadka a potom obsah bunky vlastnosti.

  6. Na table Hárok vlastností sa nastavenia ovplyvňujúce vzhľad grafu zvyčajne nachádza na karte Formát. Ak chcete prejsť na kartu a vybrať ju, stláčajte kláves Tab, kým sa neozve názov aktuálne vybratej položky karty, napríklad "Data tab item, selected" (Položka karty Údaje, vybraté). Stláčajte kláves so šípkou doľava alebo doprava, kým sa neozve: "Format tab item" (Položka karty Formátovať). Zobrazia sa vlastnosti karty Formát.

    Tip: Ak chcete skontrolovať všetky dostupné vlastnosti grafu, vyberte kartu Všetko.

  7. Ak chcete presunúť zameranie na zoznam vlastností na vybratej karte, stlačte raz kláves Tab.

  8. Ak chcete prehľadávať vlastnosti vybratej karty, stlačte kláves so šípkou nahor alebo nadol. Ak chcete rozbaliť vedľajšie ponuky, stlačte kombináciu klávesov Alt + šípka nadol. Ak chcete vybrať položku vo vedľajšej ponuka, stláčajte kláves so šípkou nahor alebo nadol, kým sa neozve požadovanú možnosť, a stlačením klávesu Enter ju vyberte. Ak chcete upraviť textové polia, zadajte do poľa novú hodnotu.

  9. Tablu Hárok vlastností zavriete stlačením klávesu F4.

Formátovanie stĺpcového alebo čiarového grafu

  1. Otvorte formulár s grafom v návrhovom zobrazení podľa pokynov v časti Vytvorenie grafu.

  2. Stláčajte kláves F6, kým sa neozve "Workspace" (Pracovný priestor) nasledovaný názvom formulára.

  3. Ak chcete presunúť zameranie na graf, stláčajte kláves Tab, kým sa neozve číslo grafu, napríklad "Chart 19, collapsed" (Graf 19, zbalené).

  4. Ak chcete presunúť zameranie na tablu Nastavenie grafu, stláčajte kláves F6, kým sa neozve položka na table. Možno budete musieť požiadať kolegu, aby vám pomohol identifikovať tablu.

  5. Ak chcete vybrať kartu Formát, stláčajte kombináciu klávesov Shift + Tab, kým sa neozve aktuálna karta, a potom stláčajte kláves so šípkou doprava, kým sa neozve: "Format tab" (Karta Formát).

  6. Ak chcete presunúť zameranie na zoznam vlastností na karte Formát, stlačte raz kláves Tab.

  7. Ak sa chcete presunúť na kartu Formát, stlačte kombináciu klávesov SR + šípka doprava alebo doľava. Ak chcete rozbaliť ponuky, stlačte kombináciu klávesov Alt + šípka nadol. Ak chcete prehľadávať ponuku, stlačte kláves so šípkou nahor alebo nadol. Požadovanú možnosť vyberiete stlačením medzerníka alebo klávesu Enter. Ak chcete upraviť textové polia, zadajte do poľa novú hodnotu.

Zmena veľkosti grafu

  1. Otvorte formulár s grafom v návrhovom zobrazení podľa pokynov v časti Vytvorenie grafu.

  2. Stláčajte kláves F6, kým sa neozve "Workspace" (Pracovný priestor) nasledovaný názvom formulára.

  3. Ak chcete presunúť zameranie na graf, stláčajte kláves Tab, kým sa neozve číslo grafu, napríklad "Chart 19, collapsed" (Graf 19, zbalené).

  4. Stlačením kombinácie klávesov Shift + klávesy so šípkami zmeňte veľkosť grafu. Možno budete potrebovať, aby vám kolega pomohol identifikovať vhodné rozmery grafu.

Premiestnenie grafu

  1. Otvorte formulár s grafom v návrhovom zobrazení podľa pokynov v časti Vytvorenie grafu.

  2. Stláčajte kláves F6, kým sa neozve "Workspace" (Pracovný priestor) nasledovaný názvom formulára.

  3. Ak chcete presunúť zameranie na graf, stláčajte kláves Tab, kým sa neozve číslo grafu, napríklad "Chart 19, collapsed" (Graf 19, zbalené).

  4. Graf môžete presúvať pomocou klávesov so šípkami. Možno budete potrebovať, aby vám kolega pomohol zistiť vhodnú pozíciu v grafe.

Prepojenie grafu na údaje vo formulári alebo zostave

Ak chcete, aby graf pracoval s údajmi vo formulári alebo zostave, zviažte ho s tým istým zdrojom údajom, s akým je zviazaný zdroj alebo zostava. Potom môžete nastaviť zodpovedajúcu hodnotu poľa pre vlastnosti údajov grafu Prepojiť podriadené polia a Prepojiť hlavné polia.

  1. Vytvorte formulár alebo zostavu zviazanú so zdrojom údajov. Podrobné pokyny nájdete v časti Vytvorenie formulára v počítačových databázach Accessu pomocou čítačky obrazovky alebo Vytvorenie zostavy v počítačových databázach Accessu pomocou čítačky obrazovky.

  2. Do formulára alebo zostavy pridajte graf podľa pokynov v časti Vytvorenie grafu. Pri výbere zdroja údajov vyberte rovnaký zdroj ako vo formulári alebo zostave.

  3. Otvorte formulár alebo zostavu v návrhovom zobrazení podľa pokynov v časti Vytvorenie grafu.

  4. Ak chcete presunúť zameranie na graf, stláčajte kláves Tab, kým sa neozve číslo grafu, napríklad "Chart 19, collapsed" (Graf 19, zbalené).

  5. Stlačením klávesu F4 otvorte tablu Hárok vlastností.

  6. Jedenkrát stlačte kláves F6. Zameranie sa presunie na riadok vlastnosti na table Hárok vlastností. Ozzve sa číslo riadka a potom obsah bunky vlastnosti.

  7. Ak chcete prejsť na kartu Údaje a vybrať ju, stláčajte kláves Tab, kým sa neozve názov aktuálne vybratej položky karty, napríklad "Format tab item, selected" (Položka karty Formát, vybraté). Stláčajte kláves so šípkou doľava alebo doprava, kým sa neozve: "Data tab item" (Položka karty Údaje). Zobrazia sa vlastnosti karty Údaje.

  8. Požiadajte kolegu, aby vám pomohol presunúť zameranie na pole vlastnosti Prepojiť podriadené polia alebo Prepojiť hlavné polia.

  9. V poli vybratej vlastnosti stlačte kombináciu klávesov Shift + F10, aby sa otvorila kontextová ponuka. Ak chcete otvoriť dialógové okno Prepojovač polí podformulára, stlačte kláves B.

  10. Dialógové okno Prepojovač polí podformulára obsahuje samostatné ponuky pre hlavné a podriadené polia. Ak sa chcete v dialógovom okne presúvať, stlačte kombináciu klávesu SR + kláves so šípkou doprava alebo doľava. Ak chcete rozbaliť zoznam polí predlohy alebo podriadených polí, stlačte kombináciu klávesov Alt + šípka nadol. Ak chcete prehľadávať zoznam, stlačte kláves so šípkou nadol. Pole, na ktoré chcete vytvoriť prepojenie, vyberiete stlačením klávesu Enter. Možno budete musieť požiadať kolegu, aby vám pomohol prejsť v dialógovom okne.

    Tip: Ak si nie ste istí, ktoré pole použiť, stláčajte kombináciu klávesov SR + kláves so šípkou doprava, kým sa nepresuniete na tlačidlo Navrhnúť, a vyberte ho stlačením klávesu Enter. Access do vybratého poľa vlastnosti sa vloží odporúčané pole.

  11. Uložte formulár alebo zostavu.

  12. Overte, či graf funguje podľa očakávaní vo formulárovom zobrazení alebozobrazení zostavy. Ak chcete aktualizovať graf, filtrujte formulár alebo zostavu podľa poľa kategórie. Možno bude potrebné požiadať kolegu, aby vám pomohol s overením grafu.

Pozrite tiež

Používanie čítačky obrazovky na vytvorenie tabuliek v počítačových databázach Accessu

Používanie čítačky obrazovky na vytvorenie dotazu v počítačových databázach Accessu

Používanie čítačky obrazovky na vytvorenie formulára v počítačových databázach Accessu

Používanie čítačky obrazovky na exportovanie accessovej tabuľky do excelového zošita

Používanie čítačky obrazovky na vloženie excelových údajov do počítačových databáz Accessu

Klávesové skratky pre Access

Používanie čítačky obrazovky na prehľadávanie a navigáciu v Accesse

Technická podpora pre zákazníkov s postihnutím

Cieľom spoločnosti Microsoft je čo najviac uľahčiť prácu všetkým zákazníkom. Ak ste zdravotne postihnutí alebo máte otázky týkajúce sa zjednodušenia ovládania, technickú pomoc vám poskytne oddelenie Microsoft Disability Answer Desk. Tím podpory Disability Answer Desk je školený v používaní mnohých rozšírených pomocných technológií pre ľudí s postihnutím a dokáže poskytnúť pomoc v angličtine, francúzštine, španielčine a americkom posunkovom jazyku. Na lokalite Microsoft Disability Answer Desk nájdete kontaktné údaje pre svoju oblasť.

Ak ako používateľ pôsobíte vo verejnej správe, komerčnej alebo podnikovej sfére, obráťte sa na podnikovú službu Disability Answer Desk.

Potrebujete ďalšiu pomoc?

Rozšírte svoje zručnosti
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pripojiť k Microsoft insiderov chcú

Považujete poskytnuté informácie za užitočné?

Ďakujem za vaše pripomienky!

Ďakujeme vám za pripomienky. Pravdepodobne vám pomôže, ak vás spojíme s pracovníkom podpory pre Office.

×