Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Príznaky

Predstavte si nasledujúcu situáciu:

  • Máte počítač so systémom Windows Server 2008 R2 s nainštalovaná rola službu Vzdialená pracovná plocha.

  • Mnohí používatelia pokúsi prihlásiť alebo odhlásiť zo servera vzdialenej pracovnej plochy v rovnakom čase.

    Poznámka tento problém sa môže vyskytnúť pri pokuse sedem až desať prihlásiť alebo odhlásiť naraz.

V tomto scenári, Remote Desktop server zabraňuje niektoré požiadavky na pripojenie. Okrem toho sa zobrazí nasledujúce chybové hlásenie:


Vzdialené volanie procedúr zlyhala a nevykonali.



Poznámka: Ak sa používateľ pokúsi znova pripojiť, používateľ bude na druhý pokus.

Príčina

Tento problém je spôsobený súbehu v module vzdialeného volania Procedúr.

Riešenie

Informácie o rýchlej oprave

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v systémoch, v ktorých sa vyskytuje problém popísaný v tomto článku. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu.

Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy.

Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na webovej lokalite spoločnosti Microsoft:

http://support.microsoft.com/contactus/?ws=supportPoznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Požiadavky

Ak chcete použiť túto rýchlu opravu, musí byť počítač Windows Server 2008 R2 s nainštalovanou rolou službu Vzdialená pracovná plocha.

Informácie o databáze Registry

Ak chcete použiť rýchlu opravu v tomto balíku, nemáte robiť žiadne zmeny v databáze registry.

Požiadavka na reštartovanie

Po nainštalovaní tejto rýchlej opravy je nutné reštartovať počítač.

Informácie o nahradení rýchlej opravy

Táto rýchla oprava nenahrádza predchádzajúcu rýchlu opravu.

Informácie o súboroch

Angličtina (USA) verzia tejto rýchlej opravy inštaluje súbory, ktorých atribúty sú uvedené v nasledujúcich tabuľkách. Dátumy a časy jednotlivých súborov sú uvedené vo formáte UTC (Coordinated Universal Time). Dátumy a časy pre tieto súbory v lokálnom počítači sú zobrazené v miestnom čase a podľa aktuálneho nastavenia funkcie prechodu na letný čas. Dátumy a časy sa okrem toho môžu zmeniť aj pri vykonávaní určitých operácií so súbormi.

Poznámky k informáciám o súboroch systémov Windows 7 a Windows Server 2008 R2


Dôležité upozornenie: Rýchle opravy systémov Windows 7 a Windows Server 2008 R2 sú súčasťou rovnakých balíkov. Rýchle opravy na stránke žiadosti o rýchlu opravu sú však uvedené pre obidva operačné systémy. Ak chcete požiadať o opravu hotfix, ktorá je určená pre jeden alebo oba operačné systémy, vyberte rýchlu opravu, ktorá je uvedená v časti "Windows 7 alebo Windows Server 2008 R2" na stránke. Vždy si pozrite časti "Vzťahuje sa na" v článkoch, aby ste zistili skutočný operačný systém, pre ktorý je daná rýchla oprava určená.

  • Súbory typu MANIFEST (.manifest) a súbory MUM (.mum) ktoré sa inštalujú pre jednotlivé prostredia, sú uvedené samostatne v sekcii "Ďalší súbor informácie pre systém Windows Server 2008 R2 a Windows 7". Súbory MUM a súbory MANIFEST a priradené súbory katalógu zabezpečenia (.cat), sú veľmi dôležité na zachovanie stavu aktualizovaných súčastí. Súbory katalógov zabezpečenia, pre ktoré nie sú uvedené atribúty, sú podpísané digitálnym podpisom spoločnosti Microsoft.

Pre všetky podporované verzie systému Windows Server 2008 R2 s procesorom x64

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Regapi.dll

6.1.7600.20621

95,232

19-Jan-2010

10:30

x64

Pre všetky podporované verzie systému Windows Server 2008 R2 s procesorom typu IA-64

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Regapi.dll

6.1.7600.20621

183,296

19-Jan-2010

09:01

IA-64

Stav

Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.

Ďalšie informácie

Ďalšie informácie získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:

970689 terminálový server systému Windows Server 2008 zabraňuje žiadosti o spojenie s chybovým hlásením "vzdialené volanie procedúr zlyhala a nevykonali" náhodne za podmienok vysokého prihlásenie a odhlásenie

Ďalšie informácie o terminológii z oblasti aktualizácií softvéru získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:

824684 Popis štandardnej terminológie použitej na popis aktualizácií softvéru od spoločnosti Microsoft

Informácie o ďalších súboroch

Ďalšie informácie o súboroch pre systém Windows Server 2008 R2

Ďalšie súbory pre všetky podporované verzie systému Windows Server 2008 R2 s procesorom x64

Názov súboru

Amd64_461dd0607814fc992a4dbb8700d4d4f6_31bf3856ad364e35_6.1.7600.20621_none_291109329cf552b2.manifest

Verzia súboru

Nevzťahuje sa

Veľkosť súboru

721

Dátum (UTC)

20-Jan-2010

Čas (UTC)

00:43

Platforma

Nevzťahuje sa

Názov súboru

Amd64_f02270b20fa9c8441f320f77f97e60b6_31bf3856ad364e35_6.1.7600.20621_none_a3ebe8236e0f58a5.manifest

Verzia súboru

Nevzťahuje sa

Veľkosť súboru

719

Dátum (UTC)

20-Jan-2010

Čas (UTC)

00:43

Platforma

Nevzťahuje sa

Názov súboru

Amd64_microsoft-windows-t..rvices-registryapis_31bf3856ad364e35_6.1.7600.20621_none_010d9870549d4110.manifest

Verzia súboru

Nevzťahuje sa

Veľkosť súboru

2,431

Dátum (UTC)

19-Jan-2010

Čas (UTC)

13:39

Platforma

Nevzťahuje sa

Názov súboru

Update.mum

Verzia súboru

Nevzťahuje sa

Veľkosť súboru

2,328

Dátum (UTC)

20-Jan-2010

Čas (UTC)

00:43

Platforma

Nevzťahuje sa

Názov súboru

X86_microsoft-windows-t..rvices-registryapis_31bf3856ad364e35_6.1.7600.20621_none_a4eefcec9c3fcfda.manifest

Verzia súboru

Nevzťahuje sa

Veľkosť súboru

2,429

Dátum (UTC)

19-Jan-2010

Čas (UTC)

13:40

Platforma

Nevzťahuje sa

Ďalšie súbory pre všetky podporované verzie systému Windows Server 2008 R2 s procesorom typu IA-64

Názov súboru

Ia64_efeabf0bb7474f83f63a296d8165af2b_31bf3856ad364e35_6.1.7600.20621_none_c53ae327dc6b6120.manifest

Verzia súboru

Nevzťahuje sa

Veľkosť súboru

719

Dátum (UTC)

20-Jan-2010

Čas (UTC)

00:43

Platforma

Nevzťahuje sa

Názov súboru

Ia64_f02270b20fa9c8441f320f77f97e60b6_31bf3856ad364e35_6.1.7600.20621_none_47cef095b5aff06b.manifest

Verzia súboru

Nevzťahuje sa

Veľkosť súboru

718

Dátum (UTC)

20-Jan-2010

Čas (UTC)

00:43

Platforma

Nevzťahuje sa

Názov súboru

Ia64_microsoft-windows-t..rvices-registryapis_31bf3856ad364e35_6.1.7600.20621_none_a4f0a0e29c3dd8d6.manifest

Verzia súboru

Nevzťahuje sa

Veľkosť súboru

2.430

Dátum (UTC)

19-Jan-2010

Čas (UTC)

13:40

Platforma

Nevzťahuje sa

Názov súboru

Update.mum

Verzia súboru

Nevzťahuje sa

Veľkosť súboru

1,684

Dátum (UTC)

20-Jan-2010

Čas (UTC)

00:43

Platforma

Nevzťahuje sa

Názov súboru

X86_microsoft-windows-t..rvices-registryapis_31bf3856ad364e35_6.1.7600.20621_none_a4eefcec9c3fcfda.manifest

Verzia súboru

Nevzťahuje sa

Veľkosť súboru

2,429

Dátum (UTC)

19-Jan-2010

Čas (UTC)

13:40

Platforma

Nevzťahuje sa

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×