Ustvarjanje, nalaganje ali urejanje poizvedbe v Excel (Power Query)

Power Query ponuja več načinov za ustvarjanje in nalaganje Power poizvedb v delovni zvezek. V oknu Možnosti poizvedbe lahko nastavite tudi privzete nastavitve nalaganja poizvedbe.   

Namig      Če želite videti, ali so podatki na delovnem listu oblikovani z dodatkom Power Query, izberite celico s podatki in če se prikaže kontekstni zavihek Poizvedba, so bili podatki naloženi iz dodatka Power Query. 

Selecting a cell in a query to reveal the Query tab

Poznate okolje, v katerem ste Power Query je dobro integriran v Excel uporabniškega vmesnika, še posebej pri uvažanje podatkov, delu s povezavami in urejanju vrtilnih tabel, Excel tabel in imenovanih obsegov. Če se želite izogniti zmešnjavi, morate vedeti, v Excel ali Power Query trenutno uporabljate.

Znani Excel list, trak in mrežo

Trak urejevalnika dodatka Power Query in predogled podatkov 

A typical Excel worksheet Običajen pogled Urejevalnika za Power Query

Na primer, spreminjanje podatkov v delovnem Excel je bistveno drugačno od dodatka Power Query. Povezani podatki, ki jih vidite na delovnem listu Excel, lahko delujejo v ozadju dodatka Power Query za oblikovanje podatkov ali pa tudi ne. Do te težave pride le, če podatke naložite v delovni list ali v podatkovni model iz dodatka Power Query.

Preimenovanje zavihkov delovnega lista    Zavihke delovnih listov je dobro preimenovati na smiseln način, še posebej, če jih imate veliko. Še posebej pomembno je, da razjasnite razliko med delovnim listom s podatki in delovnim listom, ki je naložen iz urejevalnika Power Query. Tudi če imate le dva delovnega lista, enega s tabelo Excel, imenovano List1,in drugo poizvedbo, ustvarjeno z uvozom te tabele Excel, imenovane »Tabela1«,lahko preprosto zamenjate. Vedno je dobra praksa, da privzeta imena zavihkov delovnih listov spremenite v imena, ki so bolj smiselna za vas. Preimenujte na primer List1 v Podatkovna tabela in Tabela1 v Poizvedba tabela. Zdaj je jasno, kateri zavihek ima podatke in kateri zavihek ima poizvedbo.

Ustvarite lahko poizvedbo iz uvoženih podatkov ali pa ustvarite prazno poizvedbo.

Ustvarjanje poizvedbe iz uvoženih podatkov

To je najpogostejši način za ustvarjanje poizvedbe.

  1. Uvozite nekaj podatkov. Če želite več informacij, glejte Uvoz podatkov iz zunanjih virov podatkov.

  2. Izberite celico v podatkih in nato izberite Poizvedba,>Uredi.

Ustvarjanje prazne poizvedbe

Morda boste želeli začeti od začetka. To lahko naredite na dva načina.

  • Izberite Podatkovni> Get Data > From Other Sources in > Blank Query (Prazna poizvedba).

  • Izberite Možnost> get data > Launch Power Query Editor ( > Urejevalnik dodatka Power Query).

Na tej točki lahko ročno dodate korake in formule, če poznate jezik formul M dodatka Power Query.

Lahko pa izberete Osnovno in nato izberete ukaz v skupini Nova poizvedba. Naredite nekaj od tega.

  • Izberite Nov vir, da dodate vir podatkov. Ta ukaz je podoben ukazu Podatkovni> dobi podatke na traku Excel podatkov.

  • Izberite Nedavni viri, da izberete vir podatkov, s tem virom podatkov ste delali. Ta ukaz je podoben ukazu Podatkovni> nedavni viri na traku Excel virih.

  • Izberite Vnesi podatke, da ročno vnesete podatke. Ta ukaz lahko izberete, če želite preskusiti urejevalnik Power Query, neodvisno od zunanjega vira podatkov.

Če predvidevate, da je vaša poizvedba veljavna in nima napak, jo lahko naložite nazaj na delovni list ali v podatkovni model.

Nalaganje poizvedbe iz urejevalnika Power Query

V urejevalniku dodatka Power Query naredite nekaj od tega:

  • Če se želite naložiti v delovni list, izberite Osnovno> Zapri & nalaganje > Zapri & nalaganje.

  • Če se želite naložiti v podatkovni model, izberite Osnovno> Zapri & nalaganje > Zapri & naloži v.

    V pogovornem oknu Uvoz podatkov izberite Dodaj te podatke v podatkovnimodel.

Namig   Včasih je ukaz Naloži v zatemnjen ali onemogočen. To se lahko zgodi, ko prvič ustvarite poizvedbo v delovnem zvezku. Če pride do tega, izberite Zapri nalaganje v& , na novem delovnem listu izberite Podatki > Poizvedbe & Povezave > Poizvedbe, z desno tipko miške kliknite poizvedbo in nato izberite Naloživ . Druga možnost je, da na traku Urejevalnik za Power Query izberete Poizvedba> naloži v.

Nalaganje poizvedbe iz podokna »Poizvedbe in povezave« 

V Excel, boste morda želeli poizvedbo naložiti v drug delovni list ali podatkovni model.

  1. V Excel izberite Data> Queries & Connections(Poizvedbe) in nato izberite zavihek Queries (Poizvedbe).

  2. Na seznamu poizvedb poiščite poizvedbo, jo kliknite z desno tipko miške in nato izberite Naloži v. Prikaže se pogovorno okno Uvoz podatkov.

  3. Odločite se, kako želite uvoziti podatke, nato pa izberite V redu. Če želite več informacij o uporabi tega pogovornega okna, izberite vprašaj (?).

Poizvedbo, ki je naložena na delovni list, lahko uredite na več načinov.

Urejanje poizvedbe iz podatkov v Excel delovnem listu

  • Če želite urediti poizvedbo, jo poiščite v urejevalniku dodatka Power Query, izberite celico v podatkih in nato izberite Poizvedba,> Uredi.

Urejanje poizvedbe v podoknu »& povezave«

Podokno Poizvedbe v & Povezavami je priročnejše, če imate v enem delovnem zvezku veliko poizvedb in jo želite hitro najti.

  1. V Excel izberite Data> Queries & Connections(Poizvedbe) in nato izberite zavihek Queries (Poizvedbe).

  2. Na seznamu poizvedb poiščite poizvedbo, jo kliknite z desno tipko miške in nato izberite Uredi.

Urejanje poizvedbe v pogovornem oknu »Lastnosti poizvedbe«

  • V Excel izberite Podatkovne> Podatkovne & Povezave > Poizvedbe, z desno tipko miške kliknite poizvedbo in izberite Lastnosti,v pogovornem oknu Lastnosti izberite zavihek Definicija in nato Uredi poizvedbo.

Namig    Če ste na delovnem listu s poizvedbo, izberite Lastnostipodatkov in >,v pogovornem oknu Lastnosti izberite zavihek Definicija in nato Uredi poizvedbo. 

V podatkovnem modelu je običajno več tabel, ki so razporejene v relaciji. Poizvedbo naložite v podatkovni model z ukazom Naloži v, da prikažete pogovorno okno Uvoz podatkov, nato pa potrdite polje Dodaj te podatke v podatkovni način l. Če želite več informacij o podatkovnih modelih, glejte Ugotovite, kateri viri podatkov so uporabljeni v podatkovnem modelu delovnega zvezka, Ustvarite podatkovni model v programu ExcelinUporaba več tabel za ustvarjanje vrtilne tabele.

  1. Če želite odpreti podatkovni model, izberite Power Pivot >upravljaj.

  2. Na dnu okna Power Pivot izberite zavihek delovnega lista v tabeli, ki jo želite.

    Preverite, ali je prikazana pravilna tabela. Podatkovni model lahko ima veliko tabel.

  3. Bodite seznanjeni z imenom tabele.

  4. Če želite zapreti okno Power Pivot, izberite Datoteka>Zapri. Morda bo trajalo nekaj sekund, da prevzamete pomnilnik.

  5. Izberite podatkovne > povezave & >zavihku Poizvedbe, z desno tipko miške kliknite poizvedbo in nato izberite Uredi.

  6. Ko ste v urejevalniku dodatka Power Query vnešeni spremembe, izberite Datoteka> Zapri & nalaganje.

Rezultat

Poizvedba na delovnem listu in v tabeli v podatkovnem modelu se posodobi.

Če opazite, da nalaganje poizvedbe v podatkovni model traja veliko dlje kot nalaganje na delovni list, si oglejte navodila v dodatku Power Query, da preverite, ali filtrirate stolpec z besedilom ali strukturiran stolpec seznama z operatorjem Vsebuje. S tem Excel znova oštevilcijo celoten nabor podatkov za vsako vrstico. Poleg Excel uporaba večnitebranega izvajanja ne more učinkovito uporabiti. Kot rešitev poskusite uporabiti drug operator, na primer Je enako ali Se začne z.

Microsoft pozna težavo in jo trenutno preiskujemo.

Power Query lahko naložite tako:

  • Na delovni list. V urejevalniku dodatka Power Query izberite Osnovno> Zapri & nalaganje > Zapri & nalaganje.

  • V podatkovni model. V urejevalniku dodatka Power Query izberite Osnovno> Zapri & nalaganje > Zapri & naloživ. 

    Power Query privzeto naloži poizvedbe na nov delovni list pri nalaganju ene poizvedbe in hkrati naloži več poizvedb v podatkovni model.  Privzeto vedenje lahko spremenite za vse delovne zvezke ali le za trenutni delovni zvezek. Ko nastavljate te možnosti, Power Query ne spremeni rezultatov poizvedbe na delovnem listu ali podatkovnega modela in opomb.

    Privzete nastavitve poizvedbe lahko dinamično preglasite tudi v pogovornem oknu Uvozi, ki se prikaže, ko izberete Zapri & naloživ. 

Globalne nastavitve, ki veljajo za vse vaše delovne zvezke

  1. V urejevalniku dodatka Power Query izberite Datoteka> Možnosti in nastavitve >Možnosti poizvedbe.

  2. V pogovornem oknu Možnosti poizvedbe na levi strani v razdelku GLOBAL  izberite Nalaganje podatkov.

  3. V razdelku Default Query Load Nastavitve (Privzeto nalaganje poizvedbe) naredite to:

    • Izberite Uporabi standardne nastavitve nalaganja. 

    • Izberite Določanje privzetih nastavitev nalaganja pomeri , nato pa izberite ali počistite možnost Naloži v delovni  list ali Naloži v podatkovni model.

Namig    Na dnu pogovornega okna lahko izberete Obnovi privzete nastavitve, da se priročno vrnete na privzete nastavitve.

Nastavitve delovnega zvezka, ki veljajo le za trenutni delovni zvezek

  1. V pogovornem oknu Možnosti poizvedbe na levi strani pod razdelkom TRENUTNI DELOVNI ZVEZEK izberite Nalaganje podatkov.

  2. Naredite nekaj od tega:

    • V razdelku Zaznavanjevrste potrdite ali počistite polje Zaznaj vrste stolpcev in glave za nestrukturirane vire.

      Privzeto jih zaznate. Počistite to možnost, če želite podatke oblikovati sami.

    • V razdelkuRelacije potrdite ali počistite polje Ustvari relacije med tabelami pri prvem dodajanju v podatkovni model.

      Pred nalaganjem v podatkovni model morate poiskati obstoječe relacije med tabelami, kot so tuji ključi v relacijski zbirki podatkov, in jih uvoziti s podatki. Če želite to narediti sami, počistite to možnost.

    • V razdelku Relacijepotrdite ali počistite polje Posodobi relacije pri osveževanju poizvedb, ki so naložene v podatkovni model.

      Privzeta nastavitev je, da relacij ne posodabljate. Ko osvežite poizvedbe, ki so že naložene v podatkovni model, Power Query poišče obstoječe relacije med tabelami, kot so tuji ključi v relacijski zbirki podatkov, in jih posodobi. S tem boste morda odstranili relacije, ki ste jih ročno ustvarili po uvozu podatkov ali ko uvedete nove relacije. Če pa želite to narediti, izberite možnost.

    • V razdelku Podatki vozadju izberite ali počistite polje Dovoli predogledom podatkov, da se prenesejo v ozadju.

      Privzeto lahko prenesete predoglede podatkov v ozadju. Če želite takoj videti vse podatke, počistite to možnost.

Glejte tudi

Pomoč za Power Query Excel rabi

Upravljanje poizvedb v Excel

Ali potrebujete dodatno pomoč?

Razširite svoja znanja

Oglejte si izobraževanje >

Prvi dobite nove funkcije

Pridruži se Microsoftu programa Insider >

Vam je bila informacija v pomoč?

Kako ste zadovoljni s kakovostjo jezika?
Kaj je vplivalo na vašo izkušnjo?

Zahvaljujemo se vam za povratne informacije.

×