Uvoz podatkov iz mape z več datotekami (Power Query)

Z dodatkom Power Query združite več datotek z isto shemo, shranjeno v eni mapi, v eno tabelo. Kombinirate lahko na primer delovne zvezke za proračune iz več oddelkov, kjer so stolpci enaki, število vrstic in vrednosti pa se razlikuje v vsakem delovnem zvezku. Ko nastavite podatke, jih lahko osvežite, da si ogledate rezultate za vsak mesec.  

Konceptualni pregled združevanja datotek map

Opomba    V tej temi je prikazano, kako združite datoteke iz mape. Združite lahko tudi datoteke, shranjene v SharePointu, shrambi dvojiških podatkov Azure in shrambi Azure Data Lake Storage. Postopek je podoben.

Ta naj bo preprost:

  • Prepričajte se, da so vse datoteke, ki jih želite združiti, v dodeljeni mapi brez dodatnih datotek.

  • Vsaka datoteka mora imeti isto shemo s skladnimi glavami stolpcev, podatkovami in številom stolpcev. Ni treba, da so stolpci v enakem vrstnem redu kot ujemanje, in so narejeni z imeni stolpcev.

  • Če je mogoče, se izognite nepovezanim podatkovnim predmetom za vire podatkov, ki lahko imajo več podatkovnih predmetov, na primer datoteko JSON, Excelov delovni zvezek ali Accessovo zbirko podatkov.

Vsaka od teh datotek ima preprost vzorec, in sicer le eno tabelo podatkov v vsaki datoteki.

  1. Izberite Možnost > Get Data > From File > From Folder (Dobi podatke iz >iz mape). Prikaže se pogovorno okno Prebrskaj.

  2. Poiščite mapo z datotekami, ki jih želite združiti.

    Opomba     Sporočilo »Noben element se ne ujema z vašim iskanjem« pomeni, da je Power Query našel mapo in je prikazano v polju Ime mape. Datoteke, ki jih želite združiti, so še vedno v mapi, vendar niso vidne.

  3. Seznam datotek v mapi se prikaže v pogovornem oknu <mapa> mape. Preverite, ali so vse datoteke na seznamu.

    Primer pogovornega okna za uvoz besedila

  4. Izberite enega od ukazov na dnu pogovornega okna, na primer Združi> Združi & nalaganje. V razdelku O vseh teh ukazih so opisani dodatni ukazi.

  5. Če izberete kateri koli ukaz Združi, se prikaže pogovorno okno Združevanje datotek. Če želite spremeniti nastavitve datoteke, izberite posamezno datoteko v polju Vzorčna datoteka, nastavite izvor datoteke,ločilo in zaznavanje podatkovnega tipa tako, kot želite. Potrditveno polje Preskoči datoteke z napakami na dnu pogovornega okna lahko tudi potrdite ali počistite.

  6. Izberite V redu.

Rezultat

Power Query samodejno ustvari poizvedbo za usklajevanje podatkov iz vsake datoteke v delovni list. Koraki poizvedbe in stolpci, ki so ustvarjeni, so odvisni od tega, kateri ukaz izberete. Če želite več informacij, glejte razdelek O vseh teh poizvedbah.

  1. Izberite Možnost > Get Data > From File > From Folder (Dobi podatke iz >iz mape). Prikaže se pogovorno okno Prebrskaj.

  2. Poiščite mapo z datotekami, ki jih želite združiti.

    Opomba     Sporočilo »Noben element se ne ujema z vašim iskanjem« pomeni, da je Power Query našel mapo in je prikazano v polju Ime mape. Datoteke, ki jih želite združiti, so še vedno v mapi, vendar niso vidne.

  3. Seznam datotek v mapi se prikaže v pogovornem oknu <mapa> mape. Preverite, ali so vse datoteke na seznamu.

  4. Izberite enega od ukazov na dnu pogovornega okna, na primer Združi> Združi & pretvorbo. V razdelku O vseh teh ukazih so opisani dodatni ukazi.

    Prikaže se Urejevalnik dodatka Power Query.

  5. Stolpec Vrednost je strukturiran stolpec Seznam. Izberite ikono razširi Ikona za razširitev stolpca , nato pa izberite Razširi na nove vrstice. 

    Razširitev seznama JSON

  6. Stolpec Vrednost je zdaj strukturiran stolpec Zapis.  Izberite ikono Ikona za razširitev stolpca . Prikaže se spustno pogovorno okno.

    Razširjanje zapisa JSON

  7. Ohranite vse stolpce izbrane. Morda boste želeli počistiti potrditveno polje Uporabi izvorno ime stolpca kot predpono. Izberite V redu.

  8. Izberite vse stolpce, ki vsebujejo podatkovne vrednosti. Izberite Osnovno, puščico ob možnosti Odstrani stolpce, nato pa izberite Odstrani druge stolpce.

  9. Izberite Osnovno > Zapri & nalaganje.

Rezultat

Power Query samodejno ustvari poizvedbo za usklajevanje podatkov iz vsake datoteke v delovni list. Koraki poizvedbe in stolpci, ki so ustvarjeni, so odvisni od tega, kateri ukaz izberete. Če želite več informacij, glejte razdelek O vseh teh poizvedbah.

Vsak od teh virov podatkov ima lahko več predmetov za uvoz. Excelov delovni zvezek lahko ima več delovnih listov, Excelovih tabel ali imenovanih obsegov. Accessove zbirke podatkov imajo lahko več tabel in poizvedb. 

  1. Izberite Možnost > Get Data > From File > From Folder (Dobi podatke iz >iz mape). Prikaže se pogovorno okno Prebrskaj.

  2. Poiščite mapo z datotekami, ki jih želite združiti.

    Opomba     Sporočilo »Noben element se ne ujema z vašim iskanjem« pomeni, da je Power Query našel mapo in je prikazano v polju Ime mape. Datoteke, ki jih želite združiti, so še vedno v mapi, vendar niso vidne.

  3. Seznam datotek v mapi se prikaže v pogovornem oknu <mapa> mape. Preverite, ali so vse datoteke na seznamu.

  4. Izberite enega od ukazov na dnu pogovornega okna, na primer Združi> Združi & nalaganje. V razdelku O vseh teh ukazih so opisani dodatni ukazi.

  5. V pogovornem oknu Združevanje datotek:

    • V polju Vzorčna datoteka izberite datoteko, ki jo želite uporabiti kot vzorčne podatke, ki se uporabljajo za ustvarjanje poizvedb. Predmeta ne morete izbrati ali izbrati le enega predmeta. Ne morete pa izbrati več kot enega.

    • Če imate več predmetov, lahko s poljemIskanje poiščete predmet ali možnosti prikaza skupaj z gumbom Osveži, da filtrirate seznam.

    • Potrdite ali počistite potrditveno polje Preskoči datoteke z napakami na dnu pogovornega okna.

  6. Izberite V redu.

Rezultat

Power Query samodejno ustvari poizvedbo za usklajevanje podatkov iz vsake datoteke v delovni list. Koraki poizvedbe in stolpci, ki so ustvarjeni, so odvisni od tega, kateri ukaz izberete. Če želite več informacij, glejte razdelek O vseh teh poizvedbah.

Izberete lahko več ukazov, vsak ukaz pa ima drugačen namen.

  • Združevanje in pretvorba podatkov    Če želite združiti vse datoteke s poizvedbo in nato zagnati urejevalnik Power Query, izberite Združi> Združi in pretvori podatke.

  • Združevanje in nalaganje   Če želite prikazati pogovorno okno Vzorčna datoteka, ustvarite poizvedbo in se nato naložite v delovni list, izberite Združi> Združi in naloži.

  • Združi in naloži v   Če želite prikazati pogovorno okno Vzorčna datoteka, ustvarite poizvedbo in nato prikažite pogovorno okno Uvozi, izberite Združi> Združi in naloži v.

  • Nalaganje    Če želite ustvariti poizvedbo z enim korakom in se nato naložiti v delovni list, izberite Naloži> naloži.

  • Naloži v   Če želite ustvariti poizvedbo z enim korakom, nato pa prikazati pogovorno okno Uvozi, izberite Naloži> v.

  • Pretvorba podatkovČe želite ustvariti poizvedbo z enim korakom in nato zagnati urejevalnik za Power Query, izberite Pretvori podatke.

Ko je operacija uvoza končana, je Power Query ustvaril več poizvedb. Poizvedba za pretvorbo vzorčne datoteke ima poizvedbo funkcije, ki priklica poizvedbo s parametri za vnos posamezne datoteke. S to poizvedbo ustvarite tudi stolpec binarnih vrednosti, ki vsebuje vsebino datoteke, in razširite stolpec strukturiranega zapisa, da v rezultate dodate podatke stolpca.

Če želite dodatno raziskovanje, odprite podokno Poizvedbe (izberite Podatki > Poizvedbe &zavihek Povezave > poizvedbe), da si ogledate poizvedbe, ki so organizirane v dve skupini. Nato z desno tipko miške kliknite posamezno poizvedbo in izberite Uredi, da pregledate posamezen korak poizvedbe in si ogledate, kako poizvedbe delujejo z koncertom.

Če želite začeti postopek združevanja več datotek, najprej zagotovite, da so vse datoteke, ki jih želite združiti, v eni mapi z datotekami.

Opomba: Podprte so Excelove, besedilne in Accessove datoteke ter datoteke CSV, JSON in XML.

  1. Kliknite zavihek Power Query, nato pa Iz datoteke > Iz mape.

    Možnosti Power Query > Iz datoteke > Iz mape
  2. Kliknite gumb Prebrskaj, da poiščete mapo.

    Seznam datotek v mapi se bo prikazal. Izberite možnost Urejanje, da odprete urejevalnik poizvedb. V tem primeru bomo naložili 4 Excelove delovne zvezke.

    Pogovorno okno za združevanje dvojiških vrednosti z datotekami, ki bodo združene
  3. Ko ste se prepričali, da so vse želene datoteke na seznamu, kliknite gumb Združi dvojiške vrednosti iz stolpca Vsebina.

    Pritisnite gumb »Združevanje dvojiških vrednosti«, ki ga najdete v stolpcu z vsebino poizvedbe ali v razdelku »Združevanje« na traku dodatka Power Query
  4. Analizira se posamezne datoteke in se določi pravilna oblika zapisa, kot je na primer besedilo, Excel ali JSON. V tem primeru je prikazan seznam delovnih listov iz prvega Excelovega delovnega zvezka. Izberite delovni list, ki ga želite uporabiti, in kliknite V redu.

    Pogovorno okno »Združevanje dvojiških vrednosti« z razpoložljivimi Excelovimi delovnimi listi, med katerimi izberete primarni cilj usklajevanja
  5. Postopek pretvorbe združevanja dvojiških vrednosti bo nato samodejno ustvaril poizvedbo za usklajevanje podatkov iz posamezne datoteke in prikazal predogled. Če ste zadovoljni z rezultati, kliknite Zapri in naloži.

    Pogovorno okno za predogled združevanja dvojiških vrednosti. Pritisnite »Zapri in naloži«, da sprejmete rezultate in jih uvozite v Excel.

    Postopek združevanja dvojiških vrednosti bo nato uskladil navedene delovne liste v en delovni list.

  6. Če se izvirne podatkovne datoteke spremenijo, lahko vedno osvežite uvožene podatke. Kliknite kjer koli v obsegu podatkov, nato pa pojite na Orodja za poizvedbe > Osveži. Poleg tega lahko preprosto uporabite dodatne pretvorbe ali koraki pridobivanja tako, da spremenite primerek samodejno ustvarjene poizvedbe, ne da bi vam bilo treba razmišljati o spreminjanju ali ustvarjanju dodatnih funkcij korakov poizvedbe; vse spremembe primerka poizvedbe se samodejno ustvarijo v poizvedbo povezane funkcije.

Znane težave

Pri nalaganju postopka združevanja dvojiških vrednosti v Excel lahko vidite to sporočilo o napaki:

Sporočilo o napaki pri združevanju dvojiških vrednosti. To je poznana napaka, ki jo poskušamo odpraviti.

Če zaprete napake tako, da kliknete V redu, bo postopek združevanja dvojiških vrednosti dokončal in pravilno naložil podatke kljub napaki. Trudimo se odpraviti napako.

Glejte tudi

Pomoč za Power Query za Excel

Prilaganje poizvedb

Združevanje pregleda datotek (docs.com)

Združevanje datotek CSV v dodatku Power Query (docs.com)

Ali potrebujete dodatno pomoč?

Razširite poznavanje Officea
Oglejte si izobraževanje
Prvi dobite nove funkcije
Pridružite se programu Office Insider

Vam je bila informacija v pomoč?

Zahvaljujemo se vam za povratne informacije.

Zahvaljujemo se vam za povratne informacije. Videti je, da bi vam prišla prav pomoč enega od naših Officeovih agentov za podporo.

×