Sammanfattning
I Microsoft Excel kan du använda ett makro för att sammanfoga data i två intilliggande kolumner och visa resultatet i kolumnen till höger om kolumnerna som innehåller dina data. Den här artikeln innehåller ett exempel på ett VBA-makro (underprocedur) i Microsoft Visual Basic for Applications (underprocedur) för att åstadkomma detta.
Mer information
Microsoft tillhandahåller endast programmeringsexempel i visningssyfte, utan att någon form av garanti uttrycks eller är underförstådd. Detta omfattar men är inte begränsat till underförstådda garantier för säljbarhet eller lämplighet för ett visst ändamål. Den här artikeln förutsätter att du är bekant med programmeringsspråket som demonstreras och med de verktyg som används för att skapa och felsöka procedurer. Microsofts supporttekniker kan hjälpa till att förklara funktionerna i en viss procedur. De kommer dock inte att ändra dessa exempel för att tillhandahålla ytterligare funktioner eller konstruktionsprocedurer för att uppfylla dina specifika krav.
Exempel på VBA-makro (Visual Basic for Applications)
Sub ConcatColumns()
Do While ActiveCell <> "" 'Loops until the active cell is blank.
'The "&" must have a space on both sides or it will be
'treated as a variable type of long integer.
ActiveCell.Offset(0, 1).FormulaR1C1 = _
ActiveCell.Offset(0, -1) & " " & ActiveCell.Offset(0, 0)
ActiveCell.Offset(1, 0).Select
Loop
End Sub
OBS: Satsen ActiveCell.Offset(0, 1). FormulaR1C1 kan ersättas med satsen ActiveCell.Offset(0, 1). formeln. De kan användas med samma framgång om du bara använder text och tal (inte formler). R1C1 som används i slutet av den första satsen refererar till rad ett, kolumn ett och är den form som används i exempel i hjälpen.
Så här använder du makrot i Microsoft Office Excel 2007
Öppna arbetsboken som innehåller dessa data.
Starta Visual Basic Editor genom att trycka på ALT+F11.
Klicka på Modul på Infoga-menyn för att infoga en modul. Skriv makrot i modulens kodfönster.
Klicka på Stäng och återgå till Microsoft Excel på Arkiv-menyn.
Markera det kalkylblad som innehåller de data som du vill sammanfoga.
Klicka på den översta cellen i den högra kolumnen med data som du vill sammanfoga. Om cellerna A1:A100 och B1:B100 till exempel innehåller data klickar du på cell B1.
Klicka på fliken Utvecklare . Om fliken Utvecklare inte visas gör du så här:
- Klicka på Microsoft Office-knappen och sedan på Excel-alternativ.
- Klicka på Vanliga alternativ.
- Markera kryssrutan Visa fliken Utvecklare i menyfliksområdet .
- Stäng dialogrutan Excel-alternativ genom att klicka på OK.
Klicka på Makron i gruppen Kod .
Markera makrot ConcatColumns och klicka sedan på Kör.
Så här använder du makrot i Microsoft Office Excel 2003 och tidigare versioner av Excel
- Öppna arbetsboken som innehåller dessa data.
- Starta Visual Basic Editor genom att trycka på ALT+F11.
- Klicka på Modul på Infoga-menyn för att infoga en modul. Skriv makrot i modulens kodfönster.
- Klicka på Stäng och återgå till Microsoft Excel på Arkiv-menyn.
- Markera det kalkylblad som innehåller de data som du vill sammanfoga.
- Klicka på den översta cellen i den högra kolumnen med data som du vill sammanfoga. Om cellerna A1:A100 och B1:B100 till exempel innehåller data klickar du på cell B1.
- Peka påMakron på menyn Verktyg och klicka sedan på Makro. Markera makrot ConcatColumns och klicka sedan på Kör.