Group Policy Processing Stops After You Apply a WMI Filter to a GPO

Symptoms

When you apply a Windows Management Instrumentation (WMI) filter to a Group Policy object (GPO), you may experience one or both of the following symptoms:
  • That GPO may not be processed.
  • All Group Policy processing may stop.

Cause

This issue may occur if WMI encounters an error during Group Policy processing and stops responding.

More Information

When you apply a WMI filter to filter the scope of a GPO, WMI errors that are encountered during Group Policy processing are handled in the following ways:
  • When the WMI service is off:
    If the WMI service is not running, only that GPO to which you have applied the WMI filter is not processed. All other Group Policy processing continues.
  • When the WMI service is on and a known error occurs:
    If a known error is encountered, only that GPO to which you have applied the WMI filter is not processed. All other Group Policy processing continues.

    Note A known error in this case is an error for which the Group Policy feature has the error code, and for which it monitors.
  • When the WMI service is on and an unknown error occurs:
    If an error occurs for which the Group Policy feature does not have an error code and for which it does not monitor, all Group Policy processing stops (fails).
Egenskaper

Artikel-id: 814613 – senaste granskning 7 jan. 2008 – revision: 1

Feedback