How to minimize metadata in PowerPoint presentations

Summary

When you create, open, or save a presentation in Microsoft Office PowerPoint 2003 or in Microsoft Office PowerPoint 2007, the presentation may contain content that you do not want to share with others when you distribute the presentation electronically. This information is known as metadata.

Metadata is used for a variety of purposes to enhance the editing, the viewing, the filing, and the retrieval of Microsoft Office documents. Some metadata is easily accessible through the PowerPoint user interface. Other metadata is only accessible through other means, such as opening a presentation in a low-level binary file editor.

The following are some examples of metadata that may be stored in your presentations:
  • Hidden information
  • Your name
  • Your initials
  • Your company or organization name
  • The name of your computer
  • The name of the network server or hard disk where you saved the presentation
  • Other file properties and summary information
  • Non-visible parts of embedded OLE objects
  • Template information
  • Comments
This article describes various methods that you can use to minimize the metadata in your PowerPoint presentations.

More Information

For more information about how Microsoft PowerPoint 2002 minimized metadata, click the following article number to view the article in the Microsoft Knowledge Base:

314800 How to minimize metadata in Microsoft PowerPoint presentations


Metadata is created in a variety of ways in PowerPoint presentations. Therefore, there is no single method that you can use to remove all metadata from your presentations. The following sections describe areas where metadata may be saved in PowerPoint presentations.

You can use the Remove Hidden Data add-in for Microsoft Office 2003 and Microsoft Office XP to remove hidden information from your documents.


For more information about how to use the Remove Hidden Data add-in, click the following article number to view the article in the Microsoft Knowledge Base:

834427 Remove Hidden Data add-in for Office 2003 and Office XP

How to delete hidden information

To avoid unintentionally distributing hidden information, such as the author of the presentation, or the names that are associated with comments or with tracked changes, follow these steps, as appropriate for the version of PowerPoint that you are running.

Microsoft Office PowerPoint 2007

  1. Click the Microsoft Office Button Microsoft Office Button  , point to Save As, and then click PowerPoint Presentation.
  2. In the Save As dialog box, click Tools, and then click General Options.
  3. Under Privacy Options, click to select the Remove automatically created personal information from this file on save check box, and then click OK.

Microsoft Office PowerPoint 2003

  1. On the File menu, click Save As.
  2. In the Save As dialog box, click
    Tools, and then click Security Options.
  3. On the Security tab, click to select the
    Remove personal information from file properties on save check box, and then click OK.

How to delete your user name from your presentations

To view or to change your user name, follow these steps, as appropriate for the version of PowerPoint that you are running.

PowerPoint 2007

  1. Click the Microsoft Office Button Microsoft Office Button  , click Prepare, and then click Properties.
  2. Click Document Properties, and then click Advanced Properties.
  3. Click the Summary tab to view the Author, Manager, and Company fields.
  4. If you do not want this information to appear in your presentations, type non-identifying information or type spaces in the relevant fields, and then click OK.

PowerPoint 2003

  1. On the Tools menu, click
    Options.
  2. Click the General tab to view the
    Name and Initials boxes.
  3. If you do not want this information to appear in your presentations, type non-identifying information or type spaces in the box or boxes, and then click OK.
Any new presentations that you create will contain this new information, instead of the default values that you typed when you first installed Office. However, existing presentations may already contain this information.

How to delete personal summary information

When you create or when you save a presentation in PowerPoint, summary information may be saved in the presentation. To access this information, do one of the following:
  • Open the presentation.

    To do so, on the
    File menu, click Properties. The
    Summary, Statistics,
    Contents, and Custom tabs may all contain various properties, such as your name, your manager's name, and your company name.
  • In the Microsoft Windows Explorer, right-click your presentation, and then click Properties.

    The tabs in the Properties dialog box may contain information that you want to delete.
  • Use a Microsoft Visual Basic for Applications (VBA) macro or other program code to read the properties that appear in the
    Properties dialog box.
To delete summary information from an existing PowerPoint presentation, follow these steps:
  1. Open the presentation.
  2. On the File menu, click
    Properties.
  3. On the Summary tab, delete any text in the
    Author box, the Manager box, the
    Company box, and other edit boxes that contain information that you do not want to distribute.
  4. On the Custom tab, delete any properties that contain information that you do not want to distribute.
  5. When you finish, click OK.

    On the File menu, click Save.
  6. On the File menu, click
    Close.
After you complete these steps, the presentation will not contain summary properties.

How to delete personal summary information when you are connected to a network

If you are logged on to a network, your network user name may appear in the Author box on the Summary tab, and in the "Last saved by" field on the Statistics tab when you save a presentation. This issue may occur even if you deleted all other personal information from your computer. To delete summary information from a presentation when you are on a network, follow these steps:

Note If you cannot start Microsoft Windows by pressing
ESC (for example, your computer is running Microsoft Windows NT), you cannot follow these steps.
  1. If the presentation is stored on a network server, copy the presentation to your local hard disk.
  2. Start your computer, but do not log on to your network.


    When you see the network logon dialog box, click
    Cancel or press the ESC key.
  3. Open the presentation.
  4. On the File menu, click
    Properties.
  5. On the Summary tab, delete any text in the
    Author box, the Manager box, the
    Company box, and other edit boxes that contain information that you do not want to distribute.
  6. On the Custom tab, delete any properties that contain information that you do not want to distribute.
  7. When you finish, click OK.

    On the
    File menu, click Save.
  8. On the File menu, click
    Close.
When you next log on to the network, do not open the file. If you open the file, your network user name may be written in the file. However, you can use Microsoft Windows Explorer to copy the file to either a network server or a floppy disk.

How to delete comments in a presentation

You can use PowerPoint to add comments to presentations. Typically, comments contain the name of the person who created them. To delete a comment, select the comment, and then press the DELETE key, or click Delete Comment on the Reviewing toolbar.

Note To view comments in PowerPoint, click
Markup on the View menu. Any new comments that you create will not contain your user name because you deleted it from your Options dialog box, as described in the "How to delete your user name from your programs" section earlier in this article.

How to delete information from headers and footers

Headers and footers in presentations may contain identifying information. To delete information from headers and footers, on the
View menu, click Header and Footer. Change the header, change the footer, or change both. When you finish, click
Apply or click Apply To All.

How to disable the FastSaves feature

The Fast Saves feature speeds up the process of saving a presentation by saving only the changes that you make to a presentation. Because of the design of the Fast Saves feature, text that you delete from a presentation may remain, even after you save the presentation. If you are concerned about deleted text remaining in your presentation, follow these steps:
  1. On the Tools menu, click
    Options.
  2. On the Save tab, click to clear the
    Allow fast saves check box, and then click
    OK.

How to delete hyperlinks from a presentation

Presentations may contain hyperlinks to other documents or Web pages on either the intranet or the Internet. Hyperlinks typically appear as blue underlined text strings. To manually delete a single hyperlink from a presentation, right-click the hyperlink, and then click
Remove Hyperlink.

How to delete your name from VBA code

When you record a VBA macro in PowerPoint, the recorded macro starts with a header that is similar to the following:
' Macro1 Macro ' Macro recorded 3/11/2000 by J. Doe
To delete your name from any macros that you recorded, follow these steps:
  1. Open the presentation that contains the macros.
  2. Press ALT+F11 to open the Visual Basic Editor.
  3. In the project window, double-click the module that contains the macros.
  4. Delete your name from the recorded macro code.


    When you are finished, press ALT+Q to return to the program, and then click Save on the File menu.

How to delete VBA references to other files

In the Visual Basic Editor, you can create a reference to another file. If a user opens a presentation that contains references to other files, the user can see the names of the referenced files. To delete these references, follow these steps:
  1. Open the presentation that contains references.
  2. Press ALT+F11 to open the Visual Basic Editor.
  3. On the Tools menu, click
    References.
  4. Click to clear the check box that is next to the referenced file.

    When you are finished, click OK to close the
    References - VBAProject dialog box.
  5. Press ALT+Q.
  6. On the File menu, click
    Save.
Note If you delete references to other files, you may prevent the macros in your presentation from functioning correctly.

How to change macro settings in PowerPoint 2007

  1. Click the Microsoft Office Button Microsoft Office Button  , and then click PowerPoint Options.
  2. In the Navigation Pane, click Trust Center.
  3. Under Microsoft Office PowerPoint Trust Center, click Trust Center Settings.
  4. In the Navigation Pane, click Macro Settings.
  5. Modify the settings as required, and then click OK two times.

How to delete network or hard disk information from a presentation

When you save a presentation to your local hard disk or to a network server, information that identifies the local hard disk or network server may be written into the presentation. To delete this information from the presentation, follow these steps:
  1. Open the presentation.
  2. On the File menu, click Save As.

    Save the presentation to your floppy disk drive (typically, A:).
  3. On the File menu, click
    Close.
  4. Remove the disk from your floppy disk drive.
You can now use Microsoft Windows Explorer to copy the presentation file from the floppy disk to any hard disk or network server.


Note Because of the space limitation of a floppy disk (typically 1.44 megabytes (MB)), you cannot use this method if the presentation file size exceeds the free space on the floppy disk.

How to delete metadata from an embedded objects

If you embed an object in a presentation, the object still retains its own properties, regardless of what you do to the presentation. For example, if you embed a Microsoft Word document in a PowerPoint presentation, the document and the presentation retain their own properties. To delete metadata from an embedded object, follow these steps:
  1. Activate the object.
  2. Delete any metadata.
  3. Reactivate the container document. In this example, the PowerPoint presentation.
  4. Save the container document.
Note When you activate an embedded object in a presentation, only part of the embedded object appears in the presentation. The object may contain additional information that does not appear. If you want a presentation to contain only a rendering of the embedded object, and not the actual contents, follow these steps:
  1. Select the object.
    On the Editmenu, click Cut.
  2. On the Edit menu, click Paste Special to paste the object into the presentation by using a metafile format.
After you do this, you cannot edit the embedded object. However, the object will not contain any metadata.

How to delete your user name and organization from the Registry

When you install any program, you may be prompted to type your user name, initials, organization name, or all three. This information is stored in the Microsoft Windows Registry, in the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\UserInfo
You can use Registry Editor to delete the contents of these keys. Note that if you install any program, you may be prompted to type this information again. After installation of the program is complete, you can delete this registry key.

General suggestions about security

The following are some general suggestions that you can use to increase the level of security in your computing environment:
  • When you are not working at your computer, help to secure the computer by using a password-protected screen saver, a power-on password, or the Windows NT lock feature.
  • If your computer has any shared folders, make sure that you apply passwords to the shared folders. Therefore, only authorized users can access your shares. For more security, use user-level access control. Therefore, you can control exactly who can access your computer's shares.
  • When you delete a file, empty the Recycle Bin immediately. You may want to consider using a utility that completely erases or overwrites files when they are deleted.
  • When you back up your data, store the backup files in a secure location, such as a safe, a security deposit box, or a locked cabinet. Store one copy of your backup files at a secure, off-site location in case you cannot use your primary location.
  • Password-protected important documents to make sure that only authorized users can open them. Store your passwords in a secure, separate location. Note that if you cannot recall a password, there is no way to recover the contents of a password-protected document.
  • Do not distribute documents in electronic form. Instead, print them. Do not use identifying elements such as distinctive fonts, watermarks, logos, or special paper, unless you have to--for example, for a presentation.
  • E-mail is not anonymous. Do not send a document by e-mail if you are concerned about your identity being attached in any way to the document.
  • Do not send a document over the Internet by using either HTTP or FTP protocols. Information that is sent across these protocols is sent in "clear text". This means that it is technically possible (however unlikely) for the information to be intercepted.

More information

For more information about the topics that this article discusses, click the following article number to view the article in the Microsoft Knowledge Base:

290945 How to minimize metadata in Microsoft Word documents

Egenskaper

Artikel-id: 826825 – senaste granskning 12 sep. 2011 – revision: 1

Feedback