Allmänt

Du kan välja att visa alla underdatablad för en databas. Givetvis måste den innehålla underdatablad för att kunna visa några.



Så här gör du:

  1. Öppna tabellen som innehåller underdatablad.
  2. Klicka på Underdatablad på Format-menyn.
  3. Klicka på Visa alla.
Genom att visa relationerna mellan olika tabeller i en databas får du en bra överblick över databasens uppbyggnad.



Så här gör du:

  1. Tryck på F11, för att växla till Databasfönstret.
  2. Klicka på Relationer i Verktyg-menyn.
  3. Du kan även klicka på knappen Visa relationer i verktygsfältet.
En dataåtkomstsida är en webbsida som kopplats till en Access-databas. Sidan lagras i htm-format och kan därför nås via en webbläsare. Du kan skicka webbsidan som bilaga med e-post.



Det finns också möjlighet att uppdatera databasen/tabellerna via en dataåtkomstsida. Användaren behöver då inte ha Access installerat.



Så här gör du:

  1. Tryck på F11, för att växla till Databasfönstret.
  2. Klicka på Sidor.
  3. Klicka på Skapa en dataåtkomstsida genom att använda en guide.
  4. Klicka på de tabeller och fält som ska visas.
  5. Klicka på Slutför.
En dataåtkomstsida är en webbsida som kopplats till en Access-databas. Sidan lagras i htm-format och kan därför nås via en webbläsare. Du kan skicka webbsidan som bilaga med e-post.



Det finns också möjlighet att uppdatera databasen/tabellerna via en dataåtkomstsida. Användaren behöver då inte ha Access installerat för att göra detta.



Så här gör du:

  1. Tryck på F11, för att växla till Databasfönstret.
  2. Klicka på Sidor.
  3. Klicka på Skapa en dataåtkomstsida i designläge.
  4. Dra och släpp fält från fältlistan till Sidan.
  5. Välj en layout, exempelvis Kolumner.
  6. Klicka på OK.
  7. Ange en rubrik för sidan.
  8. Klicka på Visa.
  9. Spara sidan med ett filnamn.
Genom att skapa en korsfråga kan du göra olika sammanställningar med information från databasen. Med hjälp av korsfrågor visas statistik över antalet poster i en eller flera tabeller.



Så här gör du:

1. Stå i vyn för databasfönster.

2. Klicka på Ny.

3. Klicka på Korsfrågeguiden.

4. Markera en eller flera tabeller och klicka sedan på Nästa.

5. Dubbelklicka på de fält du vill infoga i korsfrågan och klicka sedan på Nästa.

6. Markera de fält och funktioner som ska beräknas och klicka sedan på Nästa.

7. Namnge korsfrågan och klicka på Slutför.
En kalender kan infogas i ett formulär så att du enklare kan registrera datum.



Så här gör du:

1. Öppna ett formulär i designläge.

2. Klicka på ActiveX-kontroll i Infoga menyn, och klicka sedan på Kalenderkontroll.

3. Dra kalendern till en plats i formuläret.

4. Klicka på Stäng och spara sedan formuläret.
Om du vill titta på viss information i en stor tabell med många poster kan du använda dig av ett filter för att slippa bläddra igenom hela tabellen. Detta spar mycket tid och minimerar risken att ta fram fel information.



Så här gör du:

1. Öppna ett formulär eller en tabell.

2. Placera markören i ett fält i en post.

3. Klicka på ikonen Filtrera efter formulär, som du hittar i Verktygsfältet.

4. Urvalet är nu begränsat/filtrerat.

5. För att visa alla poster klicka på ikonen Ta bort filter.
Tabeller är oftast knutna till varandra med hjälp av relationer. En relation är en så kallad koppling mellan fält eller kolumner i två tabeller. Detta skapar möjlighet att visa data på det sätt som du själv önskar. Om du har en koppling som är inaktuell kan du enkelt ta bort den.



Så här gör du:

1. Stäng alla öppna tabeller.

2. Ställ dig i databasfönstret genom att klicka på F1.

3. Klicka på Relationer i verktygsfältet.

4. Dubbelklicka på de tabeller du vill infoga för att sedan kunna ta bort en eller flera relationer.

5. Klicka på Stäng.

6. Markera den relationslinje du vill ta bort och klicka sedan på Delete på ditt tangentbord.



Om du inte stänger alla öppna tabeller enligt punkt ett, kommer du inte att kunna ta bort några relationer.
En databas kan bestå av en mängd olika tabeller med kopplingar mellan varandra. Du är oftast tvungen att växla mellan dina tabeller vilket resulterar i ett klickande fram och tillbaka för att aktivera tabellerna. Access ger dig dock möjlighet att visa flera tabeller samtidigt. Detta underlättar avsevärt i ditt dagliga arbete.



Så här gör du:


För att sortera tabellerna sida vid sida:

• Klicka på Sida vid sida i Fönster-menyn. För att sortera tabellerna över och under varandra:

• Klicka på Över och under i Fönster-menyn.


I Fönster-menyn hittar du även andra val för att sortera tabellerna. Du väljer själv vad som passar dig bäst.
Om du använder musen frekvent blir armen gärna trött och kan behöva avlastning ibland. Genom att använda dig av inbyggda kortkommandon underlättar du ditt arbete. En annan positiv effekt är att du också blir snabbare.



Så här gör du:


Visa hjälpen

F1 Genom att trycka på F1 visas Office-assistenten eller Microsoft Access hjälpen.



Kortkommandon för att skriva ut och spara Ctrl+P Skriver ut markerat objekt.

F12 Öppnar dialogrutan Spara som.



Kortkommandon för att söka och ersätta text och data.

Ctrl+F Öppnar fliken Sök i dialogrutan Sök och Ersätt.

Ctrl+H Öppnar fliken Ersätt i dialogrutan Sök och Ersätt.
Dubbletter tar upp onödig plats i en databas och bör inte finnas där. Om databasen blir stor kan det vara svårt att manuellt hålla reda på alla fält och deras innehåll. Access kan hålla reda på dina dubbletter åt dig.



Så här gör du:

1. Öppna tabellen i design läge

2. Markera det fält där du vill förhindra dubbletter.

3. I den nedre delen av fönstret, klicka i egenskapsrutan Indexerat och klicka sedan på Ja –inga dubbletter.
Med hjälp av en listruta kan du mata in data till din databas. Detta kan vara användbart i många fall, till exempel vid skapande och hantering av ett adressregister.

Så här gör du:

1. Starta Access och öppna ett formulär i designläge.

2. Öppna verktygslådan som innehåller bland annat verktyget för Listruta genom att klicka på Verktygslådan i Visa-menyn.

3. För att infoga en Listruta, klicka på ikonen för Listruta i verktygslådan.

4. Klicka sedan på den plats i formuläret där du vill infoga Listrutan.

5. En guide startas automatiskt. Följ instruktionerna i guidens dialogrutor och välj de alternativ du önskar att infoga i ditt formulär.

6. För att binda din Listruta till databasen, markera rutan och högerklicka.

7. Klicka på Egenskaper. 8. Klicka på fliken Data, i rutan för kontrollkälla markerar du det fält som du vill binda till Listrutan.

Behörighet

Skapar du ofta användarkonton och gruppkonton till medarbetare som ska få åtkomst till olika databasobjekt? Det kan i längden bli svårt att hålla reda på alla användarnamn samt deras lösenord. För att underlätta för dig själv kan du skapa en informationsfil som innehåller dessa uppgifter. Du får på så vis bättre kontroll över vilka som har tillgång till databasen.



Så här gör du:

1. Starta Access.

2. Klicka på Säkerhet i Verktyg-menyn och klicka sedan på Administrera arbetsgrupp.

3. I dialogrutan Information om arbetsgruppens ägare, anger du ditt namn samt företagsnamnet. Du måste även skriva ett unikt namn i rutan ID för gruppen. Genom att ge filen ett unikt namn blir det enkelt att identifiera filen.

4. Välj var du vill spara filen genom att klicka på Bläddra.

5. Klicka OK för att spara informationsfilen.


Informationsfilen används nästa gång du startar Access. Alla användarkonton och lösenord som du skapar kommer att sparas i filen. Tänk på att placera filen på ett säkert ställe på din server eller på din lokala dator. Informationen bör inte hamna i fel händer.
Den enklaste metoden för att skydda din databas är att skapa ett lösenord som ska anges när databasen öppnas. När du har skapat ett lösenord visas en dialogruta med begäran om lösenordet varje gång du eller någon annan öppnar databasen. Endast användare som anger korrekt lösenord tillåts öppna databasen.



Så här gör du:

1. Välj Säkerhet på Verktyg-menyn, (när du är i databasfönstret).

2. Klicka på Ange lösenord för databasen.

3. Skriv in ditt lösenord i båda rutorna.

4. Klicka på OK. Detta är en säker metod (lösenordet krypteras så att det inte går att läsa genom att läsa databasfilen direkt), men begränsad. När databasen väl har öppnats har användarna åtkomst till samtliga databasobjekt.


Varning! Använd inte lösenord om du tänker replikera databasen. Replikerade databaser kan inte synkroniseras om databaslösenord används.


Om du vill skydda databasen ännu mer kan du kryptera den. Genom att kryptera databasen komprimeras databasfilen och kan inte läsas av ett externt program eller ett ordbehandlingsprogram. Dekryptering upphäver krypteringen
Du kan kompilera din databas som en MDE fil, då kommer alla moduler och redigerbar kod tas bort och måldatabasen komprimeras. Visual Basic-koden kommer att kunna köras men den kan inte visas eller redigeras och storleken på Access-databasen minskas eftersom kod tas bort. Dessutom optimeras minneshanteringen så att prestanda förbättras.



Så här gör du:

1. Stäng databasen. Kontrollera också att alla andra användare har stängt databasen.

2. Välj Databasverktyg på Verktyg-menyn.

3. Klicka på Skapa MDE-fil.

4. Ange den Access-databas som du vill spara som en MDE-fil i dialogrutan Databas som ska sparas som MDE.

5. Klicka på Skapa MDE.

6. Ange ett namn, en enhet och en mapp för Access-databasen i dialogrutan Spara MDE som.



Varning! Spara en kopia av den ursprungliga Access-databasen. Du kan inte ändra utformningen av formulär, rapporter eller moduler i en Access-databas som sparats som en MDE-fil. Om du behöver ändra utformningen av dessa objekt måste du göra det i den ursprungliga Access-databasen och sedan spara om databasen som en MDE-fil. Du kommer inte heller att kunna köra eller konvertera en Access-databas som sparats som en MDE-fil i framtida versioner av Microsoft Access. Du kommer bara att kunna öppna eller konvertera den ursprungliga Access-databasen.

Installation

Genom att installera Access på din egen dator och på en server kan du dela databaser med andra som har Access installerat.


Så här gör du:

1. Skapa en katalog på servern som är delad.

2. Kopiera Accessdatabasen och placera kopian i den delade mappen.

3. Kontrollera att databasen är delad och att dina kollegor kan öppna och redigera databasen.


Nu kan ni komma åt och arbeta med databasen från olika platser i nätverket där Access finns.
Du kan ladda ned uppdateringar till Access 2002 från Download Center för att få de senaste nyheterna till ditt Access 2002.



Så här gör du:

1. Klicka på länken nedan eller skriv in http://office.microsoft.com/Downloads/ i adressfältet.

2. Välj Access i listan Product och klicka sedan på 2002/XP i listan Version.

3. Se till att alternativet Updates är markerad.

4. Klicka på Update List.



Uppdateringarna visas nu i en lista. Klicka på Download Now! för att ladda ned uppdateringen eller klicka på uppdateringen för att få mer information om den.
En funktion som många kanske missat är Identifiera och reparera. Funktionen Identifiera och reparera söker automatiskt efter fel i programmet.



Så här gör du:

1. Starta Access.

2. Välj Identifiera och reparera på Hjälp-menyn.

3. Följ instruktionerna.

Inställningar

När du skapar en tabell eller en fråga i Access finns en standardtyp angiven för fält. Om du ofta skapar tabeller där du i de flesta fall använder en annan typ av fält kan det vara praktiskt att ändra standarden.



Så här gör du:

1. Klicka på Alternativ på Verktyg-menyn.

2. Klicka på fliken Tabeller/frågor.

3. Välj önskad fälttyp i listan vid Standardfälttyp.

5. Klicka på OK.
När du skapar en tabell eller en fråga i Access finns en standard angiven för fält, för text är standarden 50 tecken och för tal är standarden långt heltal. Om du ofta skapar tabeller där du vill att helt andra inställningar ska gälla kan det vara praktiskt att ändra standarden.


Så här gör du:

1. Klicka på Alternativ på Verktyg-menyn.

2. Klicka på fliken Tabeller/frågor.

3. Skriv in önskad textlängd i fältet Text i området Fältstorlek.

4. Välj önskat format i listan vid Tal.

5. Klicka på OK.
Du kan ladda ned uppdateringar till Access 2002 från Download Center för att få de senaste nyheterna till ditt Access 2002.


Så här gör du:

1. Klicka på länken nedan eller skriv in http://office.microsoft.com/Downloads/ i adressfältet.

2. Välj Access i listan Product och klicka sedan på 2002/XP i listan Version.

3. Se till att alternativet Updates är markerad.

4. Klicka på Update List.


Uppdateringarna visas nu i en lista. Klicka på Download Now! för att ladda ned uppdateringen eller klicka på uppdateringen för att få mer information om den.
Du kan spara tid genom att kopiera formatet från en kontroll till en annan, istället för att upprepa flera steg för varje kontroll. Dessutom slipper du att försöka hålla reda på de olika formateringsalternativ du har gjort från en kontroll till en annan.



Så här gör du:

1. Öppna formuläret i designläge.

2. Markera den kontroll som har de formateringsalternativ som du vill kopiera.

3. Klicka på Hämta format på verktygsfältet Formulärdesign.

4. Klicka på den kontroll som du vill att formatet ska kopieras till. Du kan till exempel kopiera formatet från en textruta till en listruta.



Vill du kopiera formatet till flera kontroller ska du dubbelklicka på knappen Hämta format. När du har kopierat färdigt trycker du på Esc eller klickar på knappen Hämta format igen.
När du har angivit villkor för att styra formateringen av en kontroll kan du i efterhand ändra villkoret/villkoren eller ta bort dem.



Så här gör du:

1. Öppna formuläret i designläge.

2. Klicka på den kontroll som du har tidigare lagt till villkorsstyrd formatering på.

3. Klicka på Villkorsstyrd formatering på Format-menyn.



Gör något av följande:

- Markera önskat teckensnitt, färg eller annan formatering som du vill att kontrollen ska formateras med i stället.

- Klicka på Lägg till om du vill lägga till ytterligare villkor. Du kan ha upp till tre olika villkor.

- Klicka på knappen Ta bort och markera vilket villkor du vill ta bort. Klicka sedan på OK.


4. Klicka på OK.



När du öppnar funktionen Villkorsstyrd formatering visas den aktuella formateringen för den kontroll som du har klickat på, exempelvis teckenfärg och teckensnitt.
Du kan aktivera något som kallas programmeringshjälp som du kan ha nytta av när du programmerar i Access.



Så här gör du:

1. Klicka på Visa Office-assistenten på Hjälp-menyn.

2. Klicka på Alternativ.

3. Klicka på fliken Alternativ och markera Söka efter både produkt- och programmeringshjälp vid programmering.

4. Klicka på OK.

Utskrifter

Du behöver inte skriva ut alla poster som finns i ett formulär. Istället kan du själv välja exakt vilka poster du vill skriva ut.



Så här gör du:

1. Öppna formuläret i Formulärläge.

2. Markera de poster du vill skriva ut genom att klicka på Postväljaren. (Rutan eller listen till vänster om en post i ett formulär kallas postväljaren.)

3. Klicka på Skriv ut på Arkiv-menyn.

4. Välj Markerade poster i dialogrutan Skriv ut.
Det är mycket viktigt att du har en bra utformning på dina tabeller och relationerna mellan dem. Det finns en funktion i Access 2002 som hjälper dig att bedöma utformningen genom att skapa en grafisk översikt över tabellernas relationer i din databas.



Så här gör du:

1. Öppna önskad databas.

2. Klicka på Tabeller under Objekt.

3. Klicka på Relationer på Verktyg-menyn.

4. Markera en tabell och klicka på Lägg till.

5. Upprepa steg 4 för varje tabell du vill ha med i översikten.

6. Klicka på Stäng för att stänga dialogrutan Visa tabell.

7. Klicka på Skriv ut relationer på Arkiv-menyn.
Innan du skriver ut en rapport första gången bör du först kontrollera eventuella marginaler, sidorientering och andra sidinställningar.



Så här gör du:

1. Markera en rapport i databasfönstret.

2. Välj Skriv ut på Arkiv-menyn.

3. Ange inställningar i dialogrutan Skriv ut.

4. Ange skrivare under Namn.

5. Ange vilka sidor som ska skrivas ut samt om de ska sorteras under Kopior.

6. Klicka på OK.



Du kan även klicka på knappen Skriv ut i verktygsfältet om du vill skriva ut allt.
Så här gör du:

1. Öppna den rapport som du ska skriva ut i designläge.

2. Klicka på knappen Textruta.

3. Skriv koden =Nu().

Referenser

Migration of content in page http://web01.microsoft.se/tips/se/
Egenskaper

Artikel-id: 828855 – senaste granskning 13 aug. 2004 – revision: 1

Feedback