Gult utropstecken visas bredvid ikonen Firewall Client på en dator som kör en viss version av Firewall Client för ISA Server och en verktyget tips meddelande visas: ”Firewall Client har inte installerats korrekt”


Viktigt Den här artikeln innehåller information om hur du ändrar registret. Kontrollera att du säkerhetskopierar registret innan du ändrar den. Se till att du vet hur du återställer registret om det uppstår problem. Mer information om hur du säkerhetskopierar, återställer och ändrar registret klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
256986 beskrivning av registret i Microsoft Windows

Symptom


Du hittar ett gult utropstecken bredvid ikonen Firewall Client. Det här problemet uppstår på en dator som kör version av Firewall Client för ISA Server som beskrivs i Microsoft Knowledge Base-artikeln 929556. Dessutom när du flyttar muspekaren över ikonen Firewall Client visas verktyget tips ett meddelande av följande slag:
Firewall Client har inte installerats korrekt

Orsak


Det här problemet uppstår om du kör ett program som installerar WinSock Base Service Provider (NSP), till exempel mobiltelefon anslutning optimizers. En NSP kan kringgå brandväggen klient NSP och påverka Firewall Client fungerar korrekt. Till varning du om denna situation Firewall Client visas ett varningsmeddelande. Vissa BSPs kringgås dock inte brandväggen klient NSP. Därför påverkar inte dessa BSPs Firewall Client fungerar. Om du har testat programmet och om du har kontrollerat att det inte påverkar Firewall Client fungerar korrekt, kan du inaktivera varningsmeddelandet för verktyget tips. Installera snabbkorrigeringen som beskrivs i avsnittet ”lösning” om du vill inaktivera meddelandet verktyget tips. När du har installerat snabbkorrigeringen måste du lägga till registerposten UiEnableCatalogValidation för att aktivera snabbkorrigeringen. Mer information om hur du lägger till den här registerposten finns i avsnittet ”information om Windows-registret”.

Lösning


Information om snabbkorrigeringen

En snabbkorrigering är tillgänglig från Microsoft. Den här snabbkorrigeringen är emellertid avsedd att åtgärda det problem som beskrivs i denna artikel. Använd bara den här snabbkorrigeringen för system med just detta problem. Om snabbkorrigeringen är tillgänglig för hämtning finns ett avsnitt för ”snabbkorrigeringen är tillgänglig” överst i den här Knowledge Base-artikeln. Om det här avsnittet inte visas, skicka en begäran till Microsofts kundtjänst och Support för att få snabbkorrigeringen. Obs! Om det uppstår ytterligare problem eller krävs felsökning, kan du behöva skapa en serviceförfrågan. De vanliga supportkostnaderna gäller för övriga supportfrågor och problem som inte uppfyller kraven för den här snabbkorrigeringen. En fullständig lista över telefonnummer för Microsofts kundtjänst och Support eller skapa en serviceförfrågan finns på följande Microsoft-webbplats:Obs! ”Snabbkorrigeringen tillgänglig”-formuläret visar de språk som snabbkorrigeringen är tillgänglig. Om ditt språk inte visas beror det på att ingen snabbkorrigering är tillgänglig för språket.

Filinformation

Den engelska versionen av den här snabbkorrigeringen har de filattribut (eller senare filattribut) som visas i följande tabell. Datum och tider för dessa filer anges i UTC-tid (UTC). När du visar filinformationen konverteras den till lokal tid. Använd fliken tidszon i datum och tid på Kontrollpanelen om du vill se skillnaden mellan UTC-tid och lokal tid.
FilnamnFilversionStorlekDatumTidPlattform
Fwcmgmt.exe4.0.3442.700120,20820-May-200716:39Ej tillämplig

Information om Windows-registret

Varning allvarliga problem kan uppstå om du ändrar registret på ett felaktigt sätt med Registereditorn eller med någon annan metod. Dessa problem kan medföra att du måste installera om operativsystemet. Microsoft kan inte garantera att problemen kan lösas. Ändra registret på egen risk. När du har installerat den här snabbkorrigeringen måste du lägga till registerposten UiEnableCatalogValidation om du vill aktivera den här snabbkorrigeringen. Gör så här:
  1. Klicka på Start, Kör, Skriv regeditoch klicka sedan på OK.
  2. Leta upp och klicka på följande registerundernyckel:
    På 32-bitarsdatorer:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Firewall-Client-2004\Policiespå 64-bitarsdatorer: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Firewall klient-2004\Policies
  3. Klicka på NyttRedigera -menyn och klicka sedan på DWORD-värde.
  4. Skriv UiEnableCatalogValidationoch tryck sedan på RETUR.
  5. Högerklicka på UiEnableCatalogValidationoch kontrollera att rutan data innehåller ett null-värde (0).

Status


Microsoft har bekräftat att detta är ett problem i Microsoft-produkterna som nämns i avsnittet ”gäller”.

Mer information


Mer information om hur du skaffar en version av brandväggsklienten för ISA Server (December 2006) som innehåller Windows Vista support, klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
929556 hur du skaffar en version av brandväggsklienten för ISA Server (December 2006) som har stöd för Windows Vista
Mer information om standardterminologi som används för att beskriva Microsoft-programuppdateringar klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
824684 beskrivning av standardterminologin som används för att beskriva Microsoft-programuppdateringar