Långsamma prestanda kan uppstå om du är en användare som inte har tilldelats en SUPER användar-ID i Microsoft Dynamics NAV 4.0


Den här artikeln gäller för Microsoft Dynamics NAV 4.0 för alla länder och språkversioner.

Symptom


I Microsoft Dynamics NAV 4.0 kan det uppstå långsamma prestanda om du är en användare som inte har tilldelats en SUPER user identifierare (ID). Det här problemet uppstår om följande villkor är uppfyllda:
  • I Microsoft Dynamics NAV 4.0 kan du använda den ursprungliga databasen.
  • Den ursprungliga databasen innehåller mer än 300 företag.

Orsak


Det här problemet uppstår eftersom Microsoft Dynamics NAV 4.0 måste kontrollera massor av behörigheter.

Lösning


Information om snabbkorrigeringen

En snabbkorrigering är nu tillgänglig från Microsoft. Snabbkorrigeringen korrigerar det problem som beskrivs i denna artikel. Använd den bara för system där just detta problem.

Om du vill lösa problemet omedelbart kontaktar du teknisk Support för Microsoft Dynamics och relaterade produkter för att få snabbkorrigeringen. Du kan logga in på Microsoft Dynamics-webbplatsen och skapa en ny supportbegäran. Besök följande Microsoft-webbplats om du vill göra detta :Du kan även kontakta teknisk Support för Microsoft Dynamics och relaterade produkter på telefon (888) 477-7877.

Obs! I särskilda fall, de avgifter som är normalt för support vara avgiftsfri om en supporttekniker för Microsoft Dynamics och relaterade produkter som bestämmer att en särskild uppdatering kan lösa ditt problem. De vanliga supportkostnaderna gäller för eventuella ytterligare supportfrågor och problem som inte berör den särskilda uppdateringen.

Förutsättningar

Det finns inga förutsättningar.

Information om borttagning

Du kan inte ta bort den här snabbkorrigeringen.

Krav på omstart

Om du uppmanas att starta om datorn, måste du starta om datorn när du har installerat den här snabbkorrigeringen.

Hur du hämtar snabbkorrigeringen Microsoft Dynamics NAV eller uppdatera filer

När du begär en snabbkorrigering för Microsoft Dynamics NAV eller en uppdateringsfil från teknisk Support för Microsoft Dynamics kommer en hyperlänk att skickas till dig i ett e-postmeddelande.


E-postmeddelandet innehåller en hyperlänk och ett lösenord. Du kan använda hyperlänken för att hämta snabbkorrigeringen Microsoft Dynamics NAV eller uppdateringsfilerna. När du klickar på hyperlänken öppnas dialogrutan Filhämtning – säkerhetsvarning . Du uppmanas sedan att köra, spara eller avbryta hämtningen.


Om du klickar på Körbörjar filerna hämtning och extrahering av. Du måste ange en mapp för de nya filerna och ange lösenordet.


Om du klickar på Sparamåste du ange en sökväg för att spara den komprimerade filen. När du öppnar den fil som du sparade, uppmanas att ange en sökväg för filerna. Sedan måste du ange det lösenord som anges i e-postmeddelandet.


Om du klickar på Avbrytavbryts hämtningen.

Hur du installerar Microsoft Dynamics NAV-snabbkorrigering eller uppdatering för Microsoft Dynamics NAV

Snabbkorrigeringar för Microsoft Dynamics NAV och Microsoft Dynamics NAV-uppdateringar görs tillgängliga som enskilda filer. Om du vill installera en snabbkorrigering för Microsoft Dynamics NAV eller en uppdatering för Microsoft Dynamics NAV måste du ersätta de befintliga filerna i Microsoft Dynamics NAV-installation med hjälp av snabbkorrigeringsfilerna eller uppdateringsfilerna.


Om du har Microsoft Dynamics NAV-klienten installerad måste du ersätta följande filer i Microsoft Dynamics NAV klientinstallationskatalogen.
FilnamnFilversionStorlekDatumTidPlattform
Dbm.dll4.0.3.25307345,20801-Oct-200717:57x86
Fin.exe4.0.3.253078,119,41601-Oct-200717:58x86
Finhlink.exe4.0.3.25307119,92801-Oct-200717:56x86
Finsql.exe4.0.3.253078,168,56801-Oct-200717:58x86
Nc_netb.dll4.0.3.2530778,96801-Oct-200717:56x86
Nc_tcp.dll4.0.3.2530783,06401-Oct-200717:56x86
Nc_tcps.dll4.0.3.2530791,25601-Oct-200717:56x86
Ndbcs.dll4.0.3.253071,090,68001-Oct-200717:58x86
Slave.exe4.0.3.2530795,35201-Oct-200717:56x86
Obs! Microsoft Dynamics NAV-klienten installeras vanligtvis i följande katalog:
C:\Program Files\Microsoft Business Solutions-Navision\Client
Gör så här om du vill ersätta de befintliga filerna i Microsoft Dynamics NAV-installation:
  1. Avsluta Microsoft Dynamics NAV.
  2. Leta reda på Microsoft Dynamics NAV klientinstallationskatalogen.
  3. Kopiera de filer som du har hämtat.
  4. Klistra in filerna som du har hämtat i installationskatalogen för Microsoft Dynamics NAV-klienten.
  5. Klicka på Ja om du vill skriva över filer i installationskatalogen för Microsoft Dynamics NAV-klienten i dialogrutan Bekräfta ersättning av fil .

Status


Microsoft har bekräftat att detta är ett problem i Microsoft-produkterna som nämns i avsnittet "Gäller".

Mer Information


För mer information om terminologin för programuppdateringar klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
824684 beskrivning av standardterminologin som används för att beskriva Microsoft-programuppdateringar