Fel-händelse när du försöker starta Microsoft Dynamics CRM E-mail Router-tjänsten i Microsoft Dynamics CRM: "E-mail Router-tjänsten kunde inte köra tjänstens huvudbakgrundstråd"

Gäller för: Microsoft Dynamics CRM 2011Dynamics CRM 4.0

Symptom


När du försöker starta Microsoft Dynamics CRM E-mail Router-tjänsten i Microsoft Dynamics CRM har följande felhändelse loggas i programloggen:

Orsak


Det här problemet uppstår eftersom Microsoft.Crm.Tools.EmailAgent.SystemState.xml-filen är skadad.

Lösning



Det här problemet har åtgärdats i Dynamics CRM 4.0 Update Rollup 13. Finns i KB http://support.microsoft.com/kb/2308072 för mer information. Det har också tagits upp i Dynamics CRM 2011.

Om du inte är på Update Rollup 13 för att lösa det här problemet så här:
  1. Ta bort filen Microsoft.Crm.Tools.EmailAgent.SystemState.xml.


    Kommentarer
    • Som standard är filen Microsoft.Crm.Tools.EmailAgent.SystemState.xml i följande mapp:
      C:\Program Files\Microsoft CRM Email\Service
    • Standard är Service-mappen en dold mapp. Om du vill visa den här mappen måste du ändra inställningarna för Utforskaren om du vill visa dolda filer och dolda mappar.
  2. Starta om Microsoft Dynamics CRM E-mail Router-tjänsten.

    Filen Microsoft.Crm.Tools.EmailAgent.SystemState.xml återskapas.

Om Microsoft Dynamics CRM-användare ange att använda e-postrouter och inte en framåt postlåda för inkommande e-post, finns det risk för borttagna e-postmeddelanden som skickas tillbaka till Microsoft Dynamics CRM när du implementerar den här lösningen. Om inte ett e-postmeddelande har tagits bort från användarens postlåda, kunde e-postrouter hitta en användares e-post i sin inkorg, inte hitta i Microsoft Dynamics CRM och skapa e-postmeddelandet i Microsoft Dynamics CRM igen. För att undvika detta bör också e-postmeddelandet tas bort från användarens postlåda tillsammans med Microsoft Dynamics CRM.

Om du vill undvika detta regelbundet göra en säkerhetskopia av följande filer och spara dem på skrivbordet på samma server.

  • Microsoft.Crm.Tools.EmailAgent.Configuration.bin
  • Microsoft.Crm.Tools.EmailAgent.SystemState.Xml


Om Microsoft Dynamics CRM e-post Router Konfigurationshanteraren misslyckas vid start eller e-postrouter för Microsoft Dynamics CRM-tjänsten inte startar ersätta ovanstående 2 filer i C:\Program Files\Microsoft CRM Email\Service. Starta om tjänsten e-postrouter för Microsoft Dynamics CRM och sedan starta Microsoft Dynamics CRM e-post Router Konfigurationshanteraren. Om säkerhetskopiera filerna är senaste måste slutföra konfigurationen av e-postrouter.

Referenser


2012555 fel e-configuration manager kunde inte läsa konfigurationsinformation som uppstår när du startar Microsoft Dynamics CRM e-post Router Konfigurationshanteraren